Penumbra Collection on 12.1 64

Anyone successfully get this collection of games running on openSUSE 12.1 64 bit? I bought them a while ago admittedly, but I haven’t had a problem running them until now.

I get from the terminal -

kinzie@linux:~> cd '/usr/games/PenumbraCollection' 
kinzie@linux:/usr/games/PenumbraCollection> ./blackplague 
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/
(0) : fatal error C9999: *** exception during compilation ***
Cg compiler terminated due to fatal error./BlackPlague/blackplague: line 9:  7987 Segmentation fault      ./blackplague.bin "$@"
Penumbra: Black Plague exited unexpectedly, please check
/home/kproject/.frictionalgames/Penumbra/Black Plague/hpl.log
for any error messages
Also try running
ulimit -c unlimited
And re-running Penumbra and try and recreate the error
then submit the generated core file or stack trace

I’ve installed a bunch of audio packages, both 64 and 32 bit, to no avail. The official Penumbra forums are full of folks with the same problem but there’s no help or potential patch forthcoming. Is there anyone here who knows how to handle this and can help?

Many thanks.

What do you mean by this? That you installed i586 packages, or …32bit…x86_64 packages? The first option is plain wrong, it’s going to destabilize your system. The system BTW would not allow you doing so without ignoring dependencies…

A couple of things: some distros use /usr/lib for 64bit libraries. Those distros use a /usr/lib32 for 32bit libraries. Others, like openSUSE use /usr/lib64 for 64bit libs, /usr/lib/ for 32bit ones. If the Penumbra suite is 32bit, you need to install libasound2-32bit, maybe a couple of other ones.

sudo zypper in -C $(readelf -d blackplaguedemo.bin | fgrep NEEDED | sed 's/.*\\(.*\)\]/\1/'

to install all the needed libraries from the system and remove/move everything from the “lib” subdirectory but (openSUSE provides

Between, requires glibc 2.3.4 and the website says the minimum requirement is glibc 2.3.

Don’t Panic! I didn’t go around installing stuff willy nilly. Instead, I had a concerted Google around with the error message, and just installed a few things that were recommended, including the library you mention. Unfortunately, nothing has worked so far.

@RedDwarf, was that for me? I’ll try it later when I get home from work. Thanks. :slight_smile:

Indeed. As a general rule always just try to run with the system libraries instead of the included ones when trying to play closed source games.
Linux binary compatibility is not so simple and developers usually make bad decisions about how to distribute its games.

RedDwarf thankyou! Your command itself didn’t work for me, as I think it needed a little tailoring that was beyond my skills. But, buoyed by your response and general understanding of what you were saying, I removed the troublesome libs manually from the games’ lib folder and now the games run beautifully.

Many thanks indeed. :slight_smile: The openSUSE forum to my rescue yet again.