Pc is not booting

Hello ;=)

After upgrading to kernel 4.9 i saw some new warnings in dmesg : some acpi errors, according to some searches i did these errors are due to a bios update being needed for acpi tables were wrong in the Bios.
So i wanted to upgrade bios (i have a motherboard from msi : b85-g43 with v 3.9 bios, which is before the last one in 2015).

I then downloaded the last bios files from msi site, unfolded the zip and pasted the 3 files it gave me on a usb drive i had emptied just before this.
I only left what looked important (one dir called ‘volume system information’ or similar, and another file i had no clue where it was coming from, and which was certainly created by the OS) .
After rebooting i used th M-Flash utility from the MSI bios , but it said there was no bios file on the drive … That i should be at the root of the usb drive … It was like the Bios would not be able to read the files correctly (?)

I then removed the data i had left : ‘volume system information’ dir and the other file on the usb drive, so that i would be only left with the 3 bios files alone. ANd i then rebooted the pc.
After this the pc is not booting anymore.

I have a black screen with ‘A2’ written at the bottom right of the screen, and i can’t do anything.
ctrl+alt+Fn does not work, ctrl-alt-del and system request magic keys neither ( Left Alt-print screen + R /S/ E/ I/ U/ B ) .

From there what shall i do to reboot the pc ?

Thanks :wink:

Since you fool with the BIOS/UEFI then you need to take this up with the manufacturer. AFAIK this is not an OS problem but a equipment problem

I have no idea if the procedure you follow is the way to go or not. But what I miss is any thoughts about that USB mass-storage device. You “paste” files to it and remove files from and in the end let it be used by some low level utility.

When that “pasting” and removing took place in your openSUSE system, I assume that it might be partitioned and that there is some file system there.
You never explain anything about that.

Does the low level utility you use to overwrite the BIOS not have any requirements about how that USB stick should be organised?

Edit: I assume that my thoughts hint in the same direction as @gogalthorpe’s.

Can you still enter the BIOS setup?

If not, you really have a problem.

Hi :wink:

actually i did nothing on the machine, but on the usb drive.

I may have cut too much from it though, when i rebooted 1st time the m-flash utility from within the bios was not able to read the bios file.
When i cut the files out and then rebooted the pc did not boot but i don’t know why. I booted using the Del key once in a while to enter the bios.
It did not enter the bios and i’m not quite sure which state is the pc in (?)
Is the bios entering process being damaged by a usb key ? How can i be sure ?
I think i’ll try to see 1st of all if the usb drive still works, if not i’ll erase it and copy a few files to see in which state it is.
THen if/when ok i thought i could unfold again the bios files on the key and then try to reboot the pc with the usb drive plugged and using Dell to enter the Bios.
How can a usb drive stuck a machine ? Or is it the motherboard and then do i need to pull out the motherboard battery ? Can it help ?

the links i have from msi are as follows, it’s not telling a lot (that i found of ) about the usb drive partitions.

Well did you boot from the USB?? if so some function that you placed on it may have started and tried to update the UEFI (BIOS) SO first try to get into the URFI system if you can not get to the UEFI menus you have bricked the MB

It is hard to know exactly what you have done from here. But UFI/BIOS updates often come on bootable images if they are not totally Windows dependent. So even a boot to the image may start the update process. If not all is right with the image ie not all files are there it may not complete leaving a damaged UEFI (BIOS) behind. Burning a new BIOS is a tricky thing and has to be dome 100% right. It is not god that you tried to wing it.

Look, I have an ASUS motherboard here, and the DEL key at startup is the key to enter the BIOS setup.

The question remains:
Are you still able to enter the BIOS setup, or not?

Hi ;=)

I rebooted with the usb drive plugged, i did not reboot on purpose on it, but it is possible that it used it as 1st drive being read (i don’t remember the exact setting of the bios).

Del is the key i usually need to enter Bios settings, when i boot and press on Del key i have a black screen and 2 things written on it :
“Enter the menu” on the bottom left side and “A2” on the bottom right side of the screen.
I don’t know if it’s the bios or another menu, i’m not sure so far.

I’m thus not able to enter the bios as usual but there maybe some good tips/tricks that could be useful in this case , i hope so :slight_smile:

btw : i had upgraded another bios before on another MB, the process went smoothly. This time it was similar but i thing i cut out some files too quickly, i was trying to gain some time, but i was wrong.

ps : i tried the usb drive on another pc with windows 10 : it works ok, it had the 3 bios files on it, and a .Trash dir.
So it seems the key was ok but entering the bios with it plugged did something wrong (this is the process asked for to update the Bios though).

Now i erased completely the key and formated it to Ntfs, unfolded the bios files on it, and rebooted the pc with it plugged.
I press Del to enter the Bios after the reboot , i only see the black screen as before :
i have a black screen and 2 things written on it :
“Enter the menu” on the bottom left side and “A2” on the bottom right side of the screen.

Looks like you killed the BIOS you must get help from MSI to deal with this

Note actually BIOS is gone if the board is less then 5-6 years old the program that now does the job the old BIOS did is technically called UEFI :stuck_out_tongue:

The BIOS is some kind of mini-OS, looking e.g. for devices from which the PC could be booted, and triggering the loading of the bootloader.
So, if the BIOS doesn’t run, no bootloader won’t run, and therefore no operating system can ever run.
And, if the BIOS doesn’t run, you can’t make BIOS updates any longer. Period.

So don’t expect any tips, tweaks, or miracles here.

In order to get that MoBo running again you would have to replace the ROM chips on it.

It is not the USB key that is the problem - it is the BIOS.

I once made an intel MoBo unusable by making a BIOS update which I downloaded from the intel website.
Afterwards the BIOS always stopped at boot and waited for floppy drive B: (which wasn’t present).
There was no way to change this behaviour in the BIOS setup.
Looking around in the internet then I found that this was a known bug which intel never seem to have fixed, and that I wasn’t the only one with this problem.
No chance to do anything, which in that case wasn’t such a great loss because the PC was quite old already.
Otherwise I would have perhaps thought about trying to get another MoBo second hand.

Hi :wink:

Don’t you think that the fact that i cut out too much files from the usb key may have disturbed the Bios when it read th usb key ??

I tried different ways to boot the pc with only screen and 1 ram on, sometimes it gave only one entry :
“Enter the menu” on the left, sometimes nonne (black screen) instead of 2 entries : “Enter the menu” and “A2”.
I read that A2 is some error code from AMI Bios but i’m not sure if it’s due to HDD or Ram.

I’m wondering if i can use the Dos way to flash, the MB manual says i can so i’ll try this way to see if it helps to flash.

If i need to change the MB i’m wondering if i’ll keep the same one or choose another brand :
Do you know other Uefi Bioses that come with convenient solutions in these cases ? (a bios for this helping purpose maybe or a 2d “emergency” bios ?). This MSI tool to burn the bios from within the Bios seems to me tricky if anything goes wrong.
I read many tests of recent MB and it seems Asus as the best uefi bios nowadays, also Asrock looks ok with progress along the years and Bios generations. Asrock is even using the comfortable tools UEFI Bios brought : network layer from the Bios. Therefore Asrock Uefi Bios helps to update the Bios from the Bios using a usb key or the network.
Anyone who tried this network solution ?

Thanks :wink:

hi :wink:

If i unplug everyhting but the power supply, 1 ram and the screen i can reach the Efi Shell.
From there what can i do ?
Thanks :wink:

You are looking at a BIOS problem, not an openSUSE problem. You need to Google to find the specific directions for your system to recover the BIOS (often done using a USB key, or CD with the BIOS as supplied by the manufacturer). Many machines manufactured in the past 10 or so years have a problem with the BIOS suddenly going poof with no previous warning, and I have not been able to find any information about what is causing that.

However, Google will show that the internet is littered with hits on this problem, as well as the methods for recovering/reburning the BIOS.

The method using the key or CD as I mentioned above usually involves holding a specific key while turning the machine on, then releasing it at a precise condition, then waiting for the BIOS to be fully re-written and (usually) waiting a very lengthy time for the machine to reboot.

The key combination, or the method, varies by manufacturer, and sometimes even model, so you need to find the precise instructions for your specific machine.

There may or may not be posts that a jumper can be put on that will reset the UEFI to factory. Used to sometimes see this in the old BIOS systems. But this is all very very hardware specific so you must consult the MSI docs and maybe talk to MSI support. for that board.

hi :wink:

I already tried clearing cmos with the jumper, even took off the battery, it did not help. I tried booting with 1 ram did not help.
But with only the power supply, graphics card, 1 ram and screen i reached the efi shell.
The vendor support said that the fact i reach the efi shell is wrong : it means the Bios was damaged during the update process, they could not tel why, and the MB has a problem. So the MB it going bck to MSI where they’ll decide to repair or send a new one.

I read the manual of the MB in order to flash, before action, i followed it carefully.
It spoke of 2 ways : through the M-flash utility (which is from within the Bios), or through Dos ; both with a usb key with the Bios files on it in order to reflash the Bios.

1 - Usb key :
a) Is the FS of the key important : is fat32 mandatory ? (i don’t know which fs the key was using) .
b) Were the files it cut out a problem ? i’m not sure.

2 - Dos : Do you think that using Dos to flash would have been more reliable ? Is there a way to have dos without installing a dual boot ? (this is for next time as for now it’s too late : as the bios is not launched it would not run any OS, neither windows)

3- The *libre *way :
So another possibility : is there a way to run the machine from efi shell ? Using an open bios ? And maybe reaccess the bios in order to reflash it properly (i guess that MSI has some tools for this, if they do not change the chip for a new one)

Hi :wink:

MSI sent me a new motherboard, i plugged it the same way than before but the pc is still not booting.

I can see the usual boot menu with opensuse Leap 42.2 menus, but then a black screen with error messages.

I have the following error messages :

acpi errors :
[DSSP] namespace lookup failure
Method parse/execution failed

and also message about radeon :
invalid PCI ROM header signature , expecting 0xaa55, got 0xffff

What can i do from there to boot ?

Thanks :wink:

edit : my mistake, 1st boot gave me as above, but 2d seems to work, the usual desktop arrived after a long time (at the end of this post actually)

Is there something i can do about the above messages ?

Network is missing though :frowning:

Thanks :slight_smile: