Paste (CTRL-V, nor Right Mouse Btn Select of Paste/Copy) not working

I noticed that for the last several weeks, after an update in tumbleweed, I cannot copy/paste within KDE.

I disabled klipper (by exiting the app). I also confirmed that Klipper wasn’t even receiving the “Copied” text.

I tried copy/pasting from various apps. Even to the same app. (e.g.: Konsole to Konsole).

I have confirmed that this works just fine in Leap 15.0.

I have multiple keyboard layouts, but my use of the mouse’s context menu to copy/paste obviates that path.

It’s running in a VM and I confirmed the state of the shared clipboard etc, are the same in both VMs (Leap and Tumbleweed).

Please help, this is so annoying and really stopping me from doing my work.

CTL-V is the “MSWindows compatibility keystroke combination.”
It should work, but someone else posted about this not working for him also this past week.

Recommend trying the “original Linux” keystroke combo, CTL-INSERT.


Like I said in my original post, using the right click context menu doesn’t work either (Right Click, Paste).

I moved my .config, and .local directory out of the way, and it worked again for a while.

Then I started copying back in from the old config/local certain directories (nothing to do with KDE/Plasma, I did however copy back in gtk directories) and it broke again.

Edit: Klipper sees the copied item, but I just can’t paste it anywhere (with either keyboard shortcut SHIFT-CTRL-V for Konsole, or right context menu of paste in Konsole, or Kate, or any other application). It’s like Paste is disabled.

The Linux keystroke combinations should work at a lower and different level, so should generally be unaffected by any functionality like mouse button clicks in a Desktop environment.