PasswordSafe installed but doesn't run

Long-time user of PasswordSafe. Just tried to install it again after an OS re-install (openSUSE Leap 15.5 kernel 5.14.21-150500.55.68-default 64-bit). An icon for PasswordSafe has appeared but nothing happens when clicking on the icon. And I see no evidence of it having been installed (no folder for it in /etc/, for example).

PasswordSafe is not available via zypper, so I installed it from Flatpack using Discover.

Never had this happen before, so would appreciate any help. Thanks, all.

What is the terminal output when you try to run it?

flatpak run org.pwsafe.pwsafe

Thanks for your reply. This is what I got :

cacao:~ # flatpak run org.pwsafe.pwsafe
/usr/include/c++/13.2.0/bits/stl_vector.h:1125: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](size_type) [with _Tp = std::__cxx11::basic_string<wchar_t>; _Alloc = std::allocator<std::__cxx11::basic_string<wchar_t> >; reference = std::__cxx11::basic_string<wchar_t>&; size_type = long unsigned int]: Assertion '__n < this->size()' failed.

Besides the word “failed”, can you see what the problem is? Thanks for any advice!

More info – I tried again to install PasswordSafe (4 times now), paying more attention to the messages from Yast, and the problem seems to be with dependencies. The resulting installation is broken as the file integrity check fails. The last time I installed PasswordSafe was a bout a year ago and there were no problems then, so I assume that changes in openSUSE Leap have now made the program unusable until the next update.

You’re mixing different things: Flatpak, Discover, YaST.

If you want to understand what is happening, run this:

sudo flatpak uninstall passwordsafe
sudo flatpak install passwordsafe

By the way, you can also use KeePassXC from openSUSE repository.

@heitormoreira - Sorry, yes, I wasn’t very clear in my description. I “installed” the package from Discover, where it was listed as a Flatpak version (small print at the right hand side of the program listing). And I later used Yast to investigate the status of the installation. That was all.
Thanks very much for the suggested re-installation directly from Flatpak. I will try that.
Thanks for mentioning KeePassXC. I am aware of the program but all of my passwords (none are duplicates) are already in a PasswordSafe database which I would prefer to continue using (as you might imagine!).
Thanks for your help with this.

I’m not a user of Password Safe nor Secrets, but I have a feeling that if you are not in KeePass database format you’ll probably be at some point.

I’ve just created a new database with PasswordSafe/Secrets and this database just worked in KeePassXC. I can’t speak for legacy databases.

“Project ‘World/PasswordSafe’ was moved to ‘World/secrets’. Please update any links and bookmarks that may still have the old path.”

“Secrets is a password manager which makes use of the KeePass v.4 format”

Source: World / Secrets · GitLab

Thanks, @heitormoreira - I am beginning to think that KeePassXC is the new way to go. It would not accept my (old format) PasswordSafe file under any option and, since I haven’t been able to get PasswordSafe to run, I might have to start fresh with something else. Likely KeePass. Thanks again for your help.

Bruce Schneier’s PasswordSafe has served me well all these years and entering my list of passwords into a new program will be a lot of work, but I suppose that is what my retirement is for.

Didn’t you manage to install with sudo flatpak install passwordsafe?

I’ve managed to install both Password Safe and also its replacement Secrets with no problem in Leap 15.5.
You don’t need to restart from zero, you can import your data.

KeePassXC is native for Linux and KeePass is for Windows. However, both are available in Linux distributions.