Partition gone?

Yesterday, I downloaded the DVD ISO of Leap 15.2, intending to burn it into an USB stick and upgrade my a previous installation of 15.1. My HDD had the following layout:
/dev/sda1 - Windows Partition;
/dev/sda2 - First Linux partition, where / was being mounted;
/dev/sda3 - Second Linux partition, where /home was being mounted;
/dev/sda4 - Linux swap partition.

I usually prefer doing a fresh install on / after each release, since a few previous times I ran into maddening dependencies hell.

After preparing the USB stick, I booted it up and proceeded to the installation, as usual NOT deleting or formatting the partition where /home is being stored. I tried setting the installer to mount the partition under /home after install, but was surprised to notice it only allowed me to attribute it a mount-point if I formatted it - if the “don’t format the partition” option was selected, attributing it a mount point was no longer available. I didn’t care much about it at the time since I was making sure the partition was kept untouched.

Unfortunately, after booting up Leap 15.2, not only the previous /home directory was not available, any attempt to mount /dev/sda3 would result in detecting a supposedly corrupted partition. I can’t recall exactly what the partition filesystem was, but my guess is that it was either BTRFS or XFS.

Does anyone have any idea what’s going on? I did the exact same procedure a few times before and nothing of the sorts ever happened. Those times I can’t recall if the installer refused attributing a mount-point to /home, but I can’t come up with any reason why that would be troublesome now.

Any help would be greatly appreciated.


It’s hard to guess with that limited information. But if I had to guess, it would be that there was some kind of slip-of-the-finger which damaged that partition.

If you didn’t touch your partitions at all, the DVD should have probed nd found your openSUSE install and offered to upgrade it to 15.2 keeping your existing layout… Should not make any difference how your partitions were formatted.
And, the upgrade should not have prompted you to make any changes or designate partitions, your root partition, your /home, etc.
It should have just presented a summary of what the upgrade would do and then just do it.

It shouldn’t have detected any partition as corrupted or offer to format anything.

First things first…
Is your existing installation damaged?
Can you boot to your system successfully?
Or, if it can even boot to repair mode?


Warning: Read this Section Carefully Read twice. Show full output of ‘fdisk -l’. Show mount comands and full output, no editing.

As you did not upgrade, but installed fresh, the new default of having /home inside the Btrfs / partitions may clash with what you have.

Just a remark, like the others without real information like

fdisk -l 

it is difficult to know what your partitioning is. Same for

 cat /etc/fstab

to see what the system thinks about the file systems