Partition Doubts

OK, so I configured Bittorrent and it burned ok.
I got as far as install but aborted. Why?

I am currently running from Kubuntu, my HDD is partioned into four.

  1. sda1 - empty and unformatted
  2. sda3 - Kubuntu runs from here
  3. sda4 - deposit partition formatted to fat32 so I can swap with Windows if ever I re-install
  4. sda2 - gparted says ‘extended’ but it doesn’t exist as far as I know
    • sda5 - sub-partition of sda2 that has the linux swap

When I came to install OpenSUSE, sda1 and sda3 were highlighted in red as partitions ‘recommended for formatting and installation’.
But I do not want to wipe off Kubuntu just yet and from what I could understand that is what it was about to do. (I cannot remember the exact wording).

I played about with the partition editor during install but I couldn’t get it to leave sda3 alone (or at least I did not feel totally confident it would).

Any suggestions please?

P.S. I ran the LiveCD and liked what I saw.

Either from kubuntu or the live cd open a su terminal and do:

fdisk -l

post result


Ignore yast “recommendations” by switching to manual partition mode. This way, you’ll be able to tell yast what partitions to use to install the linux root fs hierarchy. It will work as far as /dev/sda1 and /dev/sda5 have enough free room to host all the packages to have chosen to install.
Note: When the time comes to install grub, don’t do it. It is better in your case, to edit menu.lst from your Kubuntu /boot/grub directory and add a new stanza to boot Open Suse. It will serve the same purpose and you won’t even touch the MBR.
To know exactly the name of the kernel and initrd file it should point to, you only have to boot Kubuntu, mount the partition where the /boot directory (that of Open Suse) is located (sda1, sda5).

And you are done.

Hope this helps.


Results of fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xf166f166

Device Boot Start End Blocks Id System
/dev/sda1 1 1216 9767488+ 83 Linux
/dev/sda2 9368 9729 2907765 5 Extended
/dev/sda3 1217 2491 10241437+ 83 Linux
/dev/sda4 2492 3715 9831780 b W95 FAT32
/dev/sda5 9368 9729 2907733+ 82 Linux swap / Solaris

Partition table entries are not in disk order

I ran the Live CD again to get the exact wording
Both the following lines are highlighted in red.

Format partition /dev/sda1 (9.32 GB) for / with ext3
Format partition /dev/sda3 (9.77 GB) for /home with ext3

I tried manual or edit partition mode but everytime I clicked ‘continue’ it just through me back to this page.

Because you have to use sda3, you can’t create any more partitions really with the setup you have.
Tough choice: Either backup and format it to a nice layout or install suse over kub*

None of the other partitions have anything on them (except swap but I have no idea what that is). If I merge sda1, 2 and 4 will I be able to install without deleting Kubuntu?

If you don’t know what swap is, how do you know what is on sda1

swap is required for a linux install but deleting sda1, sda2 and sda5 still leaves a mess and you will need to plan to implement the new swap in kubuntu. Can’t you boot kubuntu and give us a look at the Partition info in there.

I managed to install. I deleted all partitions except sda3 and it worked.
My problem now is that whatever I try to do I get an error

PID 7170 (usr/sbin/package kitd)

Any suggestions?

You need to provide more info.
Like do you get a suse boot screen?
Does it show kubu* in the menu?
What are you booting when this error happens Kubu* or suse?
When does this error happen?