Paralles Tools Will Not Install on Tumbleweed


I have recently setup a new VM using Paralles 13. Host system is a 2017 Macbook Pro, and guest system is OpenSUSE Tumbleweed. Installation was effortless and the system runs fine.

However, I cannot get Parallels Tools to install. I have seen several issues with this on the Parallels forums but no solutions.

I tried the steps suggested below, but they did not work:

Any ideas would be much appreciated!

Here is my output:

Parallels Tools 13.3.0-43321 Installer started.
2018-04-03T10:11:24-0500: Failed to setup console printk level.
2018-04-03T10:11:36-0500: execCmd: ./installer/ --check gtools [0]
Started installation of Parallels Guest Tools version ‘’
sed: can’t read /etc/SuSE-release: No such file or directory
sed: can’t read /etc/SuSE-release: No such file or directory

Tue Apr 3 10:11:45 CDT 2018
Start installation or upgrade of Guest Tools
new version of parallels tools
Installed Guest Tools were not found
Perform installation into the /usr/lib/parallels-tools directory
cat: /usr/lib/parallels-tools/kmods/…/version: No such file or directory
make: Entering directory ‘/usr/lib/parallels-tools/kmods’
cd prl_eth/pvmnet && make
make[1]: Entering directory ‘/usr/lib/parallels-tools/kmods/prl_eth/pvmnet’
make -C /lib/modules/4.15.13-1-default/build M=/usr/lib/parallels-tools/kmods/prl_eth/pvmnet
make[2]: Entering directory ‘/usr/src/linux-4.15.13-1-obj/x86_64/default’
CC [M] /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.o
LD [M] /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/prl_eth.o
Building modules, stage 2.
MODPOST 1 modules
FATAL: modpost: GPL-incompatible module prl_eth.ko uses GPL-only symbol ‘sev_enable_key’
make[5]: *** [/usr/src/linux-4.15.13-1/scripts/Makefile.modpost:95: __modpost] Error 1
make[4]: *** [/usr/src/linux-4.15.13-1/Makefile:1523: modules] Error 2
make[3]: *** [Makefile:146: sub-make] Error 2
make[2]: *** [Makefile:24: __sub-make] Error 2
make[2]: Leaving directory ‘/usr/src/linux-4.15.13-1-obj/x86_64/default’
make[1]: *** [/usr/lib/parallels-tools/kmods/prl_eth/pvmnet/Makefile.v26:11: all] Error 2
make[1]: Leaving directory ‘/usr/lib/parallels-tools/kmods/prl_eth/pvmnet’
make: *** [Makefile.kmods:34: installme] Error 2
make: Leaving directory ‘/usr/lib/parallels-tools/kmods’
Error: could not build kernel modules
Error: failed to install kernel modules
Error: failed to install Parallels Guest Tools!
Please, look at /var/log/parallels-tools-install.log file for more information.
2018-04-03T10:11:47-0500: execCmd: ./install --install [143]
2018-04-03T10:11:47-0500: Error: An error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information.
2018-04-03T10:11:55-0500: Exiting with code 1

Unless all who posted about this problem in the Parallels Forum are in error, it seems that Parallels hasn’t found a solution to the problem (first reported more than 6 mths ago as of this post).

So, no current solution for Tumbleweed.
Install LEAP 42.3 instead and you’ll probably be OK.


Thanks, I see you replied on the old thread also.
That is very disappointing to here. I have an expensive Parallels setup for testing and they cannot make their software work :’(

For what it’s worth, I tried Virtualbox with Tumbleweed and got the same error. However, installing kernel-devel and kernel-default-devel fixed it and it was able to install the guest editions just fine.