Pandora Desktop Client

Trying to get the Pandora One desktop client to install. I’ve got 11.1/KDE4.1.3. I have downloaded and installed Adobe AIR already. Downloaded the Pandora AIR file. Tried opening it through the AIR Installer program and a window flashed briefly (approximately the exact same size, appearance and position as the progress window that came up when AIR was installing - it was quite obviously AIR trying to do something). Problem is, that window showed up, as I said, briefly. It disappeared in under a second with nothing having been installed. I have uninstalled AIR, redownloaded the installer, reinstalled, redownloaded the Pandora AIR file, attempted again through the AIR installation program, attempted by just clicking on the file itself, right clicked and selected open with AIR, all with the exact same results.

Using the following article as a guide on this:

That is a bit outdated, as it appears the AIR installer is no longer beta for us. One would think this would make things easier, but apparently I’m missing something here. Any suggestions?

Did you try to install from a terminal?

An error message may give you a hint on what’s happening.

If you’re asking if I tried installing the pandora AIR client via terminal, yes… I think I did it right but not entirely certain. Turned on super user, did chmod +x file, then +x file. Error was “bash: +x: command not found”.

It’s not +x, this is not a command, just an argument to the real command which is chmod. You have to run the executable, which is the file you just made executable…

Note: when you get a “command not found” error it means the executable was looked for in the wrong (for you) path. If you are calling the executable from a directory not included in the $PATH environment variable, you have to prefix it with ./, assuming you are in the same directory as the executable. This tells bash to execute from the current directory. You can also type the full path/filename, if your executable is in another directory.

example 1 - wrong path:

bash: command not found

example 2 - right path, wrong filename:

blimmer:~> cd Downloads
blimmer:~/Downloads> ./
bash: ./ File or directory not found

example 3 - right path and filename:

blimmer:~/Downloads> ./
…program running…
…error messages, if any…
…program finishes…

Note how the error messages are different in examples 1 and 2.

Try reading about the basic concepts, linked elsewhere in this forum.

Good luck.

bruno, thanks for the responses so far. Still having trouble, but I have a different error message this time! Tried it again, used chmod +x pandora_1_0_0.air, then entered ./pandora_1_0_0.air. I was in the correct folder as well, double checked that about five times, moved the file to another folder, and tried again after moving to that folder in the terminal. The error message is as follows:

invalid file (bad magic number): Exec format error

I’m 99% certain the file has to be opened through the Adobe AIR Installer… I’ll try searching the forums for any assistance with this “bad magic number”, as well as looking for the basic concepts you mentioned (like I probably should’ve done prior to installing Linux).

Has anyone successfully installed the Pandora client that could assist, though?

I’ve installed it successfully before using openSUSE 11.1 with KDE 4. But as far as I know you have to pay for the desktop client now so I haven’t done anything with it lately. Anyways, I was excited about getting it to work so I made a how-to in the pandora vs last fm poll here:

Pandora vs. - openSUSE Forums

Take Care,


Ian, thanks for the reply - unfortunately I am still hitting the same problem. AIR install window comes up for under a second, no progress on the install is made, and the client is not installed. I also redownloaded both AIR and the Pandora AIR file (discovering in the process that there is a new version of the Pandora file), but with similar (lack of) success.

I noticed that it kept asking me for the root password when I uninstalled/reinstalled AIR, but it did nothing of the sort when trying to open the Pandora AIR file. Could this be part of the problem? I’m going to check the basic concepts to see about adding root privileges without the need for the password to my user account. If I can find that there then I’ll try again and post an update.