Packman vendor change

Fresh install of Tumbleweed and I added the packman repository via yast.

Then ran these commands:

sudo zypper dup --from packman --allow-vendor-change
[sudo] password for root: 
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
Repository 'packman' not found by its alias, number, or URI.
Use 'zypper repos' to get the list of defined repositories.

Repository ‘packman’ not found by its alias, number, or URI. is flagged in red font.

Is this an issue or just ignore? thanks

Did you try suggestion in the last line of the output?

1 Like

Yes, I did do that but I cannot interpet the table to know if the vendor change is in effect.

See screenshot:

You can use alias from the Alias column or name from the Name column. I would even give you the command if you pasted here text output as text; but that is not possible with image.

1 Like
# | Alias                            | Name                                   | Enabled | GPG Check | Refresh
1 | brave-browser                    | Brave Browser                          | Yes     | (r ) Yes  | Yes
2 |    | Main Repository (NON-OSS)              | Yes     | (r ) Yes  | Yes
3 |        | Main Repository (OSS)                  | Yes     | (r ) Yes  | Yes
4 | | Main Update Repository                 | Yes     | (r ) Yes  | Yes
5 |  | Packman Repository                     | Yes     | (r ) Yes  | Yes
6 | openSUSE-20230317-0              | openSUSE-20230317-0                    | No      | ----      | ----
7 | repo-debug                       | openSUSE-Tumbleweed-Debug              | No      | ----      | ----
8 | repo-openh264                    | Open H.264 Codec (openSUSE Tumbleweed) | Yes     | (r ) Yes  | Yes
9 | repo-source                      | openSUSE-Tumbleweed-Source             | No      | ----      | ----

So use

zypper dup --from --allow-vendor-change

Excellent, this worked! Thank you.

@arvidjaar do I need to install codecs after the vendor change or were they all installed with the command you provided?

Here is the guide I am trying to understand: SDB:Installing codecs from Packman repositories - openSUSE Wiki

You can use the Name: Packman Repository (but do not forget to quote that because of the blank space in it).

You can use the Alias: (a lousy Alias, better change that to e.g. packman, then your first trial would have worked).

You can use the number: 5 (but that can change when you add/remove repos).

And as last you can use the URI. which you do not show because you did not use an appropriate command like:

zypper lr -d
1 Like

No idea. If you showed the full command and its output, we had some information to base our guess on.

1 Like

Ok, this is what I did to change the Alias suggested by @hcvv

  1. Removed the packman repository from Yast
  2. sudo zypper addrepo -cfp 90 ‘Index of /pub/linux/misc/packman/suse/openSUSE_Tumbleweed/’ packman
  3. sudo zypper refresh
  4. sudo zypper dist-upgrade --from packman --allow-vendor-change
  5. sudo zypper install --from packman ffmpeg gstreamer-plugins-{good,bad,ugly,libav} libavcodec-full vlc-codecs

That seemed to have worked and the codecs are installed.

I hope that is correct. My goal was to add packman repository, allow vendor change, then install codecs.


You apparently misunderstand what this option does. This option applies to the single command invocation only. It does not “allow vendor change for the future” as you apparently believe. If you had installed the same packages from openSUSE, then you need this option to allow automatic replacement them with packages from Packman. If those packages were not installed, you just installed them from Packman and no --allow-vendor-change is necessary. So, either 4 or 5 was redundant.

Which is why it is impossible to answer your question “were they all installed with the command you provided” without seeing the actual output of this command - what zypper did.

1 Like

It is a bit obfuscated way to do, but that should work.

1 Like

I definitely can’t wrap my around all of this. I’m sure it is simple and I’m making it more complicated than I need to.

Ok thank you for the help.