Packman codecs breaking Opera

Hello, I just tested latest TW version of Opera/Packman from fresh install, I thought it was an issue with my bumblebee installation but it turns out to be Opera issue. I never thought codecs would break a web-browser. Any suggestions for work-around?

As long as you do not even describe what you mean with “breaking Opera” I assume that you will see only ?? above the heads of those who read this.

1 Like

Your post is very vague, with no details (i.e., “what” is broken?).

You might be better served in the dedicated forums run by Opera - they do have a dedicated “Opera for Linux” sub-forum.

Remove chromium-ffmpeg-extra 114.0.5735.198 (from packman).
It is to new for your Opera version (it is probably Opera 99.0.4788.13).
An update to Opera 100 is requested 13 days ago: Request 1099325: Submit opera - openSUSE Build Service
If Opera 100 (101) is released, re-add chromium-ffmpeg-extra 114.0.5735.198 (from packman).
Normally opera and chromium-ffmpeg-extra are in sync but not now.

Btw: Packman codecs does not break Opera. It breaks at the moment the video play function (via ffmpeg).
Opera does not deliver some codecs (e.g. Vivaldi does) and this is the reason for chromium-ffmpeg-extra.

Basically somehow all of the graphical components show up broken, as if the GPU was dying, while everything runs perfectly fine on firefox. I thought it was a botched bumblebee installation but turns out it was the codecs.

I started the thread in a hurry at work but I will follow up with more details next time I reproduce it.

Please do not load off the work on the volunteers here. Prepare your topic carefully with the idea that you should burden other people with as less fuss as possible. The result could be that people do not take you serious any more and start skipping your topics without even reading them.

1 Like

Yes, I get the point, but the idea was for me to start a thread and add more to it but I have underestimated how spontaneous/responsive this forum was, I have been away for a while.

The codec packs I install from Packman that results in “broken” opera are below. since

ffmpeg lame gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-libav libavdevice56 libavdevice58 libdvdcss2 vlc-codecs

I will check the rpm -qa to see if chromium-ffmpeg-extra was also installed. For now, I have reverted/dupped back from stock tw repo, right now I don’t need this computer to play videos but since I need to use MS teams, through web browser, I am a little bit worried about codecs.

In any case, this is what I mean by Opera broken:

All these are supposed to be graphics/texts, which do get rendered fine in firefox. Even the menu items in Opera are glitchy in such state.

Try this: create a new “regular user” account .
Log into that account.
Run Opera - does it work?

If problem persists, launch Opera from the command line … any warnings or errors?
If yes, post the complete CLI output using the </> tag (Preformatted text), in a Reply.

I think you missed my last post with a picture.

Also I’m afraid it’s just the ffmpeg installed, not chromium-ffmpeg.

How are you sure that the a codec problem breaks the graphical part of Opera?

I do not even understand your problem. But you seem to think that it is related to codecs (I do not know if it is).

About codecs, for many, many years, I only have one answer (that then in 99% of the cases solved the problem):

  1. add the Packman repo (but I get the impression you did that already)
  2. switch vendor to it, either with zypper dup --from <the number, name or alias of the Packman repo>, or using YaST > repository View > Select Packman > click right above the list on Switch system packages to ….

I ever did these two steps after an installation. I never did any of the recommended codecs installs you find on lists all over the place. I never had any problem playing sound or movies (but maybe I never tried the difficult ones). For > 10 years.

Me? No, I saw your “photographic” image of a computer screen.

THAT’S what prompted my reply, but yet, you did not answer.

My reply is what I refer to as a “troubleshooting step” - it would take all of five minutes to run that test.

I guess I should explain. It is VERY common for a [browser] user-profile file(s) to become corrupted. When that corruption happens, in many instances, the side-effect is WHAT YOU SHOW - basically, corrupted output to the screen.

I know, because, I myself have had that issue and not just with Opera, but Chrome, Firefox (though not as much), and Brave. And one of the quickest ways to troubleshoot this, if it’s a profile file corruption issue, is to create a new user account (that’s never been used before). Then log into that account, and run the affected browser for a quick test.

Why? because creating a new user account means it will have a “clean slate” of profile configuration files. Then because that new user runs the browser (Opera in this case) for the first time, the Opera profile files (found in the hidden ~/.config) are freshly created and should have no corruption.

If rendering works correctly for the new user account, then that means the corruption seen for your real user account has file corruption in the browser’s configuration subdir.

Performing any troubleshooting step has the important contribution to finding a problem. You did come out here and post a thread looking for an answer to a problem, right?

Don’t dispute (or assume) what I’ve seen or have not seen. Or maybe you’re too entrenched with the thought that this is only related to a codec issue.

Okay, a detail I neglected to mention, this is literally right after fresh install. This is already a clean slate. Not to mention we can reproduce what you suggest by temporally changing ~/.config to ~/.config_temp and then starting on Opera from the same terminal.

I get your idea of take configurations/profiles into an account but I feel like it’s not totally relevant because it is again after a fresh installation and I can reproduce/revert back from the broken state of Opera if I dup the said packages from TW repo.

I am not entrenched in the thought of this being a codec issue, in fact I had no idea codecs can cause such weird issues until I see it now.

That’s a surprise to me, maybe I should test it myself before bothering with codecs.

I currently have packman repos as “packman” from Index of /pub/linux/misc/packman/suse/openSUSE_Tumbleweed/

and very weirdly if I dup from packman, I get the image I posted, if I dup again with packman removed from repo list, I get normal Opera back.

Specifically the packages that get touched are

ffmpeg lame gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-libav libavdevice56 libavdevice58 libdvdcss2 vlc-codecs

I have had 0 cases where codec caused any internet browser issue, but I guess Opera renderer depends on something that it doesn’t like from packman repo.

I will believe you, but you know very well, that this is not the way to convince people in these forums. You either post a complete repo list (e.g. zypper lr -d) or you show the contents of the repo file (something like cat /etc/zypp/repos.d/packman.repo.
The point is that we are not so much interested in where you got it from, but what it is.

And you better SHOW that “dup from packman”, as well as what you exactly do when you say “dup again with packman removed”. You by now know very well we want to see that complete: The line with the prompt and the command, all output and the line with the new prompt.

We are really slow in understanding what exactly happens when based on story telling. But most of us are sharp when it becomes to interpreting terminal sessions and other code. And when you want help, I am afraid that you should adapt to those who offer help. :wink:

Don’t take it personally if I don’t answer right away, I have very limited time to do this at work and I don’t bring my laptop home after work and for most of the day I am booted on Windows 11/MacOS, not my choice but eventually I will spend more time in native TW. I will get back to you with the CLI log of turning Opera on from terminal probably tomorrow morning (Brussel time), but do expect me to disappear for >~9 hours after that.

It is more likely a graphics issue caused by the mesa packages from packman and not related to any codecs…

That’s what I thought from the beginning, I really did think it was from my botched installation of bumblebee (Cuda + Nvidia + bumblebee + codecs "safe" way), but in the midst of botching and fresh-install cycle (I was losing my patience after 5 re-installations), I found out that the problems occurs only after installing codecs and dupping from packman repo.

Yes, I know… You’d laugh if you knew what my current job is but I thought maybe this was a known issue that others may have bumped into and have a solution especially because I thought (wrongly) everyone on TW used codecs from packman and installed multiple browsers.

Thinking that all others do the same as you in the same way, is the main source of confusion here on the forums.