Overheating ASUS X550VC


My laptop is overheating really fast, while having multiple tabs open on firefox or running a game like Hearthstone on Wine. Just today I took the whole laptop apart, cleaned it and changed the thermal paste. Still my fan is really loud and the keyboard area (upper left quarter where the fan) is really warm. Never had issues with it while running Windows.

I had overheating problems even in Windows, but I don’t want to change back as I enjoy working around in Suse :slight_smile:

Hope someone can help me solve this issue.


From Asus site specs it could have an optimus system (intel + nvidia), so the first thing to do is check if you have the video drivers correctly installed, possibly changing to the proprietary nvidia driver - but with optimus implementation.

I would recommend updating your kernel to v4.6x.
End users will notice performance improvements in the temperature control of their laptops.
It addresses a serious bug that caused thermal throttling.

Please read https://www.linux.com/news/linus-torvalds-ships-fairly-big-linux-kernel-46-release

You can add this kernel repository to the Yast Software Repositories.


I highly recommend you install suse-prime. https://software.opensuse.org/package/suse-prime
It is a better solution than Bumblebee for switching from Intel to Nvidia.
This package allows you to use the drivers downloaded from the Nvidia site.

 nvidia-prime like package for OpenSUSE


After install please do:

  1. Add the following lines

    if -f /etc/X11/xinit/xinitrc.d/prime-offload.sh ];
    . /etc/X11/xinit/xinitrc.d/prime-offload.sh

    To /etc/X11/xdm/Xsetup after the line “. /etc/sysconfig/displaymanager”

  2. Run “prime-select nvidia” log out and login again, hopefully you are using nvidia GPU. To switch back to intel GPU run “prime-select intel” Remember to run as root.

powertop may give you a hint of what is going on. Try using bbswitch to disable the nvidia card if such one is present.

You can try to set up thermald, but it is not really plug’n’play :confused: