OSS repo isn't accessible when updating from 42.2?

When I tried to upgrade my OpenSuSE Linux Desktop Computer Leap v42.2 to v42.3, the upgrade process complained at the end (97%) that the http://download.opensuse.org/distribution/leap/42.3/repo/oss/content is not accessible. Right now, I had left my computer for more than 30 minutes and the upgrade process kept trying to no avail. Has anyone encountered such a problem and can offer a solution?

FYI, when I tried to use wget http://download.opensuse.org/distribution/leap/42.3/repo/oss/content, it failed at the 1st attempt and continued to download at the 2nd attempt sans a problem as shown below.

[habibie@linux-rf8f:/home/local/PEOPLE/habibie 6%] ~ wget http://download.opensuse.org/distribution/leap/42.3/repo/oss/content
--2017-09-06 10:54:57--  http://download.opensuse.org/distribution/leap/42.3/repo/oss/content
Resolving download.opensuse.org (download.opensuse.org)...
Connecting to download.opensuse.org (download.opensuse.org)||:80... failed: Connection timed out.

--2017-09-06 10:57:05--  (try: 2)  http://download.opensuse.org/distribution/leap/42.3/repo/oss/content
Connecting to download.opensuse.org (download.opensuse.org)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 15808 (15K) [application/octet-stream]
Saving to: ‘content’

100%==========================================================================================>] 15,808      --.-K/s   in 0.07s    

2017-09-06 10:57:40 (211 KB/s) - ‘content’ saved [15808/15808]  

[habibie@linux-rf8f:/home/local/PEOPLE/habibie 7%] ~

I’d leave it for a while.

download.opensuse.org suffered a “Major Outage”, see:


See here: https://forums.opensuse.org/showthread.php/526955?p=2836945#post2836945