OS 13.1: How to limit OS updates to a certain date to avoid faulty updates ?

Hi there,

after my PC and my wifes notebook became unusable due to faulty updates sometime in Jan or Feb 2016, I tried to reinstall the entire OS 13.1 again. During the installation all partitions got re-formatted to have a clean installation. My only manual interference was to define the size of the root partition (30GB), the defintion of the /home partition to 190GB, and a 10GB Swap, all on the same SSD. The remaining installation process was fully automatic and I did not add any further software. So only an automatic clean pure standard installation, which works well and results in a fast booting functional system, but …

After meanwhile 4 installations of OS 13.1 4 and different approaches to update the OS, I ran into the following problems:

  1. All published updates installed: I end up with a system that cannot start the KDE or X-windows system - unusable.

  2. Only updates which exclude updates where the year 2016 is mentioned in the title: The system’s boot time is dramatically reduced (Pressing ALT F1 during boot I could see that Network Manager needs around 27 seconds) plus 5 seconds = 32 seconds total boot time on a SSD.

Thus I would like to fine tune the updates by restricting/filtering the updates up to certain date. For some updates this is possible as the year is part of the update name, but for others this is not the case.

I now would like to know whether there is another way to restrict updates date dependend, so that I could find out at which date the disimproving update for Network Manager got published. That may also help toidentify the problem in that update.

Any suggestions how to restrict/filter the updates ?

TIA, Joe

(Yes, I even tried Leap 42.1 on both machiens, but after 3 installations on the notebook and one on my PC I was still not able to get the needed functionality back that had on OS 13.1 before. Thus I want to go back to OS 13.1 and wait a year unti Leap has reached a similar level like OS13.1 . )

Ok I tested what was suggested in after-recient-updates-long-dely-starting-Network-Manager and it worked for the installation where I could exclude certain 2016 updates.
Boot time is down to 5 seconds. So if there is no impact on other funcionality … I have a usable system again rotfl!

But I still would like to restrict updates by date. Just in case the above “patch” should have any other negative side effects…


Uncheck the box for “software updates” in System Tray Settings. Then do updates manually using Yast online updates and “zypper up” at the command line.

Note you seem unique in this problem so all details should be reported on bugzilla if you want them fixed. notably which updates seem to be the problem.

Thanks for your answer … but System Tray Settings ? Where can I find it ??? It’s not in Yast, right ?

Manually , do you mean file by file ? How would this prohibit update files from 2016 to spoil my system ? More details please !


Well, this is one of my options indeed. Meanwhile I have installed windows 7 again on my wifes notebook. She is a jurist and needs to work.

Now only my PC is left for playing around. I will now try Ubuntu and afterwards Debian to see whether its a general problem of Linux or a specific one of OpenSuse.


Right-Click on an empty space in the system tray and choose “System Tray Settings”. The easiest way is probably the small up arrow just left of the digital clock though.

But as you use 13.1, you are probably using KDE4 and Apper. Apper has a background service that checks for and reports updates too.
You can disable that in “Configure Desktop”->“Startup and Shutdown”->“Service Management”.

Manually , do you mean file by file ? How would this prohibit update files from 2016 to spoil my system ? More details please !

You can enable/disable certain updates in YaST->Online Update. OTOH, you can do the same in Apper too.
“zypper up” will install all updates.

But you can “lock” specific updates in YaST->Online Updates, by right-clicking on them in the list on the left. They should then also not be shown any more in the update applet.

In the end, the best thing would be to find out which update is “faulty”, and report it.
There seems to be a problem with the wpa-supplicant update:
If you use a wireless connection, this is likely the culprit in your case too.

PS: in case you didn’t know, you can revert specific updates by using the “Versions” tab in YaST.


I answered that as if it were for 42.1. With 13.1, you also have to turn of Apper, as Wolfi has pointed out. Thanks for the correction.