OS 11.2 won't boot.

After upgrading from 11.2 RC2 to GM the only why it boots is to leave the dvd in and the tell it to boot to HHD.
What have I done wrong?


When you boot without the dvd in the drive, do you get GRUB errors? Any errors?

I’m guessing its a GRUB problem. First thing I would do is boot to your installed system and reinstall GRUB through YAST -> Bootloader.

Also the BIOS settings may be the reason. Set the corresponding hard drive to be the first or second (after DVD) bootable device.

Switch the power off, fully. At the next reboot, verify that the setting is kept the same.

No errors that I could see. At the time it’s supposed to boot to the Suse login screen all it says is
“No operating system”.

From what I could figure out it is all ok. Still a no go.

Looks like the boot loader has not been installed.

Once you are booted into openSUSE, reinstall it. I know it is possible to do with a command like

grub-install /dev/sdb

And Yast also can reinstall the boot loader.

I agree on that. If you are not enough experienced to feel comfortable with the commandline, you should use YAST- Hardware - Bootloader. On the bottom right of the window that appears, you should see a button “Other” or something like that (I have no english system-language on my openSUSE). Choose from the options: new configuration.
If even that fails, then you should use your DVD: there is the option to reinstall grub, somewhere in the repair installation menu.

I tried doing it in
Yast and from the DVD repair. Still no boot, Only get message
“Error! No operating system”


If you leave the DVD out, do you get a grub screen at all? If that’s a yes, can you press the escape key and get access to the grub pronmpt (the ‘c’ or ‘e’ key I think)?

Thats a No get Grub.

You could try a manual grub install…


OK, I see you can boot to openSUSE. Let’s test a few things:
Can you open a console/terminal and su to root and then enter grub and get the Grub prompt (grub >). If that’s a yes, what does this give at the grub prompt:

find /boot/grub/menu.lst

GNU GRUB version 0.97 (640K lower / 3072K upper memory)

Minimal BASH-like line editing is supported. For the first word, TAB
lists possible command completions. Anywhere else TAB lists the possible
completions of a device/filename. ]

grub> find /boot/grub/menu.lst


That’s interesting, some of it’s working. Can you now post these three and maybe the problem will be seen:

  • sudo cat /boot/grub/menu.lst
  • sudo /sbin/fdisk -l
  • sudo cat /boot/grub/device.map

danorske@linux-amhc:~> sudo cat /boot/grub/menu.lst

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.        
#3) With great power comes great responsibility.

root’s password:

Modified by YaST2. Last modification on Mon Nov 16 03:10:26 CST 2009


Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd1,1)/boot/message

###Don’t change this comment - YaST2 identifier: Original name: linux###
root (hd1,1)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-WDC_WD1001FALS-40U9B0_WD-WMATV3644270-part2 repair=1 resume=/dev/disk/by-id/ata-WDC_WD1001FALS-40U9B0_WD-WMATV3644270-part1 splash=silent quiet showopts vga=0x31a
initrd /boot/initrd

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – SUSE LINUX
root (hd1,1)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-WDC_WD1001FALS-40U9B0_WD-WMATV3644270-part2 showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
initrd /boot/initrd

danorske@linux-amhc:~> sudo /sbin/fdisk -l

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x14ab14aa

Device Boot Start End Blocks Id System
/dev/sda2 * 2 24321 195350400 f W95 Ext’d (LBA)
/dev/sda5 2 10368 83272896 b W95 FAT32
/dev/sda6 10369 24321 112077441 b W95 FAT32

Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000b5049

Device Boot Start End Blocks Id System
/dev/sdc1 1 262 2104483+ 82 Linux swap / Solaris
/dev/sdc2 * 263 2873 20972857+ 83 Linux
/dev/sdc3 2874 121601 953682660 83 Linux

danorske@linux-amhc:~> sudo cat /boot/grub/device.map
(hd0) /dev/disk/by-id/ata-WDC_WD2000JB-00FUA0_WD-WMAEP1354473
(hd2) /dev/disk/by-id/usb-Seagate_FreeAgentDesktop_9QM21RC2-0:0
(hd1) /dev/disk/by-id/ata-WDC_WD1001FALS-40U9B0_WD-WMATV3644270

I’m looking for inconsistencies:

fdisk shows Linux on sdc
menu.lst shows the root of Linux to be partition 2 of (hd1) with drive ID ending in WMATV3644270
device.map shows (hd1) with a drive ID ending in WD-WMATV3644270
That looks OK

device.map shows three dives including the external freeagent drive but fdisk shows only two drives.
Might be a problem there.

It does show (hd0) as the drive ending in WD-WMAEP1354473 which is consistent because that ending according to fdisk belongs to sda (I think).

Let’s test whether we can see (hd1) using Grub and then maybe map it to the MBR of drive (hd0)

Try this: open a console and enter su to become root. Then enter grub to get the grub shell: grub>

Then enter this: root (hd1,1)
You should get like this:

 Filesystem type is ext2fs, partition type 0x83

What happens?

Got this.
grub> root (hd1,1)
Filesystem type is ext2fs, partition type 0x83


That’s good, maybe it will work to go further.

The next step would be to try installing Grub to sda1 after declaring root to be at (hd1,1). So get yourself to this position:

grub> root (hd1,1)
 Filesystem type is ext2fs, partition type 0x83

and then enter this command at the ‘grub>’ prompt:

setup (hd0)

Then ‘quit’ grub and reboot without the DVD in the drive. Cross your fingers.

I reboot, gets to loading grub stage 1.5 then get "HD1,1/Boot/message/ Boot not found. something like that. then goes to next screen:
thats like the suse boot screen but its black and white.offers a choice of what to start. I choose Suse 11.2…
A screen comes up that offers to e for edit b for boot and a couple of other choices. I highlight (hd1,1) hit the e key to edit and change from hd1,1 to hd0,1 the hit b to boot and here I am on Suse 11.2.

But it doesn’t stick the next time I have to go through it again.
Should I do a setup (hd1) instead?

It won’t hurt to do ‘setup (hd1)’ and it might work, so sure, try it. If that doesn’t improve things then I have three entries for you to try in menu.lst, one of which really should work.