Optirun cant run eclipse (nVidia card only mode)


I have Lenovo Yoga 500-14IHW with 2 graphic cards, one is the iGPU from Intel, the other is nVidia 920M. I installed the drivers and bumblebee from a custom repo, and it works as intended for all my selected apps by running them via optirun command (using ONLY the nVidia GPU), except for Eclipse (Developer Studio for WSO2 ESB). When I try to run the usual way:

optirun ./eclipse

it throws the following error:


The log is here. It worked, running it the same way, in Fedora 24.

BTW: I got the latest Oracle Java installed (and correctly configured in alternatives)

Have you tried using primusrun instead of optirun?

primusrun ./eclipse

And, have you tried running eclipse without specifying the GPU?


Yes, primusrun throws the same error. Running it without optirun or primusrun (just eclipse) works just fine, but the app is quite slow for me.

Is it some similar to http://askubuntu.com/questions/513471/kubuntu-14-04eclipse-adt-crashes-at-button-ok-from-project-properties/530468#530468 they instructed us to change in /usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc the value GtkComboBox::appears-as-list from 1 to 0.

Or any of /usr/share/themes/anywindowhandler/gtk-2.0/gtkrc , maybe all

One possibility,
According to Arch Bumblebee, there can be a problem supporting compositing Window Managers, ie the ability to support hardware acceleration and display advanced graphics like 3D

You didn’t state what Desktop you installed, in general KDE by default enables and tries to utilize these types of features.
You can try turning off those features or try a different Window Manager or maybe even run a completely different Desktop (like MinimalX, LXDE or XFCE).

If you’d like to try different Window Managers, choose from the dropdown using the Yast sysconfig editor module and logout or reboot,
YAST > System > /etc/sysconfig editor > Desktop > Window manager > DEFAULT_WM

In any case, this is just a guess but I also don’t see any troubleshooting methods that can pin down this kind of problem, articles just say “slow performance.”


Changing it did not help, nor did changing to a different theme (default as well).

I have got GNOME 3.16.2 installed, is there a way to install a newest one on Leap 42.1?

Somebody knows this better. Is it some microcode issue? Is it haswell cpu that needs top-of-the-line kernel?

I do not know that, is it possible? It does not seem probable to me.

Does eclipse crash as often with and without optimus?

My problem is, eclipse does not start with optimus at all. It just throws this error, and thats it. However, running it the usual way (withouat any of these things, using iGPU) it does not crash at all.

What version number of nVidia driver?
Any information in dmesg? You can run dmesg -w to see any changes ‘live’.

The suggestions I made are related to <restricting> the Desktop use of graphical features, and aren’t likely going to be addressed by installing a newer Gnome Desktop (which if anything may try to implement even more graphical features).