Opera not working any more

I just updated Tumbleweed to version 20210920 (zypper dup brought up 3217 new packages). So far everything worked fine except the web browser Opera (opera-78.0.4093.184-1.12.x86_64) It only comes up with “page crashed”. When I opern opera from command line I get the following:

uli@linux-4skc:~> opera 
[25283:25283:0923/141333.130933:ERROR:broker_posix.cc(43)] Invalid node channel message 
uli@linux-4skc:~> [25282:25282:0100/000000.283412:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu
[25282:25282:0100/000000.283815:ERROR:broker_posix.cc(43)] Invalid node channel message

Again the only thing visible is the message “Page crashed” again. I normally used several different web browsers parallel and Opera was one of them and I would like to use it again. It seems Opera now opens in a sandbox but cannot initiate the sandbox. Any idea anyone?

1 Like

More than likely the glibc update and rebuild…

I have problems with Waterfox (Firefox clone) crashing on every page I try to open even internal stuff like passwords! Only happened after today’s update. Chromium works OK hence this update. Firefox V92 also works. First message is

###!!! [Parent][MessageChannel] Error: (msgtype=0x21006F,name=PBrowser::Msg_UpdateDimensions) Channel error: cannot send/recv


I just downloaded the latest version and installed it and now it is working! So maybe not the same error.


Today Opera 79.0.4143.22-1.2.x86_64 is out and now it is working again.

Running Opera 80.0.4170.16-1.1 on a desktop Tumbleweed install

Back in September, I had problems with the browser, too - pages crashing. Not every page: just pages playing a lot of media: YouTube, twitter, the Guardian’s site. I imagined that I was a codec - html5? - short, and a fix would in due course appear

Unfortunately, after installing the latest update (see above) my opera problem has got worse: the ap now won’t open at all

If I try to open it from a terminal, I get:

azed@linux-qnar:~> opera
/usr/lib64/opera/opera: symbol lookup error: /usr/lib64/opera/opera: undefined symbol: av_stream_get_first_dts 

google-ing the error message above got me to this Opera forum:


From what i can make out from the posts thereat, the page-crashing was caused by an outmoded version of libffmepg.so. The forum suggests sourcing the codecs from here:


The recommended package is the version of libffmpeg.so in opera-beta-ffmpeg-codecs-94.0.4606.54-2-x86_64.pkg.tar.zst

Have not tried this

The forum also suggests that the failure of Opera to open at all (my present problem) may be due to an incompatibility between libffmpeg.so and glib6

I quote (the 4th post):

[Commenting on the suggested codecs] Additionally you should know, that every time the Opera will be updated to the next major version (or it will be based on a significantly higher version of Chromium), you will have to update the lib accordingly. In other case, the lib may be not working in the Opera or even may cause crash of the browser.The same goes for the glibc version, if your OS will use a lower version than the one with which the FFMPEG will be compiled, it will not work and will cause the browser to not launch at all.

My version of glib6 is 2.34-2.1

How to proceed?

Is a fix for all this in hand?

Anybody else having problems with Opera?

I am also running Opera 80.0.4170.16-1.1 on a Manjaro xfce laptop install - works fine (albeit with glib6 2.33.5)

Er, what’s going on, dude?[/FONT]



This is a part of TW UX.

I did try “this”, and it worked, Opera is working again. From my notes:

 - Opera H264    - https://www.reddit.com/r/operabrowser/wiki/opera/linux_libffmpeg_config
    - It suggests using Arch Linux herecura repo
    - Look in https://repo.herecura.eu/herecura/x86_64/ for the opera-beta-ffmpeg-codecs and opera-developer-ffmpeg-  codecs files.
    - Download opera-beta-ffmpeg-codecs-94.0.4606.54-1-x86_64.pkg.tar.zst
    - extract usr/lib/opera-beta/lib_extra/libffmpeg.so
    - install the so in /usr/lib64/opera/lib_extra/
    - google an h264 test page and check in opera

This would be a couple of weeks ago (at least).

Thanks mchnz, I did this:

Downloaded opera-beta-81.0.4196.11-1-x86_64.pkg.tar.zst from https://repo.herecura.eu/herecura/x86_64/

I actually did this a couple of days ago. It was a bit of a mistake - downloaded the whole of opera

Working on the assumption that the hecuba version of opera-beta-81.0.4196.11-1 was packaged with the codecs you suggest, I extracted the libffmpeg.so file to /home/azed/Downloads/CodecsOpera80/opera-beta-81.0.4196.11-1-x86_64.pkg/usr/lib/opera-beta/libffmpeg.so

Then did:

azed@linux-qnar:~> ls -l /usr/lib64/opera/lib_extra
total 4
lrwxrwxrwx 1 root root 40 Apr  6  2020 libffmpeg.so -> ../../chromium-ffmpeg-extra/libffmpeg.so

Thus the libffmepg.so-file in /usr/lib64/opera/lib_extra symlinks to /usr/lib64/chromium-ffmpeg-extra/libffmpeg.so

Moved the chromium-ffmpeg-extra libffmpeg.so-file out of the way with:

azed@linux-qnar:~> sudo mv /usr/lib64/chromium-ffmpeg-extra/libffmpeg.so /usr/lib64/chromium-ffmpeg-extra/lib

Then copied the extracted download to [FONT=monospace]/usr/lib64/chromium-ffmpeg-extra

[FONT=monospace]sudo cp /home/azed/Downloads/CodecsOpera80/opera-beta-81.0.4196.11-1-x86_64.pkg/usr/lib/op
era-beta/libffmpeg.so /usr/lib64/chromium-ffmpeg-extra/libffmeg.so[/FONT]


Checked permissions:

azed@linux-qnar:~> ls -l /usr/lib64/chromium-ffmpeg-extra
total 5028
-rwxr-xr-x 1 root root 1868096 Oct 22 20:30 libffmeg.so
-rw-r--r-- 1 root root 3272888 Apr  6  2020 libffmeg.so.OLD

Not the same, but close enough

What can I say? Opera opened as required. Headed off to https://html5test.com
I got a score of 524/555 c.f. 512/555 for firefox

Everything seems to be working OK. The problem definitely seems to have been an out-of-date libffmeg.so file

Thanks again

Oh, and thanks also to Svyatko for taking the trouble to reply (although I didn’t use your idea)

Typo in one of my commands, immediately above, and what follows:

sudo cp /home/azed/Downloads/CodecsOpera80/opera-beta-81.0.4196.11-1-x86_64.pkg/usr/lib/op
era-beta/libffmpeg.so /usr/lib64/chromium-ffmpeg-extra/libffmeg.so

Wtf is libffmeg?

Query: why did this work?

It’s a library for decoding H264 videos. It’s proprietary in some respect, so the opera folk don’t think they can ship it. But the workaround is to sym-link opera to chromium’s version (for some reason the chromium folk are OK with shipping it). But opera moved up to a newer (still unshipped) version and chromium on OpenSUSE hasn’t caught up. So yet another hack is to extract the required newer library from some other distro that has caught up.