OpenSuse13.1+GoogleChrom+RemoteDesktop from GoogleChrome = ?

Opensuse13.1(i386) with KDE ( default installation ).

  1. From the FireFox download and install Google Chrome
  2. launch Google Chrome and in the Google Chrome add “Chrome-Remote-Desktop”.

problem - can not add my Linux in to the “Chrome-Remote-Desktop”…

Any body use this configuration ?
Any problems when configure ?


I’m also trying to get it working:

alien -r --scripts packagename.deb
  • install the rpm;
  • open the Chrome Remote Desktop app;
  • authorize pc/account;
  • click the “Share” button and a PIN will be displayed;

But i can’t find any PC when i open the android app (or the web app from another PC).

I too have this problem - anyone get this to work? opened ports tcp: 443 udp: 5222 as instructed for Ubuntu and nada

I managed to get Chrome Remote Desktop to work, but only after a lot of head banging. I converted the package with alien and installed it using zypper. That of course was not enough. I looked in various places (this post about Fedora among them) and here is what I did:

  • I created a file in my home directory called ~/.chrome-remote-desktop-session
    with a command to start the remote session. I use IceWM, so this is how my file looks like:
exec /usr/bin/icewm-session
  • I created the group “chrome-remote-desktop” and added my user account to it.
  • Now the service was able to start, and I was able to activate remote access from the Chrome browser app, but if I tried to connect from another machine with my PIN, I got an “invalid PIN” error every time. I managed to find where the Chrome Remote Desktop log file is written by starting the program manually (/opt/google/chrome-remote-desktop/chrome-remote-desktop --start
    ) and looking at the output. It turns out there was some problem with PAM and I needed a new configuration. The PAM configuration file for CRD is at /etc/pam.d/chrome-remote-desktop . After some unsuccessful attempts, I found the following configuration here:
auth required
account required
password required
session required
session optional

I put this in the PAM config file, restarted the daemon, and it finally worked!

And so I got it to work and now I can connect to the OpenSUSE PC from my Windows machine. I hope this helps some of you.

is chrome remote desktop still working on your open suse box?
Any chance you tried on tumbleweed?

Such a shame google doesn’t provide rpm’s.

Cheers :slight_smile:

Congrats on getting it working.
I took a brief look at it and as you probably found, its base code had Debian package dependencies and unclear whether comparable rpm packages would work. Your solution using alien seems to have at least partially addressed that.

But then,
I also determined the code hasn’t been updated since… 2013?
So, it seems that this interesting project has been unmaintained and is likely dead, you have what exists and it’s unlikely there will be any further modification.

And all of which likely explains why it’s not available as an openSUSE package.