Opensuse12.3 with LXDE desktop

I have installed the OS twice; updated my repositories for the 12.3 version; made repeated sweeps with my updating script. But I still cannot get a video picture with totem, mplayer or Vlc. The missing codecs are reported as “MPEG-4 AAC decoder and H.264 decoder”. While other OSs seem to have a solution, I haven’t found one for Opensuse12.3 (The ymp one-click installer didn’t seem to have it either.) My opensuse12.2 version works so I think the problem is one of availability not source or mode of installation.

There have been no direct references on the forum to this problem, so what am I doing wrong?

John Ker

Have you followed ?

Thank you very much for your help.
I have tried the VLC , KDE and Gnome one-click installations none of which worked. However, navigating your link showed there may be more problems with my set-up than I first thought. In fact 12.3 may have gone beyond the specifications of my computer. I intend to reinstall 12.2 and install 12.3 LXDE on my laptop instead of Gnome.
Thanks again.
John Ker