OpenSUSE12.1 kdm login not working after joining domain.

OpenSUSE 12.1 default KDE install in virtualbox.
I use YaST to join my Windows Domain, YaST installs winbind and kerberos.
I restart and am presented with an error: Theme not usable with autentication method ‘Winbind/Samba’.
Then I am shown the login screen which has a login dialog in the top left corner of the screen as well as the main login dialog in the center. I cannot enter data in either.

I was able to drop to console, enter YaST, and change the login manager from kdm to wdm and reboot.
I was then able to login with either my local or domain credentials. Has anyone had this issue with kdm?

Thank you,

On second thought I think the login screen I initially used was just an Xlogin screen. I subsequently installed gdm and set it as my login manager and it works. I’ll just stick with gdm until I can find a fix for kdm.

Thank you,

Hi,

I’m having exactly the same issue (and a variant of it with the GNOME install as well, where entering the username+password and clicking Login then does nothing, but allows you to Cancel).

How do you go about dropping to the console, entering YaST, etc… and have you found a long-term fix (for kdm) yet?

Thanks!

Thanks, that worked!

For completeness’ sake: I updated DISPLAYMANAGER_KDM_THEME as indicated, set the hostname to a desired value in YaST -> Network Settings, assigned a static IP address to the Linux machine from the Windows Active Directory domain controller/DNS server, rebooted the Linux machine, and finally configured YaST -> Windows Domain Membership. However, I get an error message after (successfully?) joining the domain, while the Samba configuration was being saved:

“Error: Cannot start winbind daemon.”

Acknowledged that error, rebooted the machine, and everything worked fine. I could log in using a domain account and so on. The only other complaint I have is that my domain shows up twice in the list on the login screen. (I just used the first one and had no trouble.)

Turns out, this particular step does not seem to be required. (It makes sense for servers, but it’s not necessary for desktops.) Please correct me if I’m wrong?

On 2012-04-27 02:06, LarsKemmann wrote:

> Turns out, this particular step does not seem to be required. (It
> makes sense for servers, but it’s not necessary for desktops.) Please
> correct me if I’m wrong?

AFAIK, you are right.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)