OpenSUSE won't start on T420s

These are the exact steps I did:

  • Download openSUSE-Tumbleweed-KDE-Live-x86_64-Snapshot20170516-Media.iso and make USB with imageusb because rufus doesn’t work with OpenSUSE
  • Boot from USB on T420s, connect ethernet cable, create new partition table (GPT) to completely delete Ubuntu, start installer
  • Accept all default settings and recommended partition layout (BtrFS root), execute installation
  • Reboot and remove USB

After restarting the computer, it stays on the boot device selection menu as if no operating system is installed.

I load default BIOS settings and tried again, same thing.

Then I reinstalled OpenSUSE again, still same problem.

I’ve never encountered problems like this with any other distribution of Linux.

Did you follow this guide?
https://en.opensuse.org/SDB:Live_USB_stick

No I used this https://en.opensuse.org/SDB:Create_a_Live_USB_stick_using_Windows

A Secure Boot issue perhaps? Check the UEFI settings.

I looked and didn’t find a Secure Boot setting. The only relevant settings are UEFI/Legacy Boot - UEFI ONLY and Boot Mode - Quick. I googled the issue, and the only suggestion was to Load Setup Defaults, which I’ve already tried.

Also:

Ubuntu, Fedora, Red Hat Enterprise Linux, and openSUSE currently support Secure Boot, and will work without any tweaks on modern hardware. There may be others, but these are the ones we’re aware of. Some Linux distributions are philosophically opposed to applying to be signed by Microsoft.

https://www.howtogeek.com/116569/htg-explains-how-windows-8s-secure-boot-feature-works-what-it-means-for-linux/

You may need to wait for others more familiar with EFI/Secure Boot to advise further. While waiting see if using Legacy Boot succeeds.

  1. you must boot the installer in EFI mode if installing is to be EFI boot
  2. The page you reference outline 4 different methods which one did you try??
  3. On some machines you must have secure boot off during install. Exactly what is the hardware there should be a secure boot setting in the UEFI/BIOS
  4. for EFI boot you must create or use an existing EFI boot partition. Small FAT file system should mount at /boot/efi. Should be default if not something is not right maybe booting in legacy mode
  5. you should not see a UEFI boot device menu unless you invoke it

Did you wipe your disk completely (remove all partitions) before installing?
I’m guessing that you left something, perhaps a boot partition from your prior installs.
When you do an openSUSE install, it will first probe for existing OS (In your case will not find any) and then it will propose installing the entire openSUSE system in whatever free space you have available… But this can work only if your disk is <completely> wiped which I suspect you didn’t do.

Note that for step 4 in gogalthorp’s steps in the above post, to use an existing boot partition but no OS exists, you’d probably have to not accept the default layout, you’d have to “Edit” the proposed layout and modify the proposal to point to the existing boot partition to re-use it.

TSU