OpenSUSE TW won't boot without the "dis_ucode_ldr" parameter


I’ve been trying to get openSUSE TW up and running on my ASUS Laptop N552V for almost 2 months now. Here are my specs: CPU i7 6700HQ, Nvidia Geforce 960M, 4k Screen, 16GB RAM, 512GB SSD, and 2TB HDD. I’m switching from Windows, so I’m a bit of a newbie in the Linux environment.

I managed to fix the issue where my PC couldn’t sleep and correctly resume by using the following kernel boot parameters: “init_on_alloc=0 intel_iommu=off pci=nommconf”.

However, the main problem I’m facing now is that openSUSE TW won’t boot without the “dis_ucode_ldr” kernel boot parameter.

I removed the “quiet” boot kernel parameter to get error output, but unfortunately, nothing shows up; the boot process stops very early. Even on a fresh install with default open-source drivers, I’m facing the same issue. So, it doesn’t seem to be related to the Nvidia drivers.

In fact, openSUSE boots without any issues the first time because the Intel microcode isn’t installed. But once it’s installed, the boot process hangs.

I’ve tried several rolling distros that use version 6 kernels, they all present the same problem. Only kernel 6.1.x seems to work with Intel-ucode. Unfortunately, there’s no LTS version available for openSUSE TW.

openSUSE Leap (kernel v. 5.x) works fine even when installing ucode. So, I thought the issue might be with the ucode for TW. I tried copying the microcode file (06-5e-03) from Leap and replacing the one in TW, following successfully all the necessary steps to install it manually, but the boot process continues to hang with no output.

Microcode code for i7 6700HQ is not updated anymore, the latest version is microcode-20220510.

It’s possible that something broke with kernel versions above 6.1.

I’d appreciate any guidance on how to resolve this issue.

Thank you.

Open bug report,, same user/password as here.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.