OpenSuse TW on a Chromebook

I know you can install Debian and Ubuntu on a Chromebook. I know how to do that - just follow the instructions, but I want to install TW on my Chromebook. How do I do that? Is there an instruction (I couldn’t find one).

I think you can install ventoy on your pendrive and set the opensuse iso and you can boot on ventoy and select the iso to install i maked this and worked to me

When that device can boot from a pen drive with a bootable ISO file system, then it is not different from any other computer discussed here.

(BTW, you do of course not need such an exotic tool as ventoy to copy an openSUSE installation ISO file to a pen drive.)

@zerkovic Hi, what CPU is in the Chromebook, Intel/ARM?

Acer Chromebook Spin 713 CP713-2W-36YN

@zerkovic OK, that’s a 10th Generation Intel device.

This thread may help… https://forums.opensuse.org/t/opensuse-for-intel-chromebooks/106793/8

Btw … I think I wasn’t very clear in my question, it’s about the regular way for a Chromebook, i.e. enabling Linux in Linux development environment. It the enables Debiab, but I like to enable OpenSuse TW, because I love TW way more than Debian. :smiley:

Tx, I will have a look!

Oh yes, I remeber those times … I owned the 720 :wink: But I don’t want to install TW in stead of ChromeOS. but in the container. And I seem to remember there are iamges or Iso that can be used …

Once again: DO NOT USE VENTOY. The reasons are already in some other threads.

The reason ventoy is used is since rufus is only on windows (to my knowledge) and people really like easy solutions, so if openSUSE were to create a tool similar to ventoy but like, without that thing in it, I would switch over in less than a heartbeat. But it would need to be as encompassing as ventoy is otherwise it would not hold an advantage.

There’s Balena Etcher which does the job fine. And I am not going to debate the clear statement some very knowledged devs made re. Ventoy: They will not accept bugs if the install was done from a Ventoy USB. I’d rather trust their judgement, than that of someone posting “Opinion 100”.

2 Likes

4 things,
A. I was TRYING to be funny, and as I usually do, i failed miserably.
B. I tried Balena Etcher , and it gave me all sorts of problems.
C. I dont think Beluga Ether does that multi iso thing anyway
D. When i tried a “normal” usb install it was throwing all sorts of errors at me, ventoy fixed that (idk why, but it did)

AUTOCOMPLETE IS SO SMART AUUUGHHH

Ps. I am doing my best not to dispute the devs here, but maybe a workaround for ventoy installations would help? Or is that just a dumb idea?

I use cp (copy command) to copy the iso direct to the device (not to partitions) this is supper simple and you don’t have to navigate fancy GUI interfaces. If you can’t do that you probably should not be installing any OS including Windows

2 Likes

What I ment was something like this:
Fedora install

I suppose it has to do with this: linux images

None of that is needed for openSUSE or TW just copy the the iso to the dev

1 Like

*block device

balena Etcher is the only modern tool that works consistently for me on Windows. Fedora Media Writer and Rufus had me fail LiveUSB media checks more than a few times. A few other random tools couldn’t lock the USB device or something.