openSUSE Tumbleweed on Dell Latitude 10 ST2E

I have a project. I want a GENUINE Linux tablet and I want it to run openSUSE. I took a chance and I picked up a Dell Latitude 10 ST2E on eBay for about $75. Here are the specs:

10.1" Screen
Intel Atom Z2760 1.8 Ghz Dual-Core Processor (32bit)

It will only boot from a 32bit UEFI. I can disable secure boot but there is no legacy boot (boo Dell, boo, but I still like you guys).

I have tried a few things all with the system not able to boot from USB. There is more info out there for installing Windows 8 but I have no use for Windows and my objective is to have this tablet running openSUSE Tumbleweed with KDE Plasma.

I used this page on Dell to get me started:

Everything I tried failed. Keep in mind I am only trying openSUSE ISO images and SUSE Studio Imagewriter to create my bootable USB flash drives.

I used the 32bit Tumbleweed and the 32bit openSUSE Tumbleweed KDE Live 32bit image.

The error I get is, that there is no bootable drive F1 to retry, F2 to setup…

But this is where I got some real hope:

I downloaded the bootia32.efi but when it actually downloaded it was named: bootia32.bin

Not sure if that matters.

Now. I’d like to edit the iso file, I think add the directory /EFI/BOOT/ and that file to see if that works.

What is the best way to go about modifying an ISO file? Is there a better choice?

My next hurdle will be, after install, will it be able to boot… I’m sure that I can, with the help of this community, be able to figure out how to manually alter GRUB or the MBR or whatever else is needed.

I intend to document everything very clearly and add it to the openSUSE wiki pages for others to use.

I am not interested in running anything but openSUSE on this Tablet. That is kind of a KEY requirement for success.


That’s some nice project. I can’t help you techically, but I can suggest you also subscribe to the factory mailing list and post there. The tech people on the ML might be able to help in case no one here does.

Does f.e. your PC / laptop boot from the USB install medium? Any way to do that without using a USB hub? (SD card + SD card reader with mini usb?). From what I read about the windows install, it’s pretty much like installing on a PC on this Intel based tablet. I’d say that putting UEFI on on the tablet should force a UEFI install.

I can boot a laptop off of the USB medium. I also formatted an internal SD Card with the install and live USB images as well with no result.

I did subscribe to the Factory mailing list.

I might also try to see if there is a distro I don’t want to at least just see if I can get it to boot from USB and have a template to go by.


I used the instructions here and tried the Ubuntu 32bit build but this didn’t work.

I think the next thing I must do is modify an ISO and add the 32bit UEFI binary to see if that will make it happen. I do not intend on using Ubuntu on this project. I want to be very clear that openSUSE Tumbleweed is the only distro I want running on this thing. Anything else I will consider a failure on my part.

Next step, find some howtos on modifying ISOs!!!

After a long break, I have returned to this project. I called into the “Ask Noah Show” because Noah is real good about having answers to such things. He gave me a link to a site concerning installing Fedora from one Adam Williamson but that lead me to another page with a lot of real good detail.

This interestingly enough lead me back to the openSUSE wiki

Where I was able to take a USB drive, do the live-grub-stick --isohybrid command and put in the Tumbleweed NET x64_86 version so that it would set up the EFI partition. I swapped out the 64bit efi library for the 32bit library and added the 32bit Tumbleweed iso using the dd command. I am not 100% confident that I used the command correctly but it copy the whole ISO image to the USB flash drive as the 3rd partition.

I can now get this Dell Latitude 10 ST2E to boot to grub. My problem now is, I don’t know what to have grub execute to start the install process from the i586 partition.

The author talks about supported distributions also saying that on his Dell Venue tablet (32 bit EFI, 64bit arch, as opposed to 32bit EFI and 32bit arch of the 10 ST2) openSUSE Tumbleweed performed the best.

So, at this point, I am stuck again due to my ignorance. I don’t know what I need to tell GRUB to do to launch the installer of Tumblweed 32bit. I don’t see an equivalent for:

grub> linux (hd0,gpt3)/@/boot/vmlinuz nomodeset
grub> linux (hd0,gpt3)/@/boot/initrd
grub> boot

Any help on this would be great! I would like to actually develop a process that I can maintain on the openSUSE Wiki


The easiest way would be to poke this Feature request;

User nrickert has this blog post;

I have an ASUS XT205A sitting here, same type of setup, never got around to doing anything with it yet…

Oh, the CPU is 64bit, only the UEFI is 32bit.

It looks like the feature is done but that doesn’t really fix the i586 build of Tumbleweed.

I am now at a point where a manual entry into GRUB to start the install of Tumbleweed is what I am trying to achieve. I just don’t know what to launch on the i586 install Image.

I appreciate any help you can provide.

The help is to progress booting from a 32bit UEFI to a 64bit image (your cpu is 64bit).

You will far more likely glean help from developers/tumbleweed contributors if you go this route (Forum, Mailing List and IRC). There is minimal testing of 32bit Tumbleweed…

The tools I would suggest are looking at Kiwi and Studio Express to build say a JeOS iso image since it’s small and get past the boot hurdle.

You can see the kiwi image files on OBS;

When I go to the Intel site it says the instruction is 32-bit, unless I am understanding this spec totally wrong:

I am aware that 32 bit usage is dropping

Is there a good guide that walks me through the process to make an image on OBS? Pretend like I drag my knuckles on the ground…


:frowning: I’ve got this one in the ASUS;

The following should get you started;

So? Any ideas? beta of leap 15.0 build 128, does not contain 32 efi loader (

I know that Tumbleweed is supposed to have 32bit EFI built in now. Maybe it hasn’t made it’s way to Leap yet.

There is