[OpenSUSE]"qmake is not a typo you can use"|"Could not start D-Bus"

I’m a noob,and I have a depressing issue after installing Qt5.9.0 on my OpenSUSE Leap 42.2:
Read the instructions on Qt-Wiki;
Downloaded the xxx.run file;
Chmod and executed the file locally;
Followed the graphical setup;

Started Qt-Creator and Successfully built and run samples from the Examples;
(Qt installation seems to be correct )
---------------------Everything’s Going Well until I Did Stuff Below---------------------------
I try qmake -version in Terminal and it tells:
If ‘qmake’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf qmake

(Problem1: Apparently, my graphical setup didn’t add the Qt directory in the Environment )
Tried adding lines in /etc/profile
Tried resource /etc/profile in Terminal
Tried qmake -v in Terminal
QMake version 3.1
Using Qt version 5.9.0 in /opt/Qt5.9.0/5.9/gcc_64/lib

(It works seemingly)
Reboot and Login
Failed to get a KDE desktop. Instead ,I got a window with the message :
Could not start D-Bus. Can you call qdbus-qt5
and when I clicked “OK”, nothing happened.
Went into the Terminal by pressing Ctrl-Alt-F1
Commented out the lines added previously
And my KDE desktop is back
(Problem2: Unable to login to my KDE desktop if adding the Qt directory in /etc/profile)
So What Shall I Do to Work Around it (or them)?
Just give up , forget about qmake and Terminal.
Pledge my eternal loyalty to Qt-Creator?

Try to undo everything you’ve done.
If you can’t figure out how to do that properly, you may have to try rolling back (if you installed BTRFS) or do a re-install.

Before you install apps from anywhere else,
Always look for, and try installing from the openSUSE repository first.
QT Creator is in the OSS (You can find it in YaST Software Manager).
You can also find it at


Packages installed from the openSUSE repositories have the highest chance to work without causing problems.


is there a particular reason you need Qt 5.9 from (I’m not sure who owns them now after Microsoft bought nokia who bought trolltech)
as kde/plasma uses a particular Qt version adding 3rd party binary bloobs might break your system
plasma 5.8 that comes with LEAP needs Qt 5.6.1 and will have issues running against 3rd party bloobs
unless you really need that version for some specific reason remove /opt/Qt5.9.0/ and undo what you did in /etc/profile
if you need Qt 5 development tools just do as TSU said and search yast for qt5+creator (currently the LEAP version of Qt is at 5.6.1)
if you really need Qt 5.9 you’ll need to use the Qt5 development repo (which always has the latest stable Qt5 release currently at 5.9.0)
the thing is if you are going to use that Qt branch you’ll need to upgrade plasma 5 to the latest version build against Qt5.9 too that version can be found in the KDE:Frameworks5 repo
after adding the above repo’s you’d need to do a full vendor change to them, keep in mind those are development repo’s always changing and frequently updated