Opensuse Leap 15.3/.4/.5 Nutanix VM booting into Grub Rescue after new disk is added into LVM

Hello guys,

I have tried literally all the solutions that I can find online and unfortunately no luck till this point.

My VM will boot into grub rescue mode if a new disk is added into the LVM,

The error would be lvmid xxxx not found…

I have tried several solutions including :

  • mount /dev/mapper/system-root /mnt
  • mount --bind /dev /mnt/dev
  • mount --bind /proc /mnt/proc
  • mount --bind /sys /mnt/sys
  • chroot /mnt
  • grub2-mkconfig -o /boot/grub2/grub.cfg
  • grub2-install /dev/sdX
  • exit
  • umount /mnt/dev
  • umount /mnt/proc
  • umount /mnt/sys
  • umount /mnt
  • reboot

Fstab : -

/dev/system/swap swap swap defaults 0 0
/dev/system/root / xfs defaults 0 0

I have also verified the LVMID matches as well.

I have also tried moving /boot into a new disk with ext4 away from the LVM but with no luck as well.

I tried using yast2 to update the boot loader with no luck.

I tried as well from grub rescue to set the root and boot with no luck as well.

Appreciate if someone could help me with this.

Thank you!