openSUSE-Leap-15.0-NET-x86_64.iso: package list not updated before installation

I just installed Leap 15 from the net install ISO openSUSE-Leap-15.0-NET-x86_64.iso.

Normally a network installation has two advantages:

  1. If your internet connection is very fast, the installation might be faster than from the DVD ISO
  2. The package list will be updated from the repos before the installation starts, so you will get the most recent versions of all packages installed.

For openSUSE the second advantage doesn’t apply. I had to update/upgrade 545 packages after the first boot of the installed system.
Why does the installer NOT update the list before the installation starts? For almost every Linux distro this will be done when installing from a network installation image.

It should.

Hmm, I haven’t done a NET installation with Leap 15.0, so this might be slightly off.

Typically, early in the install you are presented with a list of repos to select. The default is to select the main repo. If you want all of the updates, you must also select the main update repo, because that’s where the updates are.

I just started the installation with default values, so I didn’t explicitely chose repos. Maybe this is the reason, the main update repo wasn’t active. I will try it again and make a re-installation.

Now I re-installed it and everything is ok. I explicitly checked the repos before installing so they were updated once again and then it worked.

I’m glad that worked. And thanks for reporting back.