OPENSUSE killed hylafax

BEEN USING opensuse and hylafax for many years, HYLAFAX WILL NOT WORK NOW. EVEN A FRESH INSTALL…

And the question is?

If you require assistance, you’ll need to supply more definitive information about the nature of the problem, and what you’ve tried so far.

But it is here?✓&baseproject=ALL&q=hylafax

Hylafax Will not even start.Wiped out the hard drive and did 2 fresh installs. tomorrow will try again

Deleted the install of hylafax…tried your links…


This what I got…

The following packages have not been found on the medium: openSUSE:Leap:15.2:Update Online updates for openSUSE Leap:15.2 This project is releasing the official updates for openSUSE Leap:15.2. openSUSE:Leap:15.2 openSUSE Leap 15.2 openSUSE Leap borrows packages from SLE for the base system. Please refer to for origin information hylafax+ A fax server HylaFAX is a fax server supporting Class 1 and 2 fax modems on UNIX systems. It provides spooling services and numerous supporting fax management tools. The fax clients may reside on machines different from the server, and client implementations exist for a number of platforms, including Windows.

yes Im running 15.2
SSD hard drive failed after 2yrs

Installed hylafax . ran the faxsetup and addmodem. Added the faxgetty-ttyACM0.service to /etc/systemd/system/ …Hyla fax wont start.

Downloading 15.3. I live in the woods… I only have 1.5M download speed. tomorrow is a new day

Dear StevenZ,

It is important to provide your potential helpers with the best technical information you can. To do so please never say things like “I installed”, or “Hylafax will not start”, but tell exactly what you did (how you installed, there are a lot of ways to “install” something and how you start, starting from the command line will probably show something and we want to see that something, even if it is nil),what command and what you got. Preferable by a complete copy/paste of the command, and the output from your terminal emulator here in your post and between CODE tags. For the CODE tags: it is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.
An example is here: Using CODE tags Around your paste.

Next best is a screen shot uploaded to

Only so can people get an idea about what you are trying to do and how.

I assume that openSUSE Leap 15.3 is already installed?

Anyway, to start with please show

zypper se -s hylafax

Others may request further information.

Download failed last night.trying again. yes I was using 15.2.downloading 15.3. was using 15.1 when hard drive failed. And hylafax worked

Clear as mud.

Work has been really busy. Hope to get back to my hylafax problems soon.

Fresh install 15.3. hylafax still wont start .faxgetty starts.

localhost:~ # systemctl start hylafax
Failed to start hylafax.service: Unit hylafax.service not found.

Have you thought about using tab completion to see what services are there?

This is hylafax+ not hylafax?

I see the following available;


I don’t know what tab completion is. yes hylafax+

Tab completion is type part of the text and press the tab key :wink:

I suspect hylafax-hfaxd.service is the service to start not hylafax…

Faxgetty works .Hylafax wont start. I know this is old school. but its a big part of my business.

Open a terminal and switch to root user and show the output from;

systemctl status hylafax-hfaxd

hylafax-hfaxd.service - HylaFAX hfaxd (client service)

     Loaded: loaded (/usr/lib/systemd/system/hylafax-hfaxd.service; enabled; vendor preset: disabled)
     Active: inactive (dead)
  Condition: start **condition failed** at Sat 2021-07-31 08:06:30 CDT; 5h 28min ago
             └─ ConditionPathExists=/var/spool/hylafax/etc/setup.cache was not met

Jul 31 08:06:30 localhost systemd[1]: Condition check resulted in HylaFAX hfaxd (client service) being skipped.

Thanks for your assistance.

So this is the issue;

ConditionPathExists=/var/spool/hylafax/etc/setup.cache was not met

As root user have you run;

/usr/sbin/faxsetup -server