openSUSE installer hanging near start

I have installed many Linux distributions, but I have never tried openSUSE! So I thought it must be time to try it. I pop the dvd in
(I checked the md5 of the iso and checked on the bootable disk) and when I go to install it pauses on the “Probe hard disks”

Things I have done:

  • Re-checking the integrity of the disk and iso.

  • Tried booting with the safe kernel.

  • Tried leaving it for ages.

Any other ideas?

Detailed info about laptop

Not on stock hard-disk (Now going to find what that is :P)


I think you need to post how the partitions are setup on your laptop hard drive. Are you wanting to shrink a Windows partition to make room to install SuSE? Have you tried using just the live disk without doing any install? I think there is some hardware that is not working for some reason, but it might be just a partition that SuSE does not understand. For instance, while SuSE has no problem with it, I recently added a USB 3.0 external hard drive. My standalone boot able GPARTED CD, no longer will boot when the USB 3.0 hard drive is present. Perhaps more detail on your hard drive partition setup would help a lot.

Thank You,

viMitch wrote:
> Any other ideas?

are you using some sort of MS-friendly but Linux-averse raid selection
in the BIOS! (RAID 0 springs to mind, but that might not be the term i
wanna remember)…

dumb question, i’m sure you thought of this, but forgive me: is it
possible the drive itself has a hardware problem? or a bad cable
connector? or other hardware malfunction? do you have a Live Linux CD
(any will do–just boot up and see if you can mount and access the
drive…hmmmm, might wanna mount it read write and see if you can do

do you anticipate that the drive is empty? full? a Linux or Redmond
file system?

DenverD (Linux Counter 282315)
posted via NNTP w/TBird | KDE 3.5.7 | openSUSE 10.3 SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Actually my partitions are very simple at the moment.

I have only Arch Linux installed on the hard disk it is separated across 3 partitions + the swap.

What would be mounted as the /boot is ext2

What would be mounted as the / and /home is ext4

Could it be the ext4? Would removing the current file system work?

Also my hard disk is working perfectly and I am not using any RAID or anything fancy its just one drive plugged in via SATA.

Other Linux distributions work perfectly :slight_smile:


Edit: I am now going to remove the file system and re-try as I don’t have any data to keep.

It works! Well… not quite.

Now it hangs on “Search for Linux partitions”.
I’m going to try the alt kernel in hope!

Please also look at our two stickie wrt installating :

You did not state which openSUSE version you were trying to install. I assume it was 11.2 ?

Reference your laptop, I note it has the Intel Graphics Media Acclerator X3100. Levono typically have a good site for Linux support, and when I look at what they have to say about the X3100 I note this: Intel Graphics Media Accelerator X3100 - ThinkWiki

They state the driver for this X3100 is still in heavy development, and officially requires at least kernel 2.6.29 with version 2.7 of the Intel driver. But in reality you should really be running at least the kernel and version 2.8 of the Intel driver. … This means for the kernel at least openSUSE-11.2. I do not know off the top of my head what version of the intel driver is included with xorg-x11-driver-video rpm: openSUSE Forums - View Single Post - openSUSE Graphic Card Practical Theory Guide for Users and I am not at a Linux PC right now so I can not check.

Reference good practise for burning a CD, I recommend you burn to a +R or -R CD/DVD (not to an RW) and also burn at the slowest speed your burner allows. Also, if possible, burn on the same device that will be used as the reader (so as to minimize impact of calibration differences between burner and reader).

I’m now trying in text mode, which I prefer anyway
and yes I am trying to install openSUSE 11.2 (I can’t believe I missed that out! :P)

As far as I know, you can only have four PRIMARY partitions on any hard drive. One of those can be a Logical partition, but if you are already up to four Primary’s with no logical drive in the mix, there may be no solution for adding in one more partition for SuSE to install even if it can down size something.

What is your your target or intended setup? How many partitions will you have, how many primary partitions and logical partitions? A logical partition can then contain several more partitions within it, but they are not primary or boot-able partitions. You can load openSUSE from any partition, but the boot loader (grub for instance) must reside in the MBR or in a PRIMARY partition, if you don’t place it in the MBR (Master Boot Record).

Thank You,

Rightio 'bout the primary partitions, but that shouldn’t stop the install dead in the water. I should think that oldcpu is on the right track - looking at the hardware. Something there is borking the install cd - assuming the cd is working. I know you said you checked the md5 sum, so I guess that assumption is safe. However, oldcpu’s point about the TYPE of cd/dvd you are using might be important. CD/DVD drives can get VERY peculiarly fussy about what they will read and what they won’t.

I would suggest you try one of the SUSE live cd’s - and see if the box runs the live cd. If it does, then the install will technically work. It just might take some playing about to figure out which param is throwing up the brick wall.

Oh ya - it wouldn’t be the ext4 - 11.2 uses ext4 by default.

Reference the Intel driver , now that I am at home, I note that if I look inside the graphic driver rpm (various ways to do this) and can see: xf86-video-intel-2.9.1.tar.bz2 …

Hence the intel driver is version 2.9.1. One can also look at the change history which is inside the nominal rpm.

There is also a new driver available here:
Index of /repositories/X11:/XOrg/openSUSE_11.2

If one looks inside the new rpm (for the new driver) one will see: xf86-video-intel-2.11.0.tar.bz2 or alternatively one just reads the change notice to see version 2.11.0

Both of those are newer than the version 2.8 of the driver that is recommended for your hardware.

Information on the Intel drivers is here: Intel Linux Graphics but one should still use an rpm packaged by openSUSE for an openSource Intel driver install.

A caution about the new driver. Newer is not always better. That repository I listed has cutting edge rpms and installing them could make things worse and not better, so I would not recommend it unless one has definite/necessary reasons for updating the driver/rpms.