OpenSuse Fedora dual boot

I am new to Linux world. Would like to know if it is possible to dual boot Leap and Fedora?
I tried installing them in parallel, but am unable to make the grub menu work.
Please advice.
Thanks in advance.

Hello and welcome.

Because people here are not mind readers, better explain more precise what you did. E.g. what was installed first (I doubt that those two installations were done"parallel" as you say). And of course all you did with Grub (Grub from Fedora or from openSUSE). And you seem to have a Grub menu. How does it look and what do you mean with “unable to make it work”.

Sorry for the confusion. I had 2 seperate installations of Fedora and Open Suse.
I tried to install them in dual boot on one disk by moving the Open Suse installation(just the install partition) on a new partition on the Fedora disk.
I later loaded Fedora and tried to update Grub so that it could let me boot Suse.
Fedora grub does recognize my Suse partition and does create the Grub boot menu but is not able to load the system.

Error is get is :

Loading Linux 5.3.18.*
error: …/…/grub-core/fs/btrfs.c:2041:file '/boot/vmlinuz-5.3.18.*
not found
Loading initial ramdisk…
error: …/…/grub-core/loader/i386/pc/linux.c:422 you need to load kernel first.

Thanks for the prompt response.

That is correct. openSUSE (it is not Suse and it is not Open Suse) is using custom grub patches and so its grub config is incompatible with grub from other distributions. openSUSE grub should be able to boot Fedora.

Thanks for a prompt clarification.
openSUSE forum rocks!!

Note the order of install matters because the last installed normally controls the boot unless manually changed at install. Also the boot type matters MBR (old style/legacy) boot or EFI (new style) boot.