openSuSE 13.2 only uses 1024*768, no other screen size available

After installin 13.2 my monitor is no longer used with 1440900 but only 1024768.
No other resolution is choosable in Display Settings.

Hardware info shows correct values for the Monitor.

So what video chip/card and have you installed the driver for it?

It sound like the system has dropped back to the VGA driver.

If this was an upgrade you need to reinstall the propritary driver you were using.

Note in the future when a problem obviously concerns a specific part of the system it is best to tell all the details about that part. In this case it is an obvious video problem, so tell use about your video. It can take a bit of time if we have to drag the details out of you :slight_smile:

From Yast hardware Info :

Graphic controller :
16: PCI 02.1: 0380 Display controller
[Created at pci.328]
Unique ID: ruGf.IeukIWQBFA8
SysFS ID: /devices/pci0000:00/0000:00:02.1
SysFS BusID: 0000:00:02.1
Hardware Class: graphics card
Model: “Intel 4 Series Chipset Integrated Graphics Controller”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x2e33 “4 Series Chipset Integrated Graphics Controller”
SubVendor: pci 0x1849 “ASRock Incorporation”
SubDevice: pci 0x2e32
Revision: 0x03
Memory Range: 0xfea00000-0xfeafffff (rw,non-prefetchable)
Module Alias: “pci:v00008086d00002E33sv00001849sd00002E32bc03sc80i00”
Config Status: cfg=no, avail=yes, need=no, active=unknown

Monitor :
62: None 00.0: 10000 Monitor
[Created at fb.71]
Unique ID: rdCR.EY_qmtb9YY0
Hardware Class: monitor
Model: “Generic Monitor”
Vendor: “Generic”
Device: “Monitor”
Resolution: 1024x768@76Hz
Driver Info #0:
Max. Resolution: 1024x768
Vert. Sync Range: 50-90 Hz
Hor. Sync Range: 31-61 kHz
Config Status: cfg=new, avail=yes, need=no, active=unknown

But the Monitor is a Philips 190SW and can show resolution up to 1440*900,
what had worked fine with openSuSwe 13.1 after some settings with xrandr.

But now, after the 1. try with upgrade installation and also after 2. try with complete new installation of 13.2
the monitor is only shown as “default” with 1024*768.

As far as I remeber I tried it this way, when I installed 13.1. some time ago :

pc-uwe-1:/etc/X11/xorg.conf.d # cvt 1440 900

1440x900 59.89 Hz (CVT 1.30MA) hsync: 55.93 kHz; pclk: 106.50 MHz

Modeline “1440x900_60.00” 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync
pc-uwe-1:/etc/X11/xorg.conf.d # xrandr --newmode “1440x900_60.00” 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync
xrandr: Failed to get size of gamma for output default
pc-uwe-1:/etc/X11/xorg.conf.d # xrandr --addmode VGA1 1440x900_60.00
xrandr: Failed to get size of gamma for output default
xrandr: cannot find output “VGA1”
pc-uwe-1:/etc/X11/xorg.conf.d # xrandr --addmode default 1440x900_60.00
xrandr: Failed to get size of gamma for output default
pc-uwe-1:/etc/X11/xorg.conf.d # xrandr --output default 1440x900_60.00
xrandr: unrecognized option ‘1440x900_60.00’
Try ‘xrandr --help’ for more information.
pc-uwe-1:/etc/X11/xorg.conf.d #

But with VGA1 instead of default

This time it does not help.

Thanks in advance for any further advice.

I also have such a monitor But use a NVIDIA card. I set up the modline in a /etc/X11/xorg.conf file since the hand shacking did not come through a KVM switch I use.

Put this in the /etc/X11/xorg.conf.d/50-monitor.conf file


Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       55.0 - 83.0
    VertRefresh     50.0 - 75.0
    ModeLine        "1600x900_60.00" 119.00 1600 1696 1864 2128 900 901 904 932 -HSync +Vsync

EndSection



It might help if the monitor is not detected. Also be sure that the driver has not dropped back to the VGA drive and is actually using the Intel

I updated my 50-monitor.conf to this :

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “CRT-1”
HorizSync 55.0 - 83.0
VertRefresh 50.0 - 75.0
Modeline “1440x900_60.00” 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync

EndSection

But it did not help. still only “default” defined in “System settings / Display” and still only 1024*768.

How can I check, which drives is used ?

To help the graphics gurus (of which i am not one) could you copy the content of the file /var/log/Xorg.0.log and paste it into http://susepaste.org , press ‘create’ on that page, and then post here the URL address where that file is pasted ?

Our graphic gurus, by looking at that file contents, may then have a better idea as to the optimal way to approach this problem.

I pasted it right now and got the link http://susepaste.org/25012191 for it.

Your Xorg.0.log shows that the fbdev (basic framebuffer) driver is in use, rather than the Intel one.

Your grub boot line is using the nomodeset option which will prevent the loading of a KMS driver

    21.530] Kernel command line:  BOOT_IMAGE=/boot/vmlinuz-3.16.6-2-desktop  root=UUID=6a5e984d-f336-4854-bef1-4340184fe98e nomodeset  resume=/dev/sdb1 splash=silent quiet showopts

However, this might have been required to get a working desktop? I’ll leave others to comment about this particular Intel chipset. (I don’t have time to research further.)

Model: "Intel 4 Series Chipset Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2e33 "4 Series Chipset Integrated Graphics Controller"

The 8086:2e33 is an Intel G41. According to an old Phoronix article, support for that has been present since 2008: http://www.phoronix.com/scan.php?page=news_item&px=NjcxNA

On my openSUSE-13.1 PC (not 13.2) when I type “man intel” I note:


SUPPORTED HARDWARE
       intel supports the i810, i810-DC100, i810e, i815, i830M,  845G,  852GM,  855GM,  865G,
       915G,  915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, Q35, G35, GM45,
       G45, Q45, G43, **G41** chipsets, Pineview-M  in  Atom  N400  series,  Pineview-D  in  Atom
       D400/D500  series,  Intel(R)  HD  Graphics:  2000-6000,  Intel(R)  Iris(TM)  Graphics:
       5100/6100, and Intel(R) Iris(TM) Pro Graphics: 5200/6200/P6300.

which suggests your (uwe_koch) graphic hardware should be supported.

If it were me with your (uwe_koch) hardware, I would reboot, and when grub appeared press ‘e’ to get the grub text edit. I would go to the line that starts with ‘linux’ and carefully (using the arrow keys to navigate) go to where ‘nomodeset’ is located and remove that single entry. Then press F10 to boot and see what happens.

If that works, then make the removal of ‘nomodeset’ permanent by going to YaST > System > Boot Loader > Bootloader options … and from the ‘optional kernel command line parameter field’ I would carefully remove the ‘nomodeset’ entry and only that ‘nomodeset’ (do NOT remove anything else on that line). Then I would clock ‘ok’ and that should update your grub without ‘nomodeset’. Then I would reboot and see what happens. If after the YaST permanent edit the PC fails to start, then reboot , and press ‘e’ at the grub menu and put ‘nomodeset’ in at the appropriate ‘linux’ line entry. And in that failure case once the reboot is back in place (after restoring nomodeset) you could use YaST to restore/save the ‘nomodeset’ from where you deleted it.

And if that did not work for me, I would ask our forum graphic gurus for some help.
.

Confirming that the Intel graphics stack should have some problems in OS 13.2.
I have a 965GM chip, boots regularly with the intel KMS driver but if I try to “switch user” with Gnome, Xorg crashes when the second user logs out.
So, if I want two (or more) graphical sessions at once on different VTs I must use the “fbdev” driver as uwe_koch is doing.
Then I noticed that custom files in /etc/X11/xorg.conf.d are read but often “not used” by the intel Xorg driver that prefers its own automatic configuration (because Option “HotPlug” is on by default?).
Then it misses some details of the EDID the monitor sends back (screen size in my case, no big deal).
Maybe something similar is happening to the OP.
Maybe the Intel stack has been tested thorougly on current HW but still has a few kinks with our older chips… (still testing, on my side).

Hi everyone, I had a similar issue with upgrading to Opensuse 13.2. I use a dual display big desktop, with two of the same monitors plugged into on-board VGA and DVI. My VGA monitor would not go past 1024/768 when my other monitor would max out. To fix this, I simply shutdown, swapped the cables in the back of the monitors and rebooted. Now they will both go to the max resolution. I dont have a Xorg.conf file since I am using Radeon modprobe driver- (I think is the reason why)

Just for the records, in the last few months kinks in the intel driver have largely been maxed out.
The current kernels (3.16.7 on OS 13.2 and 3.19.4 on Tumbleweed) are OK on the GM965 as far as I can tell.
Occasionally there are regressions (see for instance bug925946 on kernel 3.19.3) but by and large the driver is stable.