openSUSE-13.2-DVD-x86_64.iso does not finish booting in Oracles VM VirtualBox on Windows 7 Ultimate

I just downloaded the latest relase of openSUSE. The filename is openSUSE-13.2-DVD-x86_64.iso. I have verified that the hashes are correct.

When I try to start up the .ISO in Oracle’s VM Virtual Box, version 4.3.20 r96997 it starts to do good by showing the welcome screen, then the boot screen. So I select “boot from hard disk” and the boot process begins, by printing ‘Booting from local disk…’ but nothing ever happens after that. I’ve tried tweaking everything from the base memory which started at 512MB and is now set to 2048MB and other settings such as video memory, PAE enabled, etc. Nothing I do seems to make it want to boot. I have successfully booted and still use Fedora 21+, Ubuntu 14+, CentOS 6.2+, etc in Oracles VM VirtualBox without issues. This one has me stumped. Maybe there are bugs in this release?

You are loading the .iso and get the welcome boot screen, if this is a dvd, then you should choose installation

It’s not a DVD, it’s an .ISO on my hard drive. It’s how I boot all my other distros without problems. But maybe I have made a mistaken assumption here. Does OpenSUSE not boot as LIVE operating system?

Edit: Actually, I just tried to boot by selecting the “Rescue” option and it worked. I am surprised. Guess I’ll have to install this permanently to test drive it. Are they working on a LIVE bootable version of this OpenSUSE?

Not the image you pulled down
You need the Live DVD

I haven’t seen any official “LIVE DVD” release so far (but i might be wrong).

You can always checkout and look for such build or build one your self.

By default the live cd has the live environment and you will need the “LIVE CD” which was pointed out to you by Carl.

Oops, silly me. When I went to the download page I didn’t see the other versions that were offered. I would have chosen the live version. None the less, my worries are less now. So, thank you!!!