openSUSE 13.1 - Problems with GUI-mode after installing updates (3.11.10-29 to 3.12.57-44)


I just installed some updates on my openSUSE 13.1 and after I did the required restart GUI-mode does not appear any more and system only starts in konsole-mode.

When I start 13.1 it automatically switches to konsole (version 3.12.57-44). The older version 3.11.10-29 still works fine.

What can I do?

Best regards


If you are using the nvidia drivers then:

Uninstall the nvidia drivers.
Reinstall the nvidia drivers.

You should be able to run yast at console mode to do this.

Yes, I use the nvidia drivers.

I started yast in console mode and I see a software repository “nVidia Graphics Drivers”.

Can anyone please explain me how I am able to uninstall the nvidia drivers and then reinstall them?

Here’s an alternative plan that you might find easier.

Step 1: Boot the previous kernel. The advanced options menu entry should allow you to boot the previous kernel.

The chances are that graphics will still work with the previous kernel.

Now login to Icewm. If you are set for auto-login, then just logout and then login to Icewm.

Use Yast software management, and search for “nvidia”. There are possible two or three packages installed.

Uninstalll those. (Right click, and select “delete”).

Now reboot to the newer kernel. You should actually have graphics, though perhaps not good. Login again to icewm. And use Yast to install the nvidia drivers (the ones that you removed – maybe record the package names before you remove them).

Reinstall should recompile them for the new kernel. So, after another reboot you should be set.

Thanks for help!
I started Icewm and tried to delete the nvidia packages and then a dialogue with “conflict management” started. After that the installed packaged were marked for uninstallation and other nvidia packages were marked for new installation. I started this but at 50% progress it did not go further … so I stopped this and started yast via text mode.
I found there the nvidia packages that are installed but I do not know here the command for uninstallation …

How can I remove the nvidia packages in yast properly (in text mode and alternatively in gui mode)? What about the arising “conflict management”?

Thanks in advance!

I’m not sure what went wrong there. It should be possible to remove the nvidia packages, but you probably have to remove all of them at the same time (they are inter-dependent).

If you installed from yast then remove via yast. If you installed by command line then add -remove to the installer command. Note that you only remove packages with NVIDA in the name. There are other nvidia related packages that may show up in a search but leave those alone. I suspect those are the ones want to reinstall.

:slight_smile: it worked!
but I was not able to start icewm after rebooting newer kernel (variable §display not set). how can I set this variable?
so I installed nvidia via yast text mode.
I would like to know how can I remove packages via yast text mode? with “enter” I could install …

Thanks for your support :wink:

There’s a box with “Actions” (after you have selected/searched for a package). Use the TAB key to get to that box. Then you can choose between various actions (update/remove/lock/ etc).

Yes, it’s a bit awkward to use, compared to the GUI version. But it’s great to be able to fall back on it.

I’ve got very similar issues with this kernel update but not related to nvidia grafics. After updating my 13.1 system from Kernel 3.11.10-34 to 3.12.57-44 the gui will not start anymore. GraficCard is an integrated intel running with the i915 kernel module. The only ways to get gui working now on my laptop is to run the 3.11 kernel or boot with nomodeset x11failsafe. The latter disables mesa 3d. I presume the issue is related to the kernel update rather then any trouble with the kernel modules (nvidia or intel, …)

Since it is a different problem, it is best to start your own thread. Mention “Intel graphics” in the title.

I have not heard of any others having this problem. My own 13.1 system has Intel graphics, with no problem. So I’m puzzled.

Thanks :wink:

How can I configure Icewm since I was not able to start Icewm after rebooting (variable §display not set)?

I’m pretty sure that indicates that Xorg failed to start. Check the Xorg logs to see if they indicate anything relevant.

Now I am not able to start icewm via konsole:

/home/marcel # icewm
IceWM: using /root/.icewm for private configuration files
IceWM: Can’t open display: <none>. X must be running and $DISPLAY set.
/home/marcel # icewm-session
icewm-session: using /root/.icewm for private configuration files
IceWM: using /root/.icewm for private configuration files
IceWM: Can’t open display: <none>. X must be running and $DISPLAY set.
/home/marcel # icewmbg: Can’t open display: <none>. X must be running and $DISPLAY set.
icewmbg: Can’t open display: <none>. X must be running and $DISPLAY set.

Try init 5 as root.

Nothing happens …

linux-xxx:/home/marcel # init 5
linux-xxx:/home/marcel #

try init 3


init 5

thanks. :slight_smile:


init 3


init 5

marcel@linux-xxx:~> icewmthe
IceWM: using /home/marcel/.icewm for private configuration files
IceWM: A window manager is already running, use --replace to replace it
marcel@linux-xxx:~> icewm --replace
IceWM: using /home/marcel/.icewm for private configuration files
IceWM: Waiting to replace the old window manager
IceWM: done.

it works.

The xorg-logfile is very long and I do not know where to look for relevant messages since I am not able to see a date related to the messages … so I am not sure if I could start icewm after rebooting without nvidia drivers.

How can I quit Icewm and close windows e. g. firefox?

Apparently it was already in level 5 so init 3 took it back to level 3 then allowed a level 5 restart

Been some time since I ran icewm I think you right click the desktop for options