openSUSE 13.1 Gnome on Macbook Pro 3,1 installation help

After reading a lot and spending days on documentation and forums, I decided I need some more specific help.

I’m trying to install openSUSE 13.1 to my mid-2007 bought Macbook Pro 3,1 Core 2 Duo laptop.
After trying the 64-bit version, which caused a lot of graphical glitches, flickering text-mode installers and other problems, it failed to boot after installation, stating the following error: “i8042: No controller found”. I figured this must be my Nvidia Geforce 8600M GT graphics card, so I went and downloaded the 32-bit Gnome Live-CD.

It booted perfectly, no more issues with “Select CD-rom boot type” because of EFI/BIOS conflicts and a beautiful graphical installer. Followed through the steps and made sure GRUB2 was installed to the /root partition (sda4, with sda3 being a 3Gb swap partition and sda5 my /home partition).

After rebooting without CD (selecting ‘boot from hard disk’ from the CD bootloader) a perfectly operational openSUSE started, with all the function keys for sound, light as well as wifi working out of the box.

However, when about to continue exploring my new system today, it suddenly failed to boot, stating the error: “problem loading operating system”.

I’m completely stumped here. It’s my first time using Linux, so I don’t even know where to start looking for clues. Any help would be fantastic,

All the best,


Hi Newtrebel,

I have some question regarding the message “problem loading operating system”. When does it exactly appear? Can you still boot Mac OS? Do you get the GRUB-screen where you can choose the linux options? Do you get linux to boot (eg a black screen)?

This will help us locating the problem.

I forgot to mention I’m using the rEFInd boot manager. So when I boot, rEFInd shows up. I can select OS X (which boots fine, working on it right now) and a Linux icon, which is somehow misinterpreted as a FAT volume, although it’s ext4. When I select this, the Apple firmware fires up it’s legacy-BIOS support, and then I get in a black screen with a blinking cursor, shortly after showing me the “problem loading operationg system”, no GRUB menu whatsoever.

All the guides tell me to sync my partitions using rEFInd’s hybrid-MBR tool. Both before and after syncing, I have the error message. The tool confuses me a bit actually, because the MBR only reads the first four partitions, obsoleting the fifth (which is /home). My aim is to install openSUSE next to OS X for a while, get to know it, and then get rid of OS X completely.

Thanks for looking at it, I hope this information helps!

Okay. I have had a similar problem. It was so simple to solve that I have forgotten the solution :|.

First of all, you don’t have to worry about the 5th partition. The original MBR was designed to have only four entries because at that time nobody could image to have more than four partitions. UEFI tries to fix that.
And after we fixed your issue, you can safely boot Mac OS and opensuse in parallel.

I think opensuse is installed correctly. Just the firmware doesn’t find it.

Under Mac OS, could you please open the terminal, run

gdisk /dev/disk0

and type “x” and then “o”. Please post the output here. Maybe the MBR is not set up correctly.

And, I can remember having to install an efi-signature. Have you already done so in the refind-directory? If not I will try to find the zip-file containing the sigs.

One thing to keep in mind is that OSX is needed for any Apple firmware updates. I keep it around on a small partition for just that purpose.

Are you using grub2-efi? If I missed it in the thread sorry, but I didn’t see if you specified grub, grub2 or grub2-efi? I’ve used both successfully on my MBA 4,2 (along with rEfit) If you have not tried grub2-efi it might be worth a shot. If you are using grub2-efi, did you specify the efi partition during install?

One problem is - you need to bless bootloader and 13.1 does not do it (current grub GIT master upstream does it automatically during grub-install). I had to do it manually after installation from within OS X. Which is one more reason to keep it :slight_smile:

Another consideration - 32 bit openSUSE lacks efibootmgr which means installer will not be able to add grub2 to bootmenu (may be it is not required and blessing it does it automatically). And OP wanted 32, not 64 bit.

Thanks for the info! Good to know some more about MBR.

Before reading your reply, I decided to boot into a live-CD and remove all the linux partitions. I then inserted my openSUSE 13.1 GNOME Live-CD and did a new, fresh install with all the recommended options. But this time, I didn’t run rEFInd’s hybrid-MBR tool afterwards (I thought I tested this already, apparently I didn’t, or did it wrong somehow). And guess what: it works! I tried rebooting several times, including into OS X and back into openSUSE, without the error showing up so far :slight_smile:

This is what gdisk shows now:

Disk size is 312581808 sectors (149.1 GiB)
MBR disk identifier: 0xCAFECAFE
MBR partitions:

Number  Boot  Start Sector   End Sector   Status      Code
   1                     1       409638   primary     0xEE
   2                409640    253725879   primary     0xAF
   3             253726720    260028415   primary     0x82
   4      *      260028416    281827327   primary     0x83

One funny thing (and the reason I DID sync using rEFInd before) is that OS X’ Disk Utility doesn’t show /dev/sda4, the openSUSE root partition.

This is what diskutil list reads:

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *160.0 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            129.7 GB   disk0s2
   3:                 Linux Swap                         3.2 GB     disk0s3
   4:                        EFI                         11.2 GB    disk0s4
   5:       Microsoft Basic Data                         15.7 GB    disk0s5

For some reason, the root partition is marked as EFI. I guess that OS X hides this partition, because it looks the same as the hidden built-in ESP (EFI partition). I read on the rEFInd page that this is a bug. Or is this the reason my setup works now? I’m expecting the error will reoccur when I run the hybrid-MBR tool in rEFInd, so I guess I’d better leave it like this?

As for the signature, I don’t understand what that it is. I do have an openSUSE certificate in the keys folder of rEFInd?

I also keep having the graphical glitches in the top part of my screen during booting (when you see the openSUSE desktop’s plant and chameleon getting greener), but this is just a cosmetic issue, it goes away when it boots into the main desktop. It shows the same “i8042: no controller found” error I had when trying to install the 64-bit version. Which is the reason I switched to 32-bit. My macbook model is actually listed to not support 64-bit versions of Windows by Apple, I guess the EFI has some limits (it’s not a real UEFI, but EFI 1.1 with some EFI 2 functions on top of it).

Good to know! Thanks. Although I don’t expect Apple to release anything for my 7 year ‘old’ system :slight_smile:

EDIT: I’m using GRUB2, I think. That’s what the installer told me anyway.

I’ll better keep OS X then. Might also come in handy for trouble shooting things indeed.
I would actually prefer to run the 64-bit version. It’s just that the installation media are not properly recognized by my firmware, because it can’t decide between UEFI (which it doesn’t support because it runs EFI 1.1) and legacy BIOS, giving me a choice screen which reads “select CD-ROM boot type”, without the possibility to choose (keyboard doesn’t respond, machine just hangs).

While reading this article: I also read that EFI-booting macs can limit nvidia graphics support and other hardware features. Which is why I thought installing 32-bit was the safer option.

Any information or tips about getting the 64-bit version to run would be welcome.

Good to hear. Enjoy your fresh opensuse installation!

I can’t imagine you will run into problems once the bootloader is figured out. But if so, feel free to ask in the forum.

Regarding you graphic chip: You can run

cat /var/log/Xorg.0.log | grep LoadModule

You should find “nouveau” in there which is the open-source driver for nvidia cards. If you want to install the closed source one from nvidia you have to read some docs or ask in a new thread. I don’t know much about nvidia on linux.

I don’t have any experiences with 64 bit linux on macs so far. My one is running 32bit only. Unless you have more than 4GB of RAM there’s actually no real need to run a 64bit system right now.

What you could try is, that you create yet again an other small partition and try to install opensuse there as a 64-bit system for testing. The worst thing that may happen, is that you have some GB wasted. But you can always try to install opensuse there as soon as there’s a new version.

But to be honest, if 32bit is running nicely, I’d go for a deep exploration on this one first.

Those are some great tips. I didn’t realize the 13.1 does not bless the bootloader - I guess since I’d blessed with 12.3 it carried over to my 13.1 install.

It is nice that installing on Apple hardware is getting generally easier. It would be great if in the next suse release you could just install with grub2-efi and everything would “just work” - no refit/refind, manual blessing or other partition table stuff needed.

I still need to use refit to boot OSX, as booting from the Grub2 menu causes the OSX kernel to crash. Minor thing really, but it would be nice to not need reFit at all.

Glad the OP got things working on their hardware.

I have MacBook 3,1 (not Pro) and have no problem booting 13.1 64 bit DVD natively. Pressing Option during power on, I get choice of two DVD boot methods - EFI and legacy (do not remember the name). Selecting EFI boots just fine.

I did observe problem you describe, but I believe it was long ago, probably with 12.2 DVD. If I understand it right, the problem was caused by using “pure” hybrid ISO and was actually firmware bug; adding some Apple magic to generated image solved it.

Yes, this is known issue. Simple workaround is to add menu entry to chainload Mac OS X loader directly.