Opensuse 12.3 Possible DNS Resolution issues

Hello,

I have a strange problem with two Opensuse computers. They are both running an up-to-date version of Opensuse 12.3. The problem manifests itself as repeated failure to resolve the update repros when trying to install new packages or update the system. For example, if I run zypper up it will fail to resolve all of the repros, but if I hit ‘r’ for retry it will then do it. I have to do this for each one, including the nvidia repro and packman etc I might also get the same problem downloading something on the command line via git or wget etc. There is no problem with using a web browser.

Both systems are on the same network so there is a chance that its hardware but I have tried to eliminate that by changing bits of hardware. a Debian machine on the same network doesn’t have any problems, nor does a windows box, mac laptop and other bits and bobs.

I have tried:
Changing the switch, resetting the router etc.
Changing the cables.
I have no proxy setup.
IPv6 - I tried disabling it and re-enabling it.
IP is assigned by DHCP without issues.
DNS servers are the default setup in the router.

Anyone think of a place I might start to look for a solution?

Phil

Does

dmesg | tail -30

give any info?
Or

su -c 'tail -20 /var/log/message'

Invoke the commands immediately after the connection bumps. If you don’t see anything, post the output here, between CODE tags (the # in the editor)

I too have this issue.The reason may be one of the following

1.May be network connection is slow or

2.You might have problems with your DNS Server.

I have solved my problem by adding google DNS servers to resolv.conf file

Google DNS Servers 8.8.8.8, 8.8.4.4

I have had a similar problem on some web pages where bits and pieces on it came from all over the world and pages took a long time to load. Not so common these days as elements tend to be cached locally. DNS was very slow making it worse.

Personally given your problem as it sounds very similar to a YAST problem I had, sometime ok sometime not I would disable IPV6 checking the settings in your router as well. My router for instance may enable IPV6 all on it’s own.

I believe it’s possible to finish up with a try IPV6 and fall back to IPV4. As far as I am aware few isp’s are actually directly offering IPV6 and cope with the address space problems in other ways. Probably in the same way as your router copes with several PC’s being connected to it. Last time I looked around on the subject many were saying that they wouldn’t be offering IPV6 but that was some time ago now. There is also a technique called IPV6 tunnelling which allows IPV6 to pass through an IPV4 network. For that it may be best to read slow as this must involve some extra processing.

I did use the google dns service and got fed up with it, maybe because I am in the UK. Slow was something of an understatement. My isp’s dns service is sometimes slow as well so I have switched to one of the many free ones that are available and set the router up to use that.

John

Extending the thread a little out of curiosity I ran dmsg | tail -30 and found many lines mentioning mac 33.33… and one different as follows.


[135073.064860] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=33:33:00:00:00:fb:10:1c:0c:58:6b:d4:86:dd SRC=fe80:0000:0000:0000:121c:0cff:fe58:6bd4 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=97 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=57
 
[135790.897376] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=fe80:0000:0000:0000:b6b5:2fff:fea9:d96e DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44 

[135803.182779] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=33:33:00:00:00:fb:10:1c:0c:58:6b:d4:86:dd SRC=fe80:0000:0000:0000:121c:0cff:fe58:6bd4 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=97 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=57 

[136405.328889] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=33:33:00:00:00:fb:10:1c:0c:58:6b:d4:86:dd SRC=fe80:0000:0000:0000:121c:0cff:fe58:6bd4 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=97 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=57 

A web search came up with this sort of thing on this forum asking what these were. That aspect wasn’t mentioned only a possibility of disabling mDNS with no explanation of when that might be needed. Perhaps some one can explain what causes these “line” to appear. Also I can’t help wondering why I am getting them.

John

I ran tail on /var/log/messages and then did a zypper up at the same time. Below is typical of the output from zypper up. It does it with nearly all the repros.


Download (curl) error for 'http://download.nvidia.com/opensuse/12.3/repodata/repomd.xml':
Error code: Connection failed
Error message: Could not resolve host: download.nvidia.com

Abort, retry, ignore? [a/r/i/?] (a): r
Download (curl) error for 'http://download.nvidia.com/opensuse/12.3/repodata/repomd.xml':
Error code: Connection failed
Error message: Could not resolve host: http.download.nvidia.com

Abort, retry, ignore? [a/r/i/?] (a): r   
Download (curl) error for 'http://download.opensuse.org/repositories/mozilla/openSUSE_12.3/repodata/repomd.xml':
Error code: Connection failed
Error message: Could not resolve host: download.opensuse.org

At the same time I had tail -f on /var/log/messages, there was no additional output into messages while the problem occured. Same for dmesg. There was a load of errors about a hard drive which is interesting. I am going to unplug that drive and repeat the process…

Ok I have redone the test without the very ill hard drive. Useful noticing that…

So I tailed /var/log/messages and looked at dmesg, no updates to either of these while it failed to resolve the repros. I tried it on the other computer, it faired a little better, only one of the repros failed to resolve.

Interestingly if I run zypper up it all fails, then if I wait a little while and do it again its fine. If I then wait a long time it fails… Strikes me that it is some sort of timeout/caching error due to a slow DNS server perhaps. Can I increase the timeout?

I also note that ‘openSUSE-12.3-Update-Non-Oss’ appears to be outdated. Anyone else getting that?

Phil

Some other network information:
IPv6 is currently disabled
Using ifup not NetworkManager
Default route is set by DHCP
Domain Name is left blank
Hostname can be changed by DHCP but isn’t
DNS config is Use Default Policy and is set to use the routers DNS settings.

I could try putting Google (8.8.8.8) or similar into the DNS settings…

Did you ever change /etc/resolv.conf by hand? If so, or if you don’t remember, do this:

su -c 'rm /etc/resolv.conf && systemctl restart NetworkManager.service' 

Same result.

Did you set the gateway in Yast? It should be you’re router’s IP. Looks like you omitted that.
Yast - Networkdevices - Networksettings - Gateway/Routering

Could be I forgot that, or forgot to put it in my post…! I will check when I get home.

Putting the router as the default gateway didn’t help. So I have set the DNS servers to 8.8.8.8 and 4.4.4.4 (this seems on the bases of about 10mins of use) to have helped.

So it looks like it might be BTs DNS servers being a bit sluggish, or too sluggish for Opensuse at least.