openSUSE 12.3 on HP nc6400

[Note : this is a follow-on to another thread]

Due to problems with the KDE Live install I resorted to installing openSUSE-12.3-NET-i586.iso, setting the No KMS video option.
Early on in the process it reported that it couldn’t start video mode because of unsupported video hardware.
Presumably, it’s the ATI graphics adapter that is unsupported.
Specs for this nc6400 are as follows …

nc6400 Processor : Intel Core 2 Duo Processor T5600
System Memory : 4096 MB 667-MHz DDR2
Hard Drive : SATA SSD 256GB
Display : 14.1-inch WXGA Graphics : ATI Mobility Radeon X1300 512MB HyperMemory
Audio : ADI High Definition CODEC
Communications : 56K V.92 modem, Network : Broadcom NetXtreme Gigabit Ethernet PCI Express Controller
Integrated Wireless : Intel PRO/Wireless 3945ABG, Bluetooth, HP ev2200 1xEV-DO Broadband Wireless
Integrated Security : TPM 1.2 Embedded Security Chip, HP Biometric Fingerprint Sensor, Smart Card Reader
Pointing Device : Dual pointing devices (both Pointstick and Touchpad)
MultiBay II Drive : DVD+RW DL MultiBay II Drive

The text mode install seems to have mostly completed.
It auto-rebooted once after installing packages and detecting some hardware.
It seems that a second phase of system configuration was progressing.
But, now it stopped with a blue screen and one line at the bottom of the screen - white text on black background :redirecting to “systemctl --ignore-dependencies stop network.service” (NetworkManager.service)

No response to keyboard input ; network is not busy judging by activity lights on the local hub / switch port.

I would probably look in /var/log/messages if I could get a shell prompt.

What’s the recommended troubleshooting / recovery steps now ?

Please check

Doing a manual reboot from the previously mentioned stop condition.

I get the graphical boot (grub2) page with choice of :openSUSE 12.3
Advanced options for openSUSE12.3

However, none of the function keys evoke any prompts for entering video or boot options.

Selecting openSUSE 12.3 or recovery from the Advanced options for openSUSE12.3 page it will boot to the point of reached target graphical user interface whereupon no response to keyboard input other than ctrl-alt-delete.

How do I enter video or boot options in the graphical boot page ?

select the menu option then press e to edit

Go to the line with vmlinuz in the line that is the one that need the option added. note this line is wrapped so it take up sever screen lines.

Also selecting advanced and recovery (the second selection) (note on mine the text is cut off in the menu items so it is impossible to tell what is what unless you know already LOL)

Ok,checked the grub boot options.

The only thing that I was aware of that might affect graphic capability on this computer was nomodeset … but that was already there in the boot options.

So, because I’m noob at linux config, I’m now at a loss to know what else to troubleshoot .

Any suggestions on how to determine why it boots to reached target graphical user interface but there is no graphical interface active on the display ?

This thread may be of interest to you (same graphics hardware):

I will take your suggestion in that thread :

I previously verified that openSUSE-12.2-KDE-LiveCD-i686.iso worked fine (in ‘live’ mode) on the nc6400.
So, I’ll install 12.2 and wait for the 12.3 Radeon problem to be fixed.

Thanks !

You may wish to try the suggestion from post #26 and #27 in this thread: where the solution was to :

  • Omit the “vga=0x317” from the kernel line in menu.lst (this may not be necessary) and
  • use the boot code: radeon.modeset=1

A user with either X1300 or X1400 radeon hardware advised that worked for them.