OpenSuse 12.2 - Acer Aspire 5750G graphic cards

I’ve done a new installation of OpenSuse 12.2 on my laptop Acer Aspire 5750G preserving my /home directory. This laptop uses NVIDIA Optimus technology and sports an integrated Intel HD Graphics Family GF119 plus an NVIDIA GeForce GT 520M secondary card.
My problem is with Intel GF119 not being recognized. In OpenSuse 12.1 it worked well, with the correct resolution of 1366x768 pixels.
My system boots only in failsafe mode, all is working but graphics because the driver is Vesa with 1024x768 resolution and effects enabled and working (?!).
Is there a way to have Intel Graphics working?

I can confirm this bug. I have Toshiba Satellite L300 with intel Hd3000 built-in graphics card. After dist-upgrade i have resolution 1024x768, while it should be 1200x800

Oh, this bug disappeared when i booted with kernel 3.4.0 instead of deafult 3.4.6

And i finally fixed it by removing “kernel-desktop-base” package - which triggered upgrade of “kernel-desktop” package to 3.4.6

Thank you for your reply. After some other try without success I reverted to OpenSuse 12.1 that works very well.