openSUSE 12.1 x64: VNC presents "nobody's X11 desktop"

I activated VNC using Yast and it works but it only display’s “nobody’s X11 desktop”.

I use Apple Remote Desktop to connect and gave it username and password. I also tried with Chicken of the VNC which does not take a username but only a password and it cannot connect at all. Port number is always correct (5901).

What’s wrong?

To use VNC to view a running desktop requires that a VNC server be running on the destop in question. To make sure the server is running, use the netstat command

netstat -ant | grep 590

and look for a line like

tcp        0      0 :::5900                 :::*                    LISTEN

the it is likely a VNC server is running. The command

fuser 5900/tcp

will show the process id that has bound to that port. Let’s say the pid is 2390. the command

ps  -fp 2390

will show the process. For example,

UID        PID  PPID  C STIME TTY          TIME CMD
user      2390  1818  0 Mar25 ?        00:00:03 /usr/lib/vino/vino-server

BTW, VNC only uses a shared secret password (different than the log in password).

But I don’t want VNC to view a running desktop. I want it to create a desktop for me when I log in and show the login screen when I connect. That’s what I remember the option of activating “Remote Administration” used to do in Yast. What good is a black VNC viewer showing “nobody’s desktop”? Why is such an option even part of SUSE?