openSUSE 11 install hangs @ Video Card Detection

I’ve been trying to install the openSUSE 11 64-bit release from a NETWORK install (booted with ubootin from a flash drive) on my Lenovo ThinkPad X61t.

Everything works fine during stage 1 …
the system reboots and it’s finalizing the “auto configuration” and detecting hardware… at this point my intel wireless card doesn’t work… and I can’t get it restarted from the console using iwconfig…
no big deal – i just plug in my network cable…

ok … now it’s detecting my video card… it flashes a few times… pops up with the standard gray screen with X cursor… then goes back to the console and states that it’s detecting my video card and it might a take a bit…

Almost immediately it flips to a black screen (no text, no cursor) and the machine locks … hard.

Alt + Shift + SysRq + K or B or J or whatever does nothing… the numlock and caps lock do not activate their keyboard lights … CTRL+ALT+BKSPACE does nothing as well.

I restart and it brings me back to the install / autoconfigure section.

I went the console … added the xorg repos and tried a zypper update – it updated the mesa and xorg packages, but still hung on the video detection.

Next reboot I tried running “sax2” – it locks. I tried sax2 with the -r -n 0=intel (not exact, but I don’t have it in front of me) – same behavior… system locks hard.

Here are my system specs:
ThinkPad X61 Tablet 776298U 7762-98U 2,412
(12.1-inch SXGA+ Super-Wide Angle TFT,
Bluetooth Wireless Technology,
integrated fingerprint reader,
Intel Core 2 Duo processor L7500 (LV),
Mobile Intel GM965 Express Chipset,
Intel GMA X3100 Integrated Graphics,
160 GB/5400 rpm FDE, 2 GB (2 x 1024 MB),
Intel Wireless WiFi Link 4965AGN
(11n disabled),
8-cell Li-Ion battery,
Intel Turbo memory,
Microsoft Windows Vista Business)

Specs are also viewable here:
New ThinkPad X61 Tablet models include Intel Core 2 Duo processor technology and Microsoft Windows

At this point, I can use the system if I kill the installer and start kdm … /etc/init.d/xdm restart

Any thoughts?:sarcastic:

If you are able to get in to a command prompt, try:

sax2 -r -m 0=vesa

That is the vanilla vesa driver. If that doesn’t work, also try “vesafb” and “fb”; these are framebuffer drivers.

Also take a look at /var/log/Xorg.0.log. In particular, look for AIGLX or dri or glx errors. With another intel driver user, I found that the version of the driver was looking for files not in the matching Mesa package.

You don’t need the installation to complete. What’s left can be configured individually.


I just said “Que Sera, Sera” and hit no… and it all worked with the VESA drivers… but my user account “ryan” wasn’t setup.

However, this allowed me to get into an X session as root. At that point, I went to the Hardware section of YAST and let it configure my display driver…

It detected the GM965 Intel X3100 card and proper resolution and worked fine.

I could not find ANYTHING regarding this specific issue with a “just skip the end of the install and it works” on the web / forums, so hopefully this post will help others.

On another note, is there way to go back and reconfigure the end autoconfigure stuff?

I added the non-oss repos and got my intel wireless drivers install and the wireless card is seeing access points and connecting (and getting DHCP addresses) – but my routing table is empty… however, I know the route / gateway is being passed by the DHCP server.

I think I saw somebody else comment in #suse today regarding their routing tables being empty…

It works wired, but not wirelessly.

Can anyone else provide all the things I need to do to make sure I get a “good” install and complete what the installer was going to finish. I saw there’s a package that will supposedly run the final configuration steps again, but I’m not sure if that’s what I need.


Everything configured from the point you ran into difficulty with the installation, can be done from a YaST module. And at least one and often more of the steps, are not applicable at all.

As far as knowing what else the auto config would have done that it didn’t get to, you’ll know simply by what is missing. The other steps IIRC are keyboard and mouse (this is completely automated, done with the video setup because all 3 are controlled by the X server), sound, DSL (if the computer is making a direct connection), dial-up, isdn, possibly completing the user setup, online updates, and printer.

Sorry, but I don’t follow you re your wireless setup. My wireless routing table is empty; the device gateway takes care of that. A potentially important twist, which varies by device, is with DNS. With some, you need to specify the provider DNS servers, with others you only need specify the gateway. Have you completed all of the setup in the YaST module? At times there are some obscure steps required specific to the NIC and/or the driver and/or the gateway device.

fwiw in the future, IMO the auto-configuration option is just a bad idea, in particular with notebooks where there are always proprietary peculiarities. Had you had access to the video config you might have been successful with the setup or at the least been able to specify vesa and complete the installation, then configure the video afterward (as you ended up doing anyway). In Windows clean installs, not only are these functions not automatically set up, the user is forced to do so manually after the OS installs.