opensuse 11.4 x64 KDE ardour installation

Hi, I am new to opensuse, but i have experience with ubuntu and kubuntu from before. I am a lot happier with the overall experience on opensuse than on those two, and i would like to continue using it.

A showstopper for me so far has been not being able to install the Ardour DAW. When I search for “ardour” in Yeast2, it does not find anything.

zypper ls -d gives this result:

  | PK_TMP_DIR                       | PK_TMP_DIR                       | Yes     | Yes     |   99     | plaindir | dir:///var/tmp/TmpDir.TqjxRR                                            
2  | Packman_Essentials               | Packman Essentials               | Yes     | Yes     |   99     | rpm-md   |
3  | Packman_Extra                    | Packman Extra                    | Yes     | Yes     |   99     | rpm-md   |     
4  | Packman_Games                    | Packman Games                    | Yes     | Yes     |   99     | rpm-md   |     
5  | Packman_Multimedia               | Packman Multimedia               | Yes     | Yes     |   99     | rpm-md   |
6  | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes     | Yes     |   99     | rpm-md   |                               
7  | libdvdcss repository             | libdvdcss repository             | Yes     | Yes     |   99     | rpm-md   |                                    
8  | nVidia Graphics Drivers          | nVidia Graphics Drivers          | Yes     | Yes     |   99     | rpm-md   |                                
9  | openSUSE-11.4-11.4-0             | openSUSE-11.4-11.4-0             | Yes     | No      |   99     | yast2    | cd:///?devices=/dev/disk/by-id/ata-PBDS_DVD+_-RW_DS-8W1P,/dev/sr0       
10 | repo-debug                       | openSUSE-11.4-Debug              | No      | Yes     |   99     | NONE     |          
11 | repo-debug-update                | openSUSE-11.4-Update-Debug       | No      | Yes     |   99     | NONE     |                         
12 | repo-non-oss                     | openSUSE-11.4-Non-Oss            | Yes     | Yes     |   99     | yast2    |            
13 | repo-oss                         | openSUSE-11.4-Oss                | Yes     | Yes     |   99     | yast2    |                
14 | repo-source                      | openSUSE-11.4-Source             | No      | Yes     |   99     | NONE     |         

Also, i have located an .rpm at

. This one gives an error when opened with Kpackagekit:

A problem that we were not expecting has occurred.
Please report this bug with the error description.
[PK_TMP_DIR|dir:///var/tmp/TmpDir.ZOyype] Repository already exists.

When i install with zypper from the downloaded package, the following message appears:

Installing: ardour-2.7.1-1.11 [done]
Additional rpm output:
warning: /var/cache/zypp/packages/_tmpRPMcache_/ardour-2.7.1-1.11.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 20f035d8: NOKEY

And yes, Ardour is installed, but it is a slightly old version and will not be automatically updated from repos. I would really appreciate it if anyone knew a repo with the program, or could add it to Packman Multimedia.

Perhaps you’d have more success if you remove the version you got from rpmbone and use this page instead: Search Results

I’m using the same version of OpenSuse as you and did the 1-click install off that page as a test then ran ardour, although I haven’t tried working with any sound files in it yet it seems to have satisfied the dependencies and even set up jack correctly

A little tip regarding finding software that kpackagekit or Yast’s Software Management Module doesn’t find mate, first look for it on the OpenSuse download page: Download openSUSE 11.4

Just use the search box, if you still can’t find it try Yast > Software > Package Search webpin

Trouble with sites like rpmbone, rpmfind etc is the packages you get there can often be aimed at a different distro or achitecture that just don’t work well (or sometimes not at all) with OpenSuse, or there can be dependencies you need to satisfy which you may not realise, there can also be version mismatches on older/newer versions of packages that the rpm needs, start changing versions to suit and other things can start breaking, it can be a pretty hit & miss way of doing things,

If I can’t find a package using the suse download page or webpin I usually find grabbing a tarball from the app vendor’s site a better option than using rpmbone etc

All that said mate try it from the link I gave you, appears to have gone flawlessly here

Thanks! I had searched that page before and found nothing. Guess it was added in the meantime, or I am too stupid to search. :stuck_out_tongue:

But now that I used the one click installer from there, I also have the repos and guess I’ll receive automatic updates to the package. No errors when installing this time.

I am not experienced enough to handle tarballs very well. I always need a completely foolproof step-by-step guide for that.

Thanks again, this was really helpful! :slight_smile:

11.4 has only been released a couple of weeks so yeah it’s possible it;s been added since you last looked

There’s a few things I used in 11.3 that aren’t there for 11.4 yet, give a little time and I expect they will be though, so it’s worth checking again every few days when you’re looking for something for sure

I used the software download here at opensuse and Ardour works for me.

But what I want to know is how do I use Ardour to record the audio from Amarok and youtube videos? I have to reset my sound card after closing JACK Audio if I want to hear anything again.

If it’s a file on your computer, you could just load it with Audacity, which supports jack. You then just create a track in an ardour session, and use the qjackctl connection window to connect audacity to the track in ardour. Then you hit record in ardour, play in audacity, and later on you can just delete the audio that occurs between hitting record and play.

As far as youtube goes you have to get a little more tricky since you probably aren’t going to find a jack based application that can do it. I haven’t used this, but there is something in the repository called pulseaudio-module-jack, the point of which is to allow you to use the pulse audio server as a jack application, which you can then hook up in qjackctl (or equivalent program) to ardour, in the same way as above. Following the directions in 2.3.3. Integrating PulseAudio with JACK might work, but of course that’s written for fedora and not opensuse and I haven’t tried it.

Anyhow good luck.