OpenSuse - 11.4 PHP5 Interactive readline not working

Hi, I just installed openSuse for the first time the other day. I’m trying to get my web development tools up and going and I’ve hit a little snag.

After installing php5 I tried to use interactive mode on the command line (php -a) but I didn’t get the nice line-edit-capable prompt I’m used to. A little research told me I needed to install readline support, so I installed the php5 readline package. The thing is even though php -m now shows the readline module is loaded I still don’t get the line-edit support.

Is there something else I need?

A warm welcome to the forums.
What output do You get after typing php -a ?

Best regards,

Thanks for the welcome!

I can’t get home to my opensuse box for a few hours in order to be exact, but when I did php -a I got something similar to “Interactive Mode Enabled” and then just a cursor. I could type the contents of a php file like:


echo "stuff";


…then do a Ctrl-D and it would evaluate it. From what I’d read online this is the normal operation of php’s interactive mode when readline support hasn’t been enabled. I’m normally used to seeing something like:

Interactive shell

php > 

…where each instruction I type is evaluated one at a time after a carriage return.

Ok :slight_smile: now I know this is something I can’t help You with and most likly not connected with network. I don’t know that much about php. Maybe this link will somehow help You out :
Installing Nginx With PHP5 (And PHP-FPM) And MySQL Support On OpenSUSE 11.4 | HowtoForge - Linux Howtos and Tutorials

This was in openSUSE weekly news. Usually they give great advice there as far as I’ve tried. Anyway You can wait here for someone more knowledgeable here or try to post your problem in I believe more suitable forum section. I think You have more chances of getting better advice there :slight_smile:

Good luck.

Best regards,

Ahh…I posted in this forum because the description said it included network software and applications looked to be more like productivity software. I’ll check out the links and see; if I don’t figure it out or get an answer here should I simply post the same question under “applications” or is there an admin I need to contact to have the post moved?

I think You should simply post it again with reference to here but I would wait a bit more yet as there are many people with very vast knowledge here as well and the thread is quite young. Of course You can contact some admin if You would like to be moved but this is not necessary IMHO.

Best regards,

Will do. Thanks for the etiquette tips too, btw.