openSUSE 11.3 install issue sata_nv

I’m have some issues trying to install x86_64 openSUSE 11.3 using the DVD. During the installation, YAST2 complains about not finding any hard drives. After some digging, the kernel is loading the proper sata_nv module for the NVidia nForce controllers but it doesnt find any hard drives.

Now here’s the wierd part. This system I’m trying to install is currently running x86_64 openSUSE 11.2 and had no issues finding the SATA hard drive during the installation. The installed openSUSE 11.2 uses the same sata_nv module and finds the hard drives without any issues.

I’ve included the output from several commands from the running openSUSE 11.2 system.

00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev f3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC’97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev f2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev f3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
04:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a1)

2.748215] sata_nv 0000:00:07.0: version 3.5
2.748274] sata_nv 0000:00:07.0: setting latency timer to 64
2.748322] scsi0 : sata_nv
2.748407] scsi1 : sata_nv
2.748434] ata1: SATA max UDMA/133 cmd 0xd080 ctl 0xd000 bmdma 0xc800 irq 10
2.748437] ata2: SATA max UDMA/133 cmd 0xcc00 ctl 0xc880 bmdma 0xc808 irq 10
2.749101] sata_nv 0000:00:08.0: setting latency timer to 64
2.749126] scsi2 : sata_nv
2.749165] scsi3 : sata_nv
2.749191] ata3: SATA max UDMA/133 cmd 0xc480 ctl 0xc400 bmdma 0xbc00 irq 11
2.749194] ata4: SATA max UDMA/133 cmd 0xc080 ctl 0xc000 bmdma 0xbc08 irq 11
3.051949] ata3: SATA link down (SStatus 0 SControl 300)
3.201900] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
3.219988] ata1.00: ATA-7: WDC WD3200AAKS-00SBA0, 12.01B01, max UDMA/133
3.219991] ata1.00: 625142448 sectors, multi 16: LBA48 NCQ (depth 0/32)
3.226313] ata1.00: configured for UDMA/133
3.226395] scsi 0:0:0:0: Direct-Access ATA WDC WD3200AAKS-0 12.0 PQ: 0 ANSI: 5
3.226536] sd 0:0:0:0: [sda] 625142448 512-byte logical blocks: (320 GB/298 GiB)
3.226575] sd 0:0:0:0: [sda] Write Protect is off
3.226578] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
3.226598] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn’t support DPO or FUA
3.226701] sda: sda1 sda2
3.234372] sd 0:0:0:0: [sda] Attached SCSI disk
3.528779] ata2: SATA link down (SStatus 0 SControl 300)
3.831671] ata4: SATA link down (SStatus 0 SControl 300)

Now in the openSUSE 11.3 installation DVD it shows that the sata_nv module is loaded, but the kernel output doesnt have anything with sata_nv. If I do an rmmod sata_nv and then an insmod sata_nv, I do get output in the kernel output console but still doesnt find any hard disks in the installation.

Did you do this:

Have you, or are you able to try the DVD in another computer?

I did the check installation media and it all came back just fine. I dont have another system that I can load the DVD with, but I can load it into a VMWare PC and see if it gets similiar results. The DVD image I used came from using the BitTorrent download option with 64-bit.

There are some options to try too such as:

Safe Settings or No ACPI

I tried all the options under the Kernel and all result in the same. I’ve even tried to use the openSUSE-11.3-NET-x86_64.iso image. Some more information that might be useful, in the Kernel Messages I see an entrys of:

  4.176947] ata1: failed to resume link (SControl FFFFFFFF)
  4.176956] ata1: SATAlink down (SStatus FFFFFFFF SControl FFFFFFFF)

And I get similiar messages for ata1 through ata6. I dont get these messages in the working openSUSE 11.2 system.

Would you consider trying a live cd, one of the newer rebuilds of KDE?

I’m open to trying anything at the moment. I’ve even considered trying the i386 version instead of the 64-bit version.

Which one would you suggest?

I have tried the openSUSE-11.3-GNOME-LiveCD-i686 that I put on a 4gig USB thumb drive. This started to boot, and then next time I looked over had complained about missing something and rebooted after waiting the 120seconds. I had booted this thumb drive on another computer without a problem roughly 3 hours prior.

I’ll give the KDE ones a shot and see if those have any better luck.

“KDE Four Live” and “KDE Reloaded” CD images](

Well, finding out more information. The KDE Reloaded and the KDE Four Live images will not boot when written to a USB thumb drive on this system. However, I can take them and boot my laptop with them without a problem.

Now, for fun, I burned the KDE Reloaded image to an actual CD, and it boots from that. However, it still doesnt find any hard drives. The only thing it finds is the CD drive that is still on the IDE channel. It doesnt see the nForce Ethernet card, any SATA hard drives, and also doesnt seem to recognize any USB devices when plugged in.

Was the whole NVidia nForce chipset scrapped between the kernel (2.6.31) that was part of openSUSE 11.2 and the current kernel (2.6.34) thats part of openSUSE 11.3?

Some new information here. I burned the iso for openSUSE-11.3-DVD-i586.iso, put it into the system, and it boots and finds the SATA drives without a problem. So it appears, this issue is somehow linked to the x86_64 version of openSUSE or the x86_64 kernel 2.6.34.

The system I’m running is an AMD Athlon 64 X2 Dual Core Processor 5200+, and the existing openSUSE 11.2 system is the x86_64 processor.

I’m running is an AMD Athlon 64 X2 Dual Core Processor 5200+

So am I
No problem with _64

I wouldn’t worry unnecessarily about using 32bit, it will be more than adequate

Yea, I’m sure 32-bit would be ample, but your assuming I’m erasing everything I compiled and use in my 11.2 system which is currently 64-bit.

Anyhow, I’ve also been testing/playing with the 2.6.36 kernels for 11.2 found at Index of /repositories/Kernel:/HEAD/openSUSE_11.2, and those have the same boot issue with 64-bit and the sata_nv that the 11.3 installation has. Next step, is to grab a kernel from and compile a custom one specific for my system and see if the new 2.6.36 base kernel has this issue.

In your 64-bit AMD system, are you also using SATA drives and is your motherboard using the nForce chipset?

In your 64-bit AMD system, are you also using SATA drives and is your motherboard using the nForce chipset?
Yes and Yes

Perhaps you should stick with 11.2

That would take the fun out of troubleshooting this problem and besides, I find it hard to believe I’m the only one that’s having a problem.

So if you like troubleshooting - Try 11.4 M2
I have it (kde4) and it’s trouble free but many complain kde didn’t boot for them, but Gnome did.
You don’t have to install it. It’s just a different kernel… see how it is for you

I’ll give that a shot tomorrow. Although, I’m not a big KDE fan I have prefered GNOME since Helixcode did a version a few years ago when Evolution was still in beta. KDE just seems to be too bloated for my taste every since I first played with it in SuSE 5.1.

So use Gnome because most folks found it worked better anyway.

In your 64-bit AMD64 system, are you using the NVidia Driver for graphics Is your motherboard an Intel one or an NVidia one? Only reason I ask, I found the following link referring to an issue with NVidia Mobos that started with Linux Kernel 2.6.32, and the openSUSE 11.2 system I use still runs 2.6.31 which might explain why it works in 11.2 and not in 11.3, well atleast not with a the kernel provided with 11.3. I’m currently building a 2.6.31 kernel and plan on doing a zypper dup to go to 11.3.;a=commit;h=a858b15b88214c7bf918eac57d5debbdd60fffa8

ASUSTeK Computer Inc. - Motherboards - ASUS M2N4-SLI

Yes it’s nVidia and I use a nVidia 8500GT Graphics card with the nVidia driver

And now, to round this all off. I did a Bios update to this MOBO with the Nvidia nForce (MSI K9N4 SLI) taking it from Version 1.0 to 1.5, and now the boot issue no longer exists. Boots the new Kernel 2.6.34 thats provided with openSUSE 11.3 just fine now.