OpenSuSE 11.3: HDA Intel sound no longer works

Since upgrading to OpenSuSE 11.3 I no longer have sound.

I followed the steps on SDB:Intel-HDA sound problems - openSUSE
but in the end I get:

thiscomp:/home/me # rcalsasound restart
ALSA lib conf.c:3601:(snd_config_update_r) Cannot access file /etc/alsa-pulse.conf
ALSA lib control.c:902:(snd_ctl_open_noupdate) Invalid CTL hw:0
/usr/sbin/alsactl: get_controls:552: snd_ctl_open error: No such file or directory
Shutting down sound driverALSA lib conf.c:3601:(snd_config_update_r) Cannot access file /etc/alsa-pulse.conf
ALSA lib seq.c:935:(snd_seq_open_noupdate) Unknown SEQ default
can't open sequencer
Starting sound driver:  hda-intelsh: /sys/bus/pci/drivers//sys/bus/pci/drivers/HDA Intel/new_id: No such file or directory
FATAL: Error running install command for snd_hda_intel

I remember having the same prob upgrading to 11.2, but for the moment, I’m at a loss. Some pointers would be highly appreciated.

After installing the alsa-pulse rpm’s I still get:

thiscomp:/home/me # rcalsasound restart
Shutting down sound driver                                                                                                        done
Starting sound driver:  hda-intelsh: /sys/bus/pci/drivers//sys/bus/pci/drivers/HDA Intel/new_id: No such file or directory
FATAL: Error running install command for snd_hda_intel

I would like to try and help, but I am not smart enough to understand what you posted and apply that to a specific solution.

So if you are willing to let me try help, please remove ALL custom settings that you may have applied for audio. Please put EVERYTHING for audio/sound back the way it was after the initial install.

Then reboot and then please provide the information that is recommended to be provided in our multimedia stickie: Welcome to multimedia sub-area and I will make this easier and quote the salient parts for you from that stickie:

please post in this … sub-forum, providing in your post the following information:


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/ --no-upload

and post the file /etc/alsa-info.txt it creates to and press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “” … when you run:


you should get something like this (if it asks for an update, select NO):](ImageBam)

followed by this (select the SHARE/UPLOAD option):](ImageBam)

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :](ImageBam)

followed by this (where in RED is the URL).](ImageBam)

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/ --no-upload

which will create the file /tmp/alsa-info.txt. Copy that file and paste it on and press submit. That will give you a URL address. Please post that URL here.

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or newer
    , in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here>

alsa-info gives

thiscomp:/home/me # rpm -qa '*alsa*'
thiscomp:/home/me # rpm -qa '*pulse*'

thiscomp:/home/me # rpm -q libasound2
thiscomp:/home/me # uname -a
Linux basicsaint #1 SMP 2010-10-07 19:07:51 +0200 i686 athlon i386 GNU/Linux

and last:

thiscomp:/home/me # cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel
# CvwD.Rah7M_6kKJE:MCP61 High Definition Audio
alias snd-card-0 snd-hda-intel

Many thanks again of course.

Before we go any further, please check this for me … I note this in your mixer:

!!Amixer output

!!-------Mixer controls for card 0 [NVidia]

Card hw:0 ‘NVidia’/‘HDA NVidia at 0xfe028000 irq 23’
Mixer name : ‘Realtek ALC861-VD’
Simple mixer control ‘Master’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
Playback channels: Mono
Limits: Playback 0 - 64
Mono: Playback 60 [94%] -4.00dB] [off]
The mute is set in your master volume control and that will stop sound. Please unmute that and again test!

If that does not work, please advise and I’ll check the rpm list you provided.

Also, when testing your sound, try each of the following in a terminal, first as a regular user and then with root permissions:

  • first:
 speaker-test -Dplug:front -c2 -l5 -twav
  • second, try again:
speaker-test -c2 -l5 -twav
  • third:
speaker-test -c2 -D hw:0,0 -t wav -l3
  • fourth, this next command has a volume meter at the bottom of its output with a changing number of #'s and %'s to show volume levels so run this command and tell me if the number of #'s and %'s are changing:
aplay -vv /usr/share/sounds/alsa/Front_*
  • fifth: and also:
aplay -vv /usr/share/sounds/alsa/test.wav

Do any of those give an indication of sound ?

Also try those with and without headphones.

Note you only need JUST 1 of those to work, to confirm your sound is functional and that the driver is working. At which time we need then to check desktop setup and/or application setup.

Right now, I feel very stupid.
Unmuting sound did the trick (OMG, what am I saying).

rcalsasound restart still gives the same errormsg but yast sound now plays the testwav everytime.
Anyways, thanks.

Excellent! Glad to read you have sound.

My card is an 82801JI ICH10 Family HDA

Just setting model=no-jd and rebooting, sound works in suse 11.3 and 11.4

The ‘no-jd’ boot option is ONLY for very specific hardware audio codecs. The HD-Audio-Models.txt file indicates it is ONLY for some implementations (not all) of the STAC9227/9228/9229/927x and STAC92HD73* . Hence unless one has one of those hardware audio codecs, that option will not likely help.