OpenSUSE 11.3+Broadcom4312= No Joy

I’m having an issue with my broadcom wireless that is using the bcm4312 driver. I installed the b43(?) cutter firmware from the command line and now my network is detected but it just won’t actually connect to it. My router has wpa security enabled but i think it worked with it before. Can anyone help?

Seems like it’s not staying loaded either…Anyone?

I can tell you it does work, but I’m still using the wl driver from Packman because it’s way better.

Hi caf! Thanks for the reply…I forgot about wl…I see there are several wl items listed. How do i install this? I have a pae enabled laptop so do i install that one? It seems last time i installed wl on opensuse i had to do more than one of these…



From a su - terminal the code is

zypper in broadcom-wl broadcom-wl-kmp-pae

Got it installed but now i seem to have lost my wireless. The tap is all grayed out. Did i do something wrong? How can i get it back?

First off, did you reboot?
Second, if it’s still not working you may need to remove the b43 driver or blacklist it.

I did reboot and i removed the b43 driver. The wireless and the mobile tab are grayed out and the other tabs have nothing in them. Even the wired tab while i’m connected to a wired network.

Please post result of

uname -a

Here you go…

ron@linux-5fo4:~> uname -a
Linux 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 i686 i686 i386 GNU/Linux

ugh…i feel like such a dolt LOL

You have kernel-default!
Switch the package broadcom-wl-kmp-pae
to broadcom-wl-kmp-default

arrrgh…okay i’ve gotten it back somewhat…now i have the wireless tab but when i click on the icon in the notification area by the clock now that wireless is grayed out…

What do you have now with this

**/sbin/lspci -nnk
please just post the wireless bit, near the end usually

0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
        Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
        Kernel driver in use: wl

Can you click Create New Wireless Network?

Do you mean “add” in the wireless tab? I click it and the window comes up to make a new wireless connection but then it doesn’t detect any networks. And i’m sitting right next to my router…

Then you are missing something obvious.
Dare I even mention: Do you have your wireless switch ON

LOL I do have it switched on…I just don’t know what i could be missing…grrr

I’m back home now
Are you still struggling with this?

Hello hello…Well actually i messed around with it for a bit longer then just did a fresh install since it was a fresh install to begin with LOL … Thanks for all your help!