Opensuse 11.2 y No sound

I Have just installed opensuse 11.2. It is extraortdinary, but there is no sound. My system is an Asus AMD Athlon Motherboard M2N68-CM and ViaHDAudio. Could anyone help me to make it work?

Check the sound preferences to see which output device it is using.

I typically recommend users try to work their way through this troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

Most new users simply forget to turn the PCM setting in their mixer up to a high setting, or they try to play some multimedia file to which they do not have the codec, and from that draw the wrong conclusion.

Please do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is “kmix” (the small speaker in right hand corner). In Gnome your mixer is “alsamixer”.

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will ask you if you wish to share the information (select YES) and it will post its output on the Internet/web. And when finished it will give you the URL of the web site where the information is posted. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa ‘alsa
rpm -qa ‘pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a detailed recommendation. (but try the alsa-firmware installation/reboot first)

Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

Problem solved. Thank you very much for your help and for your pacience. I am very grateful to this forums, because It is the first time with opensuse.
Thanks a lot

Great !! Congratulations, and welcome to our forum.

I have a similar problem with sound. I don’t even know how to start a new thread so I posting here:

installed SUSE 11.2
I have sound when I play youtube clips or cnn clips
I did the Yast sound test and it works.
I have no sound when I try to play a CD.
I have no sound when I try to play an mp3 from a USB stick.

Do you have sound when you try to play mp3 from your hard drive?

What application are you using to try to play sound?

What application are you using to try play a CD?

Are you using gnome or KDE ?

I am not sure what the problem was; I had no sound and I could even get any multimedia player to play a CD or DVD or mp3.

I have followed the steps described at multimedia guide for SuSE 11.2. and installed all the additional packages listed there.

The amarok and other players started playing CDs but still no sound. The I found in another forum someone suggesting using xine-ui to select the alsa driver. After doing that I had sound in xine player and vlc. Still no sound in amarok or banshee. I am OK now as I only need one working media player; so I removed amarock and banshee and smplayer and others recommended at the above mentioned link.

Reference Amarok it is moving from version 1.4 to a newer version 2.x. I have read of some users having problem with the newer version. I now use 2.1. I have the packman libxine1 and Novell amarok installed and when I first ran amarok-2.1 the mp3 sound did not work (for less than a minute). So I went in its settings and configured it to use the appropriate sound device, and it just worked.

Smplayer “just worked” for sound upon install, although I note my 32-bit openSUSE PC’s have problems playing .wma files, while my 64-bit do not (with Smplayer/mplayer).

Note the PCM volume control is dynamic, and when you start a new multimedia application you may need to adjust the PCM volume levels in the mixer.

… anyway, you have mp3 sound now. Glad to read its working.

I just wanted to give some positive feedback:

I had a similar problem (no sound in Youtube), and the directions given in this thread helped me solve the problem (PCM at 0).

Thank you very much!