Opensuse 11.2 nfs issues "Unable to mount the NFS entries from /etc/fstab"

first off im a trying to finally relieve myself of windows. i’ve previously tried ubuntu, kubuntu and have now settled on opensuse because it’s kde and it seems to work fine on all three of my computers. k/ubuntu had video issues with my desktop.

so, before deleting my windows partition i made myself a list of functions i wanted to get working on opensuse, network file sharing was one of those items.

so here’s what i have…

-i decided to opt for nfs rather than samba as i no longer plan to have my computers interacting with any windows units. in the event that changes some day, then i’ll get samba up and going. until then i want to use nfs.
-all my computers on my network are set to a static ip via my router
-firewall is off on both computers (laptop still has w7 on it, only the desktop and netbook have been changed overs so far)
-i used the gui nfs server setup on both the desktop and netbook of which they both seemed to work fine with no errors
-the issue i have is on the client side of the setup. i used the gui nfs client setup on both and was unsuccessful on both. the gui client finds the server on the other computer, finds the exported folder and mostly works fine. however when i press the “Ok” button to complete the setup it returns the error of “Unable to mount the NFS entries from /etc/fstab”. so i checked my fstab and everything seems fine on it.

fstab:
/dev/disk/by-id/ata-FUJITSU_MHZ2160BH_G2_K60HT9238D47-part3 swap swap defaults 0 0
/dev/disk/by-id/ata-FUJITSU_MHZ2160BH_G2_K60HT9238D47-part1 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-FUJITSU_MHZ2160BH_G2_K60HT9238D47-part2 /home ext4 acl,user_xattr 1 2
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
192.168.2.3:/home/cobbs /home/cobbs/Netbook nfs4 rw,suid 0 0

originally i used the “default” option, but that of coarse still returned the same error. also, if i use the terminal to manually mount the folder, even immediately after receiving the error, it will mount fine and i can browse the folder without problem.

i just want to know why i’m getting the error and how to get the folder to automount upon boot.

if you need any more info just let me know. but be aware that i’m still very noobish to linux/opensuse so you will likely have to hold my hand.

thanks in advance

oh, and before i get any flame-age, i have googled my butt off trying to find a solution to my problem. obviously, i haven’t found it.

This may have somethiig to do with nfs4. I can not find the details atm, but it has something like you have not to mention the whole path of the exported directory, but only the directory itself. That would make:

192.168.2.3:/cobbs /home/cobbs/Netbook nfs4 rw,suid 0 0 

Try ‘nfs’, not ‘nfs4’.

I read through your post again and again, trying to skip all the talking about why you want to use NFS :wink:

if i use the terminal to manually mount the folder, even immediately after receiving the error, it will mount fine and i can browse the folder without problem.

I am not sure I understand this correct. Are you saying that you mount the NFS exporrt on the intended direrctory, that it then comes with the error and that you then nevertheless can cd inside* /home/cobbs/Netbook* and see/open/read/write what should be there?

I think what we are missing is following:
. the contents of /etc/exports on your NFS server;

. What happens when you do

mount /home/cobbs/Netbook

(cut and paste and put between CODE tags);

. the output of

mount

(after, but also before the above mount /home/…)

BTW, entries in /etc/fstab are normaly mounted at boot (that is were /etc/fstab is for). This is not ‘automount’, automount is something different.

EDIT: and I interprete Lazy_Kent’s remark as: Are you sure you are using nfs4 on the server?

well, here’s where i am. i went back through both the server and client gui’s and unchecked the nsfv4 option. whilst i still get the fstab error, it now works on both ends.

and yes, after receiving the error i could still use terminal to mount the folder and then immediately browse, etc. via dolphin.

this is my exports folder:

/home/cobbs	*(rw,root_squash,sync,no_subtree_check)

heres the output of mount:

cobbs@Desktop:~> mount
/dev/sda1 on / type ext4 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda2 on /home type ext4 (rw,acl,user_xattr)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
192.168.2.3:/home/cobbs on /home/cobbs/NFS (Netbook) type nfs (rw,addr=192.168.2.3,nfsvers=3,proto=tcp,mountproto=udp)

like i said though, despite the error all seems to be working fine so far, even after reboots on both ends. however, if a solution to the error can be attained id still like to know what causes it.

Thanks for some of the output I asked for. But I am sorry, I still do not get the full picture. Among other things, from you fstab it has to mount on* /home/gobbs/Netbook* and from your mount output it is mounted on* /home/gobbs.NFS*. ???
Also I have the idea that you changed your fstab entry because of the fs parameters I see, when yes the show it please!

In fact what I want to see is an unbroken sequence, starting from the beginniing, showing:
a) by mount that it is not mounted;
b) you first trial to mount it and that gives the error (I still do not get what you do there and where you get the error);
c) showing by mount what the status is;
d) your ‘mounting by hand’;
e) again mount to see the status.
the mount statements for the status may be changed to

mount | grep cobbs

too shorten the output.

To repeat, that would be: first atain the situation before you habitualy get the error, then

mount | grep cobbs
The way you mount getting the error
mount | grep cobbs
mount -a
mount | grep cobbs

yes, i forgot to mention that i rename the mount folder on the client side. it is now named (NFS) Netbook . i should have mentioned that.

Please post /etc/exports from the servers, and /etc/fstab from the clients. To start with, this is what is should look like for an errorless NFS.
The client’s fstab:
192.168.1.100:/disk/Download /disk/Download nfs defaults 0 0
The server’s exports:
/disk/Download *(rw,root_squash,sync,no_subtree_check)

That’s all. If /disk/Download needs other permissions, change them by ‘chmod’. After changes do a:

su -c ‘rcnfsserver restart’
on the server side.

i removed the client via the gui to simulate me never having set this up.

ran

mount | grep cobbs

in console and it did nothing

here i went through the gui process:
http://i108.photobucket.com/albums/n7/noremacyug/snapshot2.png
http://i108.photobucket.com/albums/n7/noremacyug/snapshot3.png
http://i108.photobucket.com/albums/n7/noremacyug/snapshot4.png

ran

mount | grep cobbs

again and here is the output:

Netbook:/home/cobbs on /home/cobbs/NFS (Netbook) type nfs (rw,addr=192.168.2.3,nfsvers=3,proto=tcp,mountproto=udp)

whilst i get the error, all works fine.

this is the exports:

/home/cobbs	*(rw,root_squash,sync,no_subtree_check)

and this is the fstab regarding the nfs mount:

Netbook:/home/cobbs	/home/cobbs/NFS\040(Netbook)	nfs	defaults 0 0 

Now as I see it:

  1. You can mount your fstab entry with the mount command. Do you need more?

  2. Reboot and see if it mounts on reboot. When yes, you are finisished.

What still is a bit strange is the error YaST produces. But as everything works and the fstab looks OK, who worries?

BTW, until your last post there was not even the slightest hint that you used YaST and that YaST produced the error!

i said that i used the gui’s to setup both the server and client side of things. it didn’t register to me to mention yast. :slight_smile: anyhow, things have gone awry and it has now ceased to start after a reboot. i can go through yast and redo the client gui and it will immediately work. but after a reboot i’m dead in the water again.

i searched a bit and read something about the possibility of the nfs server/client starting before the network has initialized. so i tried the _netdev option (i believe it was). unless i implemented it incorrectly, it didn’t help a bit. i also saw something about run levels causing that same scenario, but that’s all greek to me and i dare not fool with them without guidance.

so, after much, much, much frustration i think i’m ready to try samba.lol! i’ve fooled with it some tonight and got it close to working, but not quite. all the how to’s seem to focus on setting it up to access a windows network. i tried to find a tutorial that uses yast’s samba setup gui’s, as they are so much easier for me to understand and remember what i did, but i haven’t seen one.

soooo, if anyone has any super bright ideas on the nfs issue that might get it working again, i might try it. but if samba will do the trick and is pretty easy to setup, i’ll be just fine with that…provided some one can tell me how to set it up.

as always thanks for your replies and more importantly…your patience.:slight_smile:

You talk about the network being not ready before the mount is done.

That would be possible if you do not have a normal network setup (known in YaST as “traditinal with ifup”, but are using Network Manager. Because in the case of Network Manager your network is of course NOT started at boot (on reaching runlevel 3 or 5), but only after a user logs in (and even then he may not start the network).

well I just read that and was throwing that out there. I initially was using network manager, but it seemed flakey so I swithed back to ifup.

What of samba? Difficult?

For SAMBA there is a very good doc written by Swerdna: Linux HOWTOs and Tutorials: Suse Linux 10.0, 10.1 openSUSE 10.2, 10.3, 11.0, 11.1

thank you very much. i have samba up and running and seem to be able to reliably browse networked directories. thanks for all the help everyone!!!

if you are trying to export nfs4, then follow these instructions:

on nfs4 server (server ip 192.168.71.101):
/nfs_exports *(fsid=0,crossmnt,rw,root_squash,sync,no_subtree_check)
/nfs_exports/home *(rw,root_squash,sync,noexec,no_subtree_check,bind=/export/home)
/nfs_exports/projects 192.168.71.100(ro,root_squash,sync,no_subtree_check,bind=/export/project)

On nfs4 client (in /etc/fstab):
192.168.71.101:/ /import/nfs nfs4 defaults,soft 0 0

so in nfs client you don’t specify path to the exported dirs, but to pseudo, which is in my case /nfs_exports. nfs4 will dump anything in /nfs_exports dir to /import/nfs/

if you configure both system as above, you should see export “home and projects” on the client system inside /import/nfs directory.

I hope this helps!

Vayanga