Opensuse 11.2 network connection trouble

Hello
I used OpenSUSE 11.1 and network connection was fine.I installed Opensuse 11.2 and it seems to me that Yast and web browsers can’t connect to the network using IP names.
Some details follow:
_on terminal I can ping IP names, network OK.
_Firefox, Konqueror, Yast can’t connection to the network.
_But if I use IP addresses instead of IP names with Firefox and Konqueror network connection works.
_I disabled IPV6 and delete /etc/resolv.conf, booted PC but it still fails.
Can you help me?
Thanks in advance

First of all verify that your network is set up properly. Are you using networkmanager or traditional ifup/ifdown (via Yast)?

From a terminal, can you check the output of the following commands?


/sbin/ifconfig
/sbin/route
cat /etc/resolv.conf

Thanks for your fast answer.
I installed OpenSUSE 32 bit. I first used ifup, after NetworkManager configuration but the result was the same.
Command output follows:
giorgio@linux-fsvg:~> /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:17:D6:E1:67
inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::216:17ff:fed6:e167/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1227 errors:0 dropped:0 overruns:0 frame:0
TX packets:1335 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:150656 (147.1 Kb) TX bytes:117311 (114.5 Kb)
Interrupt:23 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:102 errors:0 dropped:0 overruns:0 frame:0
TX packets:102 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6932 (6.7 Kb) TX bytes:6932 (6.7 Kb)

giorgio@linux-fsvg:~> /sbin/route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 1 0 0 eth0
default Broadcom 0.0.0.0 UG 0 0 0 eth0
giorgio@linux-fsvg:~>

giorgio@linux-fsvg:~> cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

nameserver 192.168.1.1
giorgio@linux-fsvg:~>

All entries are looking OK to me. What I doubt now is that whether the router is actually connected to the Internet or not.
Can you log into the router and see the situation there?
From any browser, connect to it via http://192.168.1.1

There is a major difference between 11.1 and 11.2: 11.2 now has IPV6 enabled as default! If your router doesn’t support IVP6 you have to disable IPV6!
Just pass ipv6.disable=1 when you boot and change /boot/grub/menu.lst accordingly so you don’t have to pass his option every time you boot your SuSE 11.2.

Hello
thanks again, network connection is Ok, the router is working properly. With OpenSUSE 11.1 all ok, with OpenSUSE 11.2 only using IP addresses instead of IP names on Firefox I can reach Internet. My router is D-Link DVA-G3670B,I was not able to know if IPV6 is supported, perhaps not.
According to your suggestion I changed /boot/grub/menu.lst adding ipv6.disable=1, I booted PC but nothing changed.
My /boot/grub/menu.lst follows:

Modified by YaST2. Last modification on sab nov 21 16:06:43 CET 2009

THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader

Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
ivp6.disable=1
gfxmenu (hd0,6)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title Desktop – openSUSE 11.2 - 2.6.31.5-0.1
root (hd0,6)
kernel /boot/vmlinuz-2.6.31.5-0.1-desktop root=/dev/disk/by-id/ata-ST3250820AS_9QE0Z4AJ-part7 resume=/dev/disk/by-id/ata-ST3250820AS_9QE0Z4AJ-part6 splash=silent quiet showopts vga=0x31a
initrd /boot/initrd-2.6.31.5-0.1-desktop

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.2 - 2.6.31.5-0.1
root (hd0,6)
kernel /boot/vmlinuz-2.6.31.5-0.1-desktop root=/dev/disk/by-id/ata-ST3250820AS_9QE0Z4AJ-part7 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
initrd /boot/initrd-2.6.31.5-0.1-desktop

###Don’t change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader +1

Options should be given on the “kernel” line:

kernel /boot/vmlinuz-2.6.31.5-0.1-desktop root=/dev/disk/by-id/ata-ST3250820AS_9QE0Z4AJ-part7 resume=/dev/disk/by-id/ata-ST3250820AS_9QE0Z4AJ-part6 splash=silent quiet showopts vga=0x31a ipv6.disable=1

Also, there was a typo: ivp6.disable=1

Hello
I added ipv6.disable=1 on kernel line, I made poweroff/on PC and router, still fails. I don’t know if I changed menu.lst in a correct way, so it follows:

Modified by YaST2. Last modification on sab nov 21 16:06:43 CET 2009

THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader

Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
ivp6.disable=1
gfxmenu (hd0,6)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title Desktop – openSUSE 11.2 - 2.6.31.5-0.1
root (hd0,6)
kernel /boot/vmlinuz-2.6.31.5-0.1-desktop root=/dev/disk/by-id/ata-ST3250820AS_9QE0Z4AJ-part7 resume=/dev/disk/by-id/ata-ST3250820AS_9QE0Z4AJ-part6 splash=silent quiet showopts vga=0x31a
ipv6.disable=1
initrd /boot/initrd-2.6.31.5-0.1-desktop

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.2 - 2.6.31.5-0.1
root (hd0,6)
kernel /boot/vmlinuz-2.6.31.5-0.1-desktop root=/dev/disk/by-id/ata-ST3250820AS_9QE0Z4AJ-part7 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
initrd /boot/initrd-2.6.31.5-0.1-desktop

###Don’t change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader +1

It should not be in separate line. It should be in the same line starting with “kernel”, after “vga=0x31a”.
Also, remove the incorrect entry “ivp6.disable=1” you inserted earlier.

Hello
I putted ipv6.disable=1 in the right place and removed the previous added one according to your suggestion. But still failed.
Then made the following according according to Ron post Re: [11.2] IPv6 is not Disabled!? :
echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6
and in /etc/sysctl.conf
I added the line net.ipv6…conf.all.disable_ipv6 = 1
After all those changing I checked Firefox and Konqueror, they can reach Internet. Good! Thanks.
But I have still Yast not connecting to
http://download.opensuse.org/distribution/11.2/repo/non-oss/media.1/media
Firefox can get there not Yast. Can you help me on that?

Look at this:

giorgio@linux-fsvg:~> cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

nameserver 192.168.1.1

I bet that 192.168.1.1 which is your gateway does not run a DNS service. Please fix this. Replace it with the IP number of your provider’s DNS server. The do as root: rcnetwork restart

Quite a few of the wireless routers accepts the DNS requests and resolve it for you.
Please verify by doing the following:

nslookup google.com

Hi
my connection is a wired one. Nlslookup messages follows:
giorgio@linux-fsvg:~> nslookup google.com
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
Name: google.com
Address: 74.125.45.100
Name: google.com
Address: 74.125.53.100
Name: google.com
Address: 74.125.67.100

On Sat, 21 Nov 2009 15:46:01 +0000, GioSint wrote:

(…)

> giorgio@linux-fsvg:~> cat /etc/resolv.conf ### /etc/resolv.conf file
> autogenerated by netconfig! #
> # Before you change this file manually, consider to define the # static
> DNS configuration using the following variables in the #
> /etc/sysconfig/network/config file: #
> NETCONFIG_DNS_STATIC_SEARCHLIST # NETCONFIG_DNS_STATIC_SERVERS
> # NETCONFIG_DNS_FORWARDER
> # or disable DNS configuration updates via netconfig by setting: #
> NETCONFIG_DNS_POLICY=’’
> #
> # See also the netconfig(8) manual page and other documentation. #
> # Note: Manual change of this file disables netconfig too, but # may get
> lost when this file contains comments or empty lines # only, the
> netconfig settings are same with settings in this # file and in case of
> a “netconfig update -f” call. #
> ### Please remove (at least) this line when you modify the file!
> nameserver 192.168.1.1

Have you edited manually this file (/etc/resolv.conf)?

Are you using “netwokmanager” to manage the network or are you using
“ifup” method?

Greetings,


Camaleón

Hello, thanks for your answer.
Before I was using Networkmanager and I didn’t edit /etc/resolv.conf. I deleted once according to a post suggestion. Now I changed to ifup and delete again /etc/resolv.conf. Yast still fails. The resolv.conf follows:

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

nameserver 192.168.1.1

On Sun, 22 Nov 2009 19:16:01 +0000, GioSint wrote:

> Hello, thanks for your answer.
> Before I was using Networkmanager and I didn’t edit /etc/resolv.conf. I
> deleted once according to a post suggestion. Now I changed to ifup and
> delete again /etc/resolv.conf. Yast still fails. The resolv.conf
> follows:

AFAIK, there is no need to delete “resolv.conf” :-?

> ### /etc/resolv.conf file autogenerated by netconfig! #
> # Before you change this file manually, consider to define the # static
> DNS configuration using the following variables in the #
> /etc/sysconfig/network/config file: #
> NETCONFIG_DNS_STATIC_SEARCHLIST # NETCONFIG_DNS_STATIC_SERVERS
> # NETCONFIG_DNS_FORWARDER
> # or disable DNS configuration updates via netconfig by setting: #
> NETCONFIG_DNS_POLICY=’’
> #
> # See also the netconfig(8) manual page and other documentation. #
> # Note: Manual change of this file disables netconfig too, but # may get
> lost when this file contains comments or empty lines # only, the
> netconfig settings are same with settings in this # file and in case of
> a “netconfig update -f” call. #
> ### Please remove (at least) this line when you modify the file!
> nameserver 192.168.1.1

Ok. Try to define here your ISP dns server, instead the IP of the router/
gateway. Or better yet, try this:


/etc/resolv.conf
nameserver 208.67.222.222


That IP is the OpenDNS server’s one.

Once you edit this file, save it and run (as root): “rcnetwork restart”
to restart the network service and try to browse the web.

Greetings,


Camaleón

Thanks for your answer
I had to come back to 11.1. When I’ll install 11.2 againg I’ll follow your suggestion

regards Giorgio

What I have discovered so far is that for some reason the NETCONFIG_DNS_FORWARDER keeps changing from resolver (which is the default) to bind.

It will not matter if you have IPv6 enabled or don’t, as soon as you change it to resolver everything works again. That is names are correctly being resolved. What has me troubled is that as soon as I reboot the system the value changes back to bind.

Obviously, there is some kind of bug here. If I leave the value as bind is it failing because bind is not properly configured?

Thanks for your help.

I followed your advice to add the nameserver to resolv.conf and now mine all works. Many thanks.