openSUSE 11.2 Graphics Problem

Hi i am a linux newbie and I have installed openSUSE 11.2 about a week ago. The problem is that whenever I enable Desktop Effects using KWin my mouse starts displaying trails when I move it after I start an application and the application Icon starts bouncing. Also when I try to resize a window the window resizes very slowly. Another problem is that some sort of artifacts are displayed on the screen they are not exactly artifacts, they are like spaces/ lines in the middle of a window. If i use the arrow keys to move my cursor while typing it leaves a trail behind infact its happening right now in this Text box. The thing is this problem is only on Opensuse, I have used Kubuntu and Fedora 12 KDE on the same machine and I didnt have this problem on those Operating systems with desktop effects and all those animations enabled.

I have tried changing the Refresh rate and the resolution in sax2, that didnt work. I have tried to look the problem up on the internet but cant find the solution. I installed all the updates, updated Mesa but that didnt work either. (if you look at the picture you can see the mouse leaving trails) (if you look closely at the bottom left corner there is a line going across the desktop) (You can see the lines in the middle of the dolphin window this also happens when I am watching a video on youtube and when I adjust the volume from the buttons on my laptop a small window appears showing the volume percentage and these kind of lines appear in the middle of the video and window)

My laptop is an IBM thinkpad T40 with 1.5Ghz Pentium M processor, ATI Mobility Radeon 7500 (32mb) and 1gb of ram.

Any help would be appreciated.
Thank you.


I am new here but will try to help.

I see your video card is rather dated and as such it may not be capable of running the effects.

Try running: $ glxinfo ,and post the results.

Look for: direct rendering: Yes (No, possibly)

If you do not have direct rendering you may not have the capability of running the effects.

Good luck

Thank you for the reply. I do have direct rendering as it says Yes on it and the rest of the results are below:

name of display: :0.0
display: :0 screen: 0
**direct rendering: Yes **
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R100 (RV200 4C57) 20090101 AGP 4x x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 7.6
OpenGL extensions:
GL_ARB_draw_buffers, GL_ARB_imaging, GL_ARB_multisample,
GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_ARB_texture_mirrored_repeat, GL_ARB_texture_rectangle,
GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object, GL_ARB_window_pos,
GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_logic_op,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_compiled_vertex_array,
GL_EXT_convolution, GL_EXT_copy_texture, GL_EXT_draw_range_elements,
GL_EXT_fog_coord, GL_EXT_histogram, GL_EXT_multi_draw_arrays,
GL_EXT_packed_depth_stencil, GL_EXT_packed_pixels, GL_EXT_polygon_offset,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_stencil_wrap, GL_EXT_subtexture,
GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
GL_APPLE_packed_pixels, GL_ATI_texture_env_combine3,
GL_ATI_texture_mirror_once, GL_IBM_multimode_draw_arrays,
GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat,
GL_MESA_ycbcr_texture, GL_MESA_window_pos, GL_NV_blend_square,
GL_NV_light_max_exponent, GL_NV_texture_rectangle,
GL_NV_texgen_reflection, GL_OES_read_format, GL_SGI_color_matrix,
GL_SGI_color_table, GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

0x21 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x22 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x63 24 tc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
0x64 24 tc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
0x65 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 None
0x66 24 dc 0 32 0 r . . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
0x67 24 dc 0 32 0 r y . 8 8 8 8 0 24 8 16 16 16 16 0 0 Slow
0x5a 32 tc 0 32 0 r . . 8 8 8 8 0 24 8 0 0 0 0 0 0 Ncon

I forgot to mention one more thing, whenever I play flash videos on youtube or megavideo for example. The video kind of flickers in the beginning, the same artifacts/lines appear and the video plays kind of slow.

I am having the same issue when streaming video etc… in firefox. If anyone figures this out I would love to know. I have a nvidia gforce graphics card.

I have the same annoying problem. I have 11.2 installed on a Lenovo T60, with an ATI X1400. When desktop effects are enabled, and i move windows (also minimize and maximize etc) - i get some traces (lines, garbage) on the screen.

Here is a snapshot:

linux-irk2:~ # lspci | grep -i vga
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400
linux-irk2:~ # glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2

linux-irk2:~ # grep -i AIGLX /var/log/Xorg.0.log
(==) AIGLX enabled
(II) AIGLX: Screen 0 is not DRI2 capable
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_make_current_read
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: enabled GLX_texture_from_pixmap with driver support
(II) AIGLX: Loaded and initialized /usr/lib/dri/

Does anyone know why this happens?

Yes, this was a problem with the “as packaged” radeon driver (and Mesa) with openSUSE-11.2.

For a while, there was a fix on the xorg : x11 repository with updates to Mesa rpm together with the xorg-x11-driver-video and xorg-x11-driver-input rpms fixing the issue. However that repository has gone more cutting edge, and I am not convinced any more it is as compatible with 11.2.

Hence I have no recommendations.

If you pair it with the latest kernel from Kernel:HEAD it is pretty stable in 11.2, as in my case.

But yeah I wouldn’t recommend a new user to linux to do this, unless there’s no other choice.

I’m not new to linux but i need my machine to be more stable than “pretty stable” and so i’m reluctant to switch to HEAD in order to fix a minor cosmetic bug.

Does anyone know exactly what was the problem and what patch fixes it? Maybe i can create new package(s) that just fixes this issue.

I haven’t experience a single problem/crash so far :wink:

i followed the advice - when using Kernel from HEAD and using new xorg - everything is peachy. The desktop is much more snappy and responsive, and most important - no more trails/screen garbage,

The only thing changed is now my synaptics does not behave as before - i cannot drag a window by tapping on it title. I’ll try to figure out why.


I have the same problem with my synaptics. Does anybody know how to solve this problem?