OpenSUSE 11.2 and PRO/Wireless 3945ABG [Golan] not working

My wireless is not working after a fresh install of OpenSUSE 11.2. I cannot connect in KDE or Gnome. I installed cnetworkmanger and I can’t get anything to connect. My wired network card on this laptop has been down for a long time. All I have is wireless. I have to roll back today to 11.1 if I can’t fix it, but I really have been looking forward to 11.2 for some time. This is really a stupid bug to have in supposedly production ready software.

Maybe I should add that in KDE knetworkmanager does not load by itself. I have to load it manually via console every reboot. I get this:

> knetworkmanager
Object::connect: No such signal QTreeWidget::itemDoubleClicked(QTreeWidgetItem*)
Object:: connect: (sender name: ‘twNetworks’)

It puts the icon in the system tray, and annoyingly hides it, so it took me a while to evern realize it was there. When I point my mouse at it, it says “Networking Information Not Available”. When I click it, it says Network Management Disabled.

cnetworkmanager spews out a bunch of errors and finishes by saying it can’t find any .service files.

I configured the device via ‘Network Devices’ in YaST. Hardware info says it is using the iwl3945 kernel driver. Everything was fine in OpenSUSE 11.1 and 11.0. Can someone help me with this?

Thank you in advance.

in case it helps:

# dmesg | grep 3945
   13.393592] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds
   13.393601] iwl3945: Copyright(c) 2003-2009 Intel Corporation
   13.394643] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
   13.394665] iwl3945 0000:03:00.0: setting latency timer to 64
   13.514678] iwl3945 0000:03:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
   13.514687] iwl3945 0000:03:00.0: Detected Intel Wireless WiFi Link 3945ABG
   13.514865] iwl3945 0000:03:00.0: irq 30 for MSI/MSI-X
   14.470416] phy0: Selected rate control algorithm 'iwl-3945-rs'
   33.756238] iwl3945 0000:03:00.0: firmware: requesting iwlwifi-3945-2.ucode
   33.990947] iwl3945 0000:03:00.0: loaded firmware version
 1128.382715] iwl3945 0000:03:00.0: restoring config space at offset 0x1 (was 0x100106, writing 0x100506)

# iwlist scan
wlan0     Scan completed :
          Cell 01 - Address: 00:1D:7E:CE:EB:55
                    Frequency:2.462 GHz (Channel 11)
                    Quality=47/70  Signal level=-63 dBm  
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Extra: Last beacon: 159ms ago
                    IE: Unknown: 00056D68626D73
                    IE: Unknown: 010882848B9624B0486C
                    IE: Unknown: 03010B
                    IE: Unknown: 2A0104
                    IE: Unknown: 2F0104
                    IE: Unknown: 32048C129860
                    IE: Unknown: DD09001018020014000000

# wconfig
wlan0     IEEE 802.11abg  ESSID:"mhbms"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:1D:7E:CE:EB:55
          Bit Rate=54 Mb/s   Tx-Power=14 dBm
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:
          Power Management:off
          Link Quality=47/70  Signal level=-63 dBm  Noise level=-127 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0wlan0     IEEE 802.11abg  ESSID:"mhbms"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:1D:7E:CE:EB:55   
          Bit Rate=54 Mb/s   Tx-Power=14 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:
          Power Management:off
          Link Quality=47/70  Signal level=-63 dBm  Noise level=-127 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

network manager will not connect.

I forgot to post cnetworkmanager output:

cnetworkmanager -c
Traceback (most recent call last):
  File "/usr/bin/cnetworkmanager", line 110, in <module>
    nm = NetworkManager()
  File "/usr/lib/python2.6/site-packages/networkmanager/", line 50, in __init__
    super(NetworkManager, self).__init__(dbus.SystemBus(), self.SERVICE, self.OPATH, default_interface=self.IFACE)
  File "/usr/lib/python2.6/site-packages/dbusclient/", line 40, in __init__
    super(DBusMio, self).__init__(conn, bus_name, object_path, introspect, follow_name_owner_changes, **kwargs)
  File "/usr/lib/python2.6/site-packages/dbus/", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/", line 183, in activate_name_owner
  File "/usr/lib/python2.6/site-packages/dbus/", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.6/site-packages/dbus/", line 622, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files

I’ve had the same issue, even under 11.1, starting with the .9x releases of Knetworkmanager (NetworkManager-kde4) - under the .7x releases everything was fine. I was hopeing the 11.2 upgrade would correct it, but no luck. Never could find a cause in any of the configs (that doesn’t mean I didn’t over look it of course). My “workaround” under 11.1 was to use the KDE3.5 KNetworkmanager, which worked just fine. But I don’t want to add an 11.1 repo under 11.2, so…

Starting knetworkmanager gives:
Object::connect: No such signal QTreeWidget::itemDoubleClicked(QTreeWidgetItem*)
Object::connect: (sender name: ‘twNetworks’)
QLayout: Attempting to add QLayout “” to InterfaceConnectionItem “”, which already has a layout

System info is:
Owl:~ # dmesg |grep iwl
8.470215] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds
8.470312] iwl3945: Copyright(c) 2003-2009 Intel Corporation
8.470542] iwl3945 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
8.470603] iwl3945 0000:0c:00.0: setting latency timer to 64
8.541521] iwl3945 0000:0c:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
8.541571] iwl3945 0000:0c:00.0: Detected Intel Wireless WiFi Link 3945ABG
8.541769] iwl3945 0000:0c:00.0: irq 29 for MSI/MSI-X
8.721456] phy0: Selected rate control algorithm ‘iwl-3945-rs’
28.901394] iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-2.ucode
28.968450] iwl3945 0000:0c:00.0: loaded firmware version
29.037483] Registered led device: iwl-phy0::radio
29.037564] Registered led device: iwl-phy0::assoc
29.037594] Registered led device: iwl-phy0::RX
29.037622] Registered led device: iwl-phy0::TX
Owl:~ # iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:12:17:C0:31:84
Frequency:2.432 GHz (Channel 5)
Quality=53/70 Signal level=-57 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Extra: Last beacon: 1556ms ago
IE: Unknown: 000731303041637265
IE: Unknown: 010882848B962430486C
IE: Unknown: 030105
IE: Unknown: 2A0100
IE: Unknown: 2F0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: DD090010180200F0000000
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

I’m getting exactly same problem. My outputs look practically identical. Can someone advise, please.

My wireless issue wasn’t a problem. I was initially connected through eth0. I then tried to connect using wlan to my home WEP network. It wouldn’t connect even though I could connect to a neighbours insecure network. This was confusing to say the least. Anyway, after I rebooted with the eth0 cable disconnected my wireless connected on boot up no problems.

I would check your WEP/WPA settings. KNetworkManager - openSUSE

Hello everyone,

My codes are the same and I think we have here a driver problem on 11.2. Some brainstorming:

I am running the same wlan card on opensuse 11.1 with success. The only different between both systems is through the KNetwork configuration: on opensuse 11.1 BSSD is never required wich I don’t know exactly if in this case opensuse 11.2 is expecting the MacAdress of my wlan-card and therefore never completes the matching. Anyway I gave the Mac and still doesn’t not response and checked if this could be a firewall problem and disabled on Yast and still not success.

Nevertheless on 11.2 repositories I checked that the iwl3945 is missing on the lists (after adding many repos for 11.2) which this is fully included on the standard repos of 11.1 (after installation’s hardware detection), has someone of the 11.2 team forgot that? or it means this iwl3945 is not longer supported on 11.2???. The only firmwares for PRO/Wireless on opensuse 11.2 are generic and doesn’t solve this issue any way!

For me the only alternative is an upgrade of 11.1 to 11.2 using “yast-wagon” or “zypper” so my 11.1 wlan configuration/functionlity can preserve but I’m afraid it can be lost too since there is really no much technical information of what is exactly upgraded/replaced or deleted from 11.1 that in opensuse 11.2 is not longer needed.

Keep in touch guys, always brainstorming and hope is good!


Augusto Guerrero

I think I’ll try yast-wagon. I’ll post the results here. I don’t think the problem is just with knetworkmanager since I can’t connect in gnome or KDE and I can’t connect with cnetworkmanager (command line client) either.

well I’m posting the result much sooner than I thought I would. I ran yast2 wagon as root, and it gave a segemtation fault and crashed while refreshing repos. I’m not sure if I even used it right, but if I did, it apparently isn’t going to work.

Hello again guys,

Indeed was a problem between KNetwortManager and KDE (specifically with KWalletManager). First of all you need to deactivate this damm program and believe in you for remembering all passwords that you use. I don’t know why, but it is reponsible for allowing/denying your router’s passphrase or configuration into your openSUSE 11.2

The best way of disable this is clicking on starting menu and then over Configure Desktop, then click up on “Advanced” at right. This KWalletManager is part of the programs such as Session Manager, Autostart, Login Manager, Power Management, etc. (KWalletManager is not part of the Yast programs!!!)

There you will see that KWalletManager is also being prompted for your network security which you can delete this line on its “Access Control” below in the three of segments down. I could do this, but I preffered to disable it completely on “Wallet Preferences”

Next step is the most beautiful part: Configuring your wireless internet/LAN. Just after closing KWalletManager (after disabling of course) and then go to “General” onto “Configure Desktop” (Personal Settings) which we already opened before. Then click on “Network Settings” (just above of “Computer Administration” and configure your Network Connection by clicking on “Wireless”. Just put there your router’s config without BSSID (I still don’t know which MacAddress should be there) but it works if you left it empty; only complete the normal SSID, Phassfrase and Encryption KEY and after 8 secs your wireless connection should be up rotfl!

It is important not moving anything in Yast, just discovered that in this case it has nothing to do. Just leave this config as original in there (right like after installing openSUSE 11.2, with NetworkManager as default, etc.)

Now well, like germans say …Frohschaffen!!!>:)

Best regards,

Augusto Guerrero

Well done. :slight_smile: I also realized KWallet was interfering somehow and disabled it, but that didn’t solve the problem for me (it did work briefly). Maybe I didn’t recreate the network connection as you described or something, but after following these steps it connected and is working, even after rebooting! Hopefully it’ll stay that way.

odd… I wonder why I couldn’t connect in gnome either then… or with cnetworkmanager then. I’ll reinstall and give that a try.

Just follow the recommendation of the following link:
openSUSE Lizards » Updating in Place From openSUSE 11.1 to 11.2

Augusto Guerrero ((C:=

I did a basic install from the KDE live cd, disabled kwalletmanager completely, and still could not connect. It tries to connect, and sees the wireless router, but it just doesn’t get there. I’ll try the other method of upgrading to 11.2 that has been mentioned here and see how that works, but for me, this was a no go. 11.1 works fine.

I’ll give that a try sometime today probably.

I need a solution for this. I use Kwalletmanager (Konqueror) on a daily basis, as well as Wireless on a daily basis. So u can imagine the problem this is going to cause for me if I have disabled it.

I finally did get connected. I used the gnome live cd and connected fine. I found out why, after that, disabling wallet didn’t work for me in kde. It was because knetworkmanager defaulted to 128 bit passphrase, and I’m using 40 bit hex. Gnome’s nm applet knew the right authentication method so it worked right off. As for the issue with kwalletmanager, I bet you can just disable it for only wireless as a short workaround instead of disabling it entirely. Following that someone should file a bug for it with the openSUSE team. Once the bug is resolved all of us can test it and provide feedback.

Thats currently what I am doing but its a funny setup cause I use wireless round about the same time I use the Wallet. Ah well.


I have opensuse 11.2. I can connect to WEP networks with no problem.
I had a problem with WPA. I disabled the KWallet and now i can connect to WPA Personal.

The problem is that i still cannot connect to WPA enterprise.
The configurations in KNetworkManager are fine. In windows7 i have no problem connecting to the WPA Enterprise network.

Any idea what could cause this?