opensuse 11.2 and knetworkmanager

uff i’ve tried live distro and knetworkmanager worked perfectly, now, with installed 11.2 knetworkmanager doesn’t connect to wireless… it let you create the connection but it becomes unselectable, any idea?


I had major problems with it as well. The Gnome version of Network Manager works fine though. I read in a thread here that you can tell KDE to use the Gnome version, but I have not booted in to KDE again to attempt this, so I can not verify that it works. This is probably going to be my next task this morning.

It’s worth a shot. I have always been a KDE man, but I am using Gnome till I get this sorted out.

I have exactly the same problem.

My PC is Hasee Q130X - Intel Atom N270 netbook with standard netbook hardware.
everything worked fine on 11.1 (with factory KDE4.3)

Today I’ve made a fresh install of 11.2, but networkmanager (NM) on KDE4 does not allow me to enable wireless - the option is disabled, even though networkmanager clearly identifies the wlan0 interface and it is possible to set up connection properties manually (but scanning is disable also).

I have tried a USB dongle Dlink DWL-G122 (Ralink RT73 module). NM informed of new WLAN inerface, but still the problems remained with new wlan1 interface.

I have also tried the newest versions of NM from Build Service.
“Enable wireless” was not disabled, but neither of my wireless interfaces worked - still no scanning.

By the way, there is also a problem - my wireless device is not listed in Yast internet settings.

Now, I’m afraid, I will have to return to 11.1 :frowning:

Here is my iwconfig output:

wlan0     IEEE 802.11bg  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I too have difficulties with knetworkmanager. It sort of works. What does work is that the program correctly sets the IP address for the wireless. What doesn’t work is the program fails to set /etc/resolv.conf and set the default gateway (route add default command).

I just discovered that the rolling upgrade from 11.1 to 11.2 destroyed my perfectly working wireless network management configuration that was working under KDE4 all along.

To add even more insult to injury, every time I try to configure the wireless stuff, KWallet wants to stick its nose into it. I went through that BS under openSUSE 10.x and thought it was in the past since I didn’t have to cope with it under 11.0 or 11.1, but apparently somebody decided to make my life miserable all over again.

Please don’t preach to me about it being a security “requirement” that will make my system oh so nice and safe. I’ve been working with various kinds of UNIX systems for well over 20 years now, and don’t need that kind of insulting handholding. I just want to use my laptop the way I want to. If I unplug the Ethernet cable, it should default over smoothly to the wireless connection. (I am using WPA2, thank you). And, yes, the blue light is on, so I know the hardware (Broadcom 4311) has been initialized - been there, done that with fwcutter, etc. I shouldn’t have to negotiate with “Kwallet” if I don’t want to (and, no, I don’t want to).

So, who broke what, how, and why and when will it be fixed? (In the professional software community, this is referred to as a regression, in case anyone from SuSE is reading this - it should have been documented as a Release Note at the very least!)

I have a similar problem, KDE4 networkmanager only allows me to ping my router but no internet, via name (Google) or ip address. I have to use Yast to get on the internet. >:(

Guys, if can connect to the internet through Yast or whatever else, apart from Networkmanager, try during boot in Grub menu add additional boot parameter

And everything should work then.

As for my wireless problem, I have solved it, and it appeared to be in and :slight_smile:
In 11.1 I had my wireless enabled whether the hardware wireless LED on my netbook is lit or not. I’ve got used to this behavior and now on 11.2 it has changed. I just have to first enable wireless with keyboard shortcut and everything seems to be OK now :slight_smile:

On 11/15/2009 11:06 PM, Kolyanoid wrote:
> As for my wireless problem, I have solved it, and it appeared to be in
> and :slight_smile:
> In 11.1 I had my wireless enabled whether the hardware wireless LED on
> my netbook is lit or not. I’ve got used to this behavior and now on 11.2
> it has changed. I just have to first enable wireless with keyboard
> shortcut and everything seems to be OK now :slight_smile:

Between kernel 2.6.27 (11.1) and 2.6.31 (11.2), the rfkill switch was
implemented. You will have to use it now, but you can at least disable your
wireless without having to unload the driver.

Ummm, where is the “rfkill switch” (meaning the software parameter - my hardware slide switch is set to the ‘right’ position and the blue light is ON)?

In /var/log/messages, I’m seeing the following, right below the various b43 firmware loading messages:

ADDR_CONF(NETDEV_UP): wlan0: link not ready

I’m also seeing some buzz about this in the Fedora and Ubuntu fora; I have both F11 and F12 installed on different partitions of my plug-in USB drive and have seen NO problems so far and both installations are as up-to-date as possible. I do not have Ubuntu installed, however, since the last attempt to do so resulted in the disappearance of my USB drive’s partition table!

This problem is all the more frustrating because I kept a backup copy of my previous 11.1 installation and have been comparing all(?) of the relevant configuration files and I’m not seeing any differences. So, it’s not like I originally thought that perhaps my settings were somehow lost - they appear to be there, but ignored.

I was able to tell knetworkmanager to stop bugging me about Kwallet by changing the Manage Connections -> Other -> Connection Secrets -> Store connection secrets to “In file (unencrypted)”. However, I do not seem to be able to exercise any other kind of control over my wireless settings with knetworkmanager (probably because the kernel isn’t initializing the interface properly) the way I remember that I could do with knetworkmanager, and I’m reluctant to revert to YaST management of the interface lest I screw up future use of knetworkmanager management (which has happened in the past, meaning a year or two ago).

I installed OpenSUSE 11.2 as I had been waiting for it for awhile and was really excited about it, but then no network wired or otherwise after install … I need an OS/Distro … to just work on install. So for now, I am back to Ubuntu.

Kwallet might cause problems. I’ve disable everything i Kwallet and my wireless now works.


I’m glad yours is working, because I was able to disable the kwallet requirement and it’s still not working. I added a comment to BZ 555658, so hopefully someone will examine this in more detail.

I note that it didn’t work on my from-scratch installation on a USB disk partition, either. However, it’s working correctly on F11 and F12, which has an ‘rfkill_input’ module also loaded, FWIW.

OK, I looked around and found BZ 550907 and 550908, and learned that I needed to tweak the Network Connections in knetworkmanager. The following resolved the problem for me:

Click on the connection that you set up, and edit it.
Click on ‘IP Address’ and then on the small drop-down box in the lower right corner (by default it’s labelled “Basic Settings”). Set it to “Routes”, and then UNCHECK BOTH “Ignore automatically obtained routes” AND “Use only for resources on this connection”. Then click on “OK”, then “Apply” and “OK”.

Then, they suggest rebooting (which I personally prefer, since it’s my laptop), or restarting the network and logging out and logging in.


Thanks to this forum. I also had a similar problem like the above. I had installed opensuse 11.2 with Gnome as well as KDE desktop. The wireless network connection worked fine in Gnome, but in KDE, it would show being connected, but I was unable to browse or use any messenger as the DNS was not getting registered in the /etc/resolv.conf file.

I unchecked the selection in the “Use only for resources on this connection” which was selected by default and after logging out/logging in to KDE again, the wireless network connection now works fine.


N. Sridhar

This has been fixed with NetworkManager-kde4-0.9.svn1043876-1.3.1 in the 11.2 update repo.](

No, it hasn’t. Knetworkmanger has been a disaster in ANY version of KDE4.

I also had a network problem with Suse 11.2 and it was solved by executing the following command

sudo /sbin/netconfig update -f

Not so. Worked fine in the early “re-spin” KDE4 on 11.1; works fine in Fedora12 KDE4…for me anyway ! True it appears to have been problematic for a lot of people with some combinations of KDE4 at some points in some distributions’ lifecycles over the past year, but unfortunately it’s not as easy as it just being a “KDE4” problem.


Disabling the IPv6 did the trick for me. Before that i tried repeatedly removing and installing the NetworkManager, and I also tried removing /etc/resolv.conf, but non of it worked.

I haven’t tested this for any other bugs, like disabling and enable the wireless card. I am just happy that it actually worked.Hopefully there won’t be any other problems.

Hey, just registered an account here because I’ve been following this (and other similars) thread, and finally came out with half a solution that I’d like to share with you and anyone who gets frustrated by the same trouble.

First of all, known bugs are TWO and different:

  • KNetworkManager routes bug.
  • KNetworkManager enable wireless bug.

The first one is, as said in this thread, fixed in the updated release of KNetworkManager.
The question everyone seems to ask is: “how can I get the update since I have no network???”. That is part of the true. Actually, with cable connection at least, disabled IvP6 and given KNetworkManager to manage connections, we DO HAVE a connection to the router.
What we do not have, is a nameserver lookup. So basically, we can not access But if we try with Google’s IP (Google)… Ta-daaaaa!

SO, back to the point: how can we get the update? In YAST, just edit the update repository and change into
As easy as it is. Skip other repos, you’ll be able to get them later, when the net is up and working.

Now just start all the updates from YAST, then reboot.

Ok, we got it: wired connection with DNS lookup.

Now the second bug: we can connect through our cable, but we can not “enable wireless” (grey disabled option on KNetworkManager menu). No enables, no connections.
The funny thing is this is just a non-fixable bug; chances are that if you can not “enable wireless”:
a) you have no wireless adapters connected. > Connect one.
b) you are on a laptop, with wireless adapter turned off. > Turn it on.
c) you are on desktop/laptop with TWO wireless adapters. Maybe the first one integrated (with its own on/off switch), the other just an USB with no switches.

Well, if you’re the C case, take off the USB/PCMCIA adapter, just turn on the integrated wlan, wait 5 seconds and… Ta-daaaaaa! Wireless is up and running.

Still not enabled? Ok, try with “ifconfig wlan0 up”, maybe your wlan adapter is still sleeping. Wait 5 seconds again and… Well, ta-daaaaaa! Wireless is finally running.

Seems like KNetworkManager requires that if ONE adapter has a on/off switch, BOTH adapters have to got an on/off switch, otherwise no chances to enable wireless.

THAT is insane.
Don’t come back to 11.1, just follow the previous lines and you all will be ok. Gonna post this on other threads like this.