OpenSuse 11-1 KDE and xrdp

Hello Community,
I am not very familiar with with LINUX and want to setup my Suse System to be accessed via RDP. This worked fine so far using the GNOME Desktop environment but if i want to use KDE only, rdp is not working. Does anyone can give me help here how to get KDE working with Remote Desktop Protocol. (xrdp is installed for sure)



Are you using rdp to connect to a windows machine? If so, kde uses krdp and not gnome’s grdp. Just install and configure it like you did for grdp.
vnc viewer works fine for connecting to linux boxes and is available for windows clients. Start it from a terminal using the command:
vncviewer ipaddress:1
where 1 is the screen number.

I find for KDE that xrdp works better than vnc. This Xrdp tutorial is for 11.1, might help:
Windows Linux RDP Remote Desktop Connections using openSUSE as Client or Server (terminal server)

Thanks for the tips.

I tried today and if i try to connect to the xrdp server from my windows client i get the following message :

connecting to sesman ip port 3350
sesman connect ok
sending login info to sesman
login successfull for display 10
started connecting
rdpx11 channel is not present

the firewall is open. i have done this days ago using the GNOME Desktop and it worked fine but since i have installed new and decided for the KDE Desktop i have this problem.

do i need to manually modify a config file?

thanks in advance


There’s a bug about that here:

You will see that it’s supposed to be resolved – but perhaps it’s not if you’re using the wrong packages. Can you please execute this command in a console window and post the results back here. The return will show your packages:

rpm -qa | egrep "xrdp|xorg-x11-server-d|xorg-x11-server-r"

Tip: copy/paste it into the console window.

Hi swerdna,

here is whats returned:


thanks again,



The delay is because my Xrdp stopped working and took a while to fix. A different bug surfaced (different from your issue) which I was just now able to fix and am now back on the air with rdp in openSUSE.

Here’s two quotes from the bug report 455880:

I get the same error:
“rdpx11 channel is not present”

But it does work !
I can log in and everything is as it should.

the xorg.x.config.display11 issue should now be fixed in latest package. [the seg fault is a x64 issue that has not been resolved yet.]

you’ll get “rdpx11 channel is not present” when using any RDP client other than
our special version of rdesktop included in opensuse 11.1. it’s not an error,
it just means the normal RDP protocol will be used for rendering instead of our
much more efficient x11 channel.

So if it’s working for you despite the message, no need to worry. But if it’s not working for you and stops at the error, I suggest you add the Nomad Factory repo at Yast → Software → Software Repositories and then use Software Management in Yast to upgrade to these RPMs:

Here’s the address: Index of /repositories/home:/dreveman:/nomad/openSUSE_11.1

Hi Swerdna,

i did what you said. I Included the repo in the Software Repositories and pressed some buttons. I dont know really what i did but after all he replaced a lot of packages. And, TaTa, xrdp is working now. Thanks again for the help.



That music, TaTa, is always the sweetest :wink:

Hi Swerdna,

I have read your tutorial regarding the installation of RDP on Suse.

I am using an x64 11.2 Suse Linux. Although you said it is no longer supported in 11.2 I tried it out anyway.

Surprisingly it worked out, well almost.

I am able to establish a connection to my linux box from my windows mashine. I can even log in, however once i do that, the only thing I see is the connection log.

connecting to sesman ip port 3350
sesman connect ok
sending login info to sesman
login successful for display10
started connecting
rpdx11 channel not present
x11 rdp Server started
the name org.x.config.display10 was not provided by any .service files

I believe I have all the newest repositories… Maybe you can help? You seem like an expert :slight_smile:

I tried VNC as an alternative, but that didn’t work at all… Would be great if you could give me some guidance



Hi maul0r

Some initial questions:

What repositories did you enable? This command will show that quickly and can neatly paste back here in code tags:

zypper ls

Can you paste back here the RPMs with this command:

rpm -qa | egrep "rdp|xorg-x11-server"


thanks for your quick answer, here is the stuff you needed to know:

linux-mt4b:~ # zypper ls
# | Alias           | Name                  | Enabled | Refresh | Type
1 | openSUSE 11.2-0 | openSUSE 11.2-0       | Yes     | No      | yast2
2 | repo-debug      | openSUSE-11.2-Debug   | No      | Yes     | NONE
3 | repo-non-oss    | openSUSE-11.2-Non-Oss | Yes     | Yes     | yast2
4 | repo-oss        | openSUSE-11.2-Oss     | Yes     | Yes     | yast2
5 | repo-source     | openSUSE-11.2-Source  | No      | Yes     | NONE
6 | repo-update     | openSUSE-11.2-Update  | Yes     | Yes     | rpm-md
linux-mt4b:~ # rpm -qa | egrep "rdp|xorg-x11-server"
linux-mt4b:~ # ^C
linux-mt4b:~ #

I can’t find these in my repos for openSUSE 11.2:


Can you give me a link?

I used your tutorial
Windows Linux RDP Remote Desktop Connections using openSUSE as Client or Server (terminal server)

These are the 2 links:

Index of /repositories/home:/dreveman:/nomad/openSUSE_11.1/x86_64

Index of /update/11.1/rpm/x86_64

I see – I didn’t realise you were using 11.1 RPMs

I think the problem is mismatched software. I tried to use the 11.1 xrdp RPMs in openSUSE 11.2, just as you have, and it didn’t work.

I can’t help you get this going.

However I know that VNC does work in openSUSE 11.2. Maybe try to get that going.

mmh i have tried that already, for some reason the connection wont get established… even if i switch my firewall of, my windows pc works just fine, i tried a loopback as well… it just won’t work when i try to connect to my linux mashine

it gives me a weird error message though:

“failed to connect: the process ended successfully” if i translate it…

I enabled remote administration on my linux box, added vnc to the allowed services and i shut down my firewall on my windows pc…

any suggestions on that maybe? :slight_smile:

Hmm, let’s look at a few things:

Turn off this if you have it running: Yast → Network Services → Remote administration.
Reboot to get rid of any running VNC desks

Software: what comes from this command:

rpm -qa | egrep “VNC|vnc”

Firewall: what comes from this:

grep CONFIGURATIONS_EXT= /etc/sysconfig/SuSEfirewall2

you should see the service “vnc”

start a server with this command:

dbus-launch vncserver

Try this internal check from the server: suppose your network card IP is Install RPM vncviewer and run this on the server to see the VNC desk on the server (assuming you started desktop :1, the default):


hey great!

the test seems to work out, if i am supposed to get an x window command line. I can’t test it using my windows mashine right now, but I will asap.

Question though;

would you be able to explain the firewall and rpm command you did to me? (Yes i am a noob)

If you type or paste this code into a console/terminal window:

rpm -qa | egrep "VNC|vnc"

then the list of installed RPMs will be searched for names containing VNC or vnc. They are printed in the window. You copy them back here and I can see what RPMs you have installed relating to vnc.

Regarding this string:

grep CONFIGURATIONS_EXT= /etc/sysconfig/SuSEfirewall2

that’s a command to search openSUSE’s firewall script controller (located in the directory /etc/sysconfig) and to print out the line in the script controller that switches services that are allowed through the firewall. I want to see that line so I can determine whether you’ve correctly opened the ports that allow vnc communications through the firewall.

Also, you said this:

the test seems to work out, if i am supposed to get an x window command line
It seems to me that you’re getting the default xterm window being broadcast. Probably what you want it to have a full Desktop like Gnome/KDE being broadcast. So which are you using, Gnome or KDE?

If you give me that desktop info, plus the two commands I spoke about above, then I can tell you haw to make the right desktop to be broadcast.

Did you not try the ones I had built a while back for a forum

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 6 days 5:15, 3 users, load average: 0.39, 0.69, 0.52
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15